MVA Heads at 15K, 120R - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

Sponsored by Drago's Bike Works

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-26-2012, 08:12 PM Thread Starter
Join Date: Nov 2012
Location: Edgewood, WA
Posts: 38
MVA Heads at 15K, 120R

I have been getting more and more of these coming through but they are mostly new. Now I got a set of MVAs here with 15k on them.

What I found:
Guide wear and oil passing on the exhaust stems. The exhaust valves will not return to the seat unless they are not turned from the original positions when maneuvered by hand without springs. The last 1/2" of the guide, port side, has baked carbon and valves show the same. There is a noticeable trough worn in the top of the exhaust stems. Both front and rear are equally affected.

IMHO these exhausts were headed for seizing, same as the 07 CVO original pre-program heads do. These will be fixed with AV&V bronze manganese guides, .0014 in & .0016" clearance ex and high quality viton seals. Clearances now are .0019-.0024".
Stem seals are K-line.
Deweys is offline  
Sponsored Links
post #2 of 3 (permalink) Old 11-26-2012, 08:21 PM
Life Member
mitchdm's Avatar
Join Date: Sep 2012
Location: NE FL ~ South of Jax
Posts: 1,679
This does not surprise me ~ I have never had a twin cam rear head make it to 41k ~ This experience has been across an 06 SE ultra traded at 93k Rear exhaust Valve guide failed at 40 & 80k ~ a 10 LTD sold at 71k rear exhaust valve guide failed at 30k less than a year old. After the replacment on the 10 I had FM work a set of heads for me & no issues since. I have already sent a set of 110 heads to be reworked since experience has taught me that Next Summer I will need a set ~ All three failures I had were actually cruising done the interstate one on decel ~ turning of cruise to exit ~ and two on accel to pass.

IMO the heads are the overall weak link on the late model twin cams

~Road Glide The only way to Fly ~
mitchdm is offline  
post #3 of 3 (permalink) Old 11-26-2012, 08:28 PM Thread Starter
Join Date: Nov 2012
Location: Edgewood, WA
Posts: 38
I do not see this on any of the late 103 and 96" OEM heads with 7mm valves.
I used to do a "blueprint" package which used the original guides but no more on any of them. I can set the valves tighter and sealing is better on the seat and oil control for the long haul.
Deweys is offline  

Quick Reply

Register Now

In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome