Horn problems - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 09-13-2012, 11:30 PM Thread Starter
Prospect
 
sneederbilt's Avatar
 
Join Date: Aug 2012
Location: westpoint Tn
Posts: 232
Horn problems

The other day I got caught in the rain riding home. As I passed a buddies house on the way in I blew my horn and noticed it sounded sick and very low. Thinking it was the rain had got to it I didn't check it after I got home figuring it would dry out and be ok....wrong. rode my bike to town for an errand last Saturday and noticed horn wasn't working right....any suggestions on where to start looking for problems?
Sent from my SAMSUNG Infuse using Motorcycle.com Free App

I'd rather be judged by 12 than carried by 6
I'd rather be dead and cool...than alive and un cool
08 Anniversary
sneederbilt is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 09-14-2012, 12:22 AM
Life Member
 
Easyryder01's Avatar
 
Join Date: Sep 2011
Location: Long Island, New York
Posts: 2,346
Is it the OEM horn or did you change it out? If it is the OEM horn I can't imagine water being able to get into it but I don't think you can tear it apart to dry it out or lube something. But give it a try pull it off and see if cab shake it and see what comes out. If that doesn't work then put in a warranty claim or I'll sell ya mine....lol

Live, Laugh, Love, or Die Trying !
2011 Road Glide Ultra Merlot Sunglo
Easyryder01 is offline  
post #3 of 12 (permalink) Old 09-14-2012, 07:30 AM Thread Starter
Prospect
 
sneederbilt's Avatar
 
Join Date: Aug 2012
Location: westpoint Tn
Posts: 232
Yes easyryder it is the OEM one.....and thanks for the offer will be greatly appreciated

Sent from my SAMSUNG-SGH-I997 using Motorcycle.com Free App

I'd rather be judged by 12 than carried by 6
I'd rather be dead and cool...than alive and un cool
08 Anniversary
sneederbilt is offline  
post #4 of 12 (permalink) Old 09-14-2012, 08:39 AM
Prospect
 
Jettjocky's Avatar
 
Join Date: Feb 2012
Location: Flowery Branch, GA
Posts: 248
yes the problem is the piece of crap horn, it is the very first thing I replace with airs.

09 O/B CVO....Roller rocker arms, 10.5 pistons, HQ 575 Cams, SE adjustable push rods, Cee B., Rineharts, Mustang, Progressive front & rear, Moto Lights, HD LED Headlights, C & C Seat, Avon Grips,
HOGCOVERS
Jettjocky is offline  
post #5 of 12 (permalink) Old 09-14-2012, 09:09 AM
Life Member
 
DED HD's Avatar
 
Join Date: Jun 2010
Location: Iowa City
Posts: 3,704
Sometimes the horn( inside the cowbell) will move or rotate to a position that causes the horn to 'hurnk' instead of honk. I think its because of the rubber dampener on the back of the horn. Try adjusting the horn and see if it gets it honk back.

'10 Red Custom:
check out my build thread for pix and mods http://www.roadglide.org/showthread....t=GR8FLH+Build
DED HD is offline  
post #6 of 12 (permalink) Old 09-14-2012, 03:47 PM Thread Starter
Prospect
 
sneederbilt's Avatar
 
Join Date: Aug 2012
Location: westpoint Tn
Posts: 232
Thanks ded

Sent from my SAMSUNG-SGH-I997 using Motorcycle.com Free App

I'd rather be judged by 12 than carried by 6
I'd rather be dead and cool...than alive and un cool
08 Anniversary
sneederbilt is offline  
post #7 of 12 (permalink) Old 09-17-2012, 10:22 AM
Newbie
 
RGC2012's Avatar
 
Join Date: May 2012
Location: Orlando, FL
Posts: 23
I had the same problem after riding in the rain on my 2012 CVO RGC.

The problem was solved by removing the horn & shaking 2oz of water out of it, I also placed the horn in direct sunlight for 2 hours & reinstalled. Itís working like new!
RGC2012 is offline  
post #8 of 12 (permalink) Old 09-17-2012, 02:10 PM
Grey beard
 
StephenRG's Avatar
 
Join Date: Dec 2011
Location: Stony Plain, AB, Canada
Posts: 941
Quote:
Originally Posted by RGC2012 View Post
I had the same problem after riding in the rain on my 2012 CVO RGC.

The problem was solved by removing the horn & shaking 2oz of water out of it, I also placed the horn in direct sunlight for 2 hours & reinstalled. Itís working like new!
+1 but then it died again a few weeks later when dry. Warranty replaced it for me.

Stephen

'10 RG "Black Betty"
HQ 103"
HQ 575 cam
SEPRT
16" TRSSC Cee Bailey Windshield
Sancho's Wings
Mustang Seat
J & M Speakers
Drago's True Duals
Apparently not as black as I thought...

StephenRG is offline  
post #9 of 12 (permalink) Old 11-08-2012, 11:54 PM Thread Starter
Prospect
 
sneederbilt's Avatar
 
Join Date: Aug 2012
Location: westpoint Tn
Posts: 232
Well....horn started working fine the night I totaled the bike. 2 black Angus cows decided to be standing in the middle of the road when I topped a rise in the road....missed one anyways

Sent from my SAMSUNG-SGH-I997 using Motorcycle.com Free App

I'd rather be judged by 12 than carried by 6
I'd rather be dead and cool...than alive and un cool
08 Anniversary
sneederbilt is offline  
post #10 of 12 (permalink) Old 11-09-2012, 02:06 AM
Life Member
 
RoadGlideRider's Avatar
 
Join Date: Sep 2009
Location: West TN
Posts: 2,015
Quote:
Originally Posted by sneederbilt View Post
The other day I got caught in the rain riding home. As I passed a buddies house on the way in I blew my horn and noticed it sounded sick and very low. Thinking it was the rain had got to it I didn't check it after I got home figuring it would dry out and be ok....wrong. rode my bike to town for an errand last Saturday and noticed horn wasn't working right....any suggestions on where to start looking for problems?
Sent from my SAMSUNG Infuse using Motorcycle.com Free App
I had mud dobbers built a nest in my OEM horn. It made the horn sound sick.

yaS wa'DIch la'Hom Ho'neH jorDe' vestai-VamPyr
IKRV Hurgh HaP, Ring of Fire Fleet, Order of the Bat'Leth

Vietnam Veteran, PGR, Widow's Son, "lIgh tlhab" (Ride Free)
RoadGlideRider is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome