Electrical Problem Tonight - Page 2 - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 11-09-2012, 06:24 AM
Life Member
mitchdm's Avatar
Join Date: Sep 2012
Location: NE FL ~ South of Jax
Posts: 1,679
Could be a variety of things ~ not sure of the miles but I had a stator go out. This is not that uncommon due to possible issues with the automatic primary chain adjuster. There are issues with the adjuster overtightening and causing the stator to get out of line for a period of time. Sounds like a warranty issue for sure.... I was able to narrow mine down to the Regulator/Stator on my 10 before I took it to the boutique.... Good Luck.

~Road Glide The only way to Fly ~
mitchdm is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome