Throttle lag? - Page 2 - Road Glide Forums
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 21 (permalink) Old 09-22-2012, 02:05 PM
Hangaround
 
navyman's Avatar
 
Join Date: Aug 2012
Location: Cincinnati, Ohio
Posts: 54
Throttle lag seems to vary from bike to bike. I have none.

2012 Road Glide Ultra Ember Red Sunglo
navyman is offline  
Sponsored Links
Advertisement
 
post #12 of 21 (permalink) Old 09-25-2012, 09:42 AM
Newbie
 
taxfree4's Avatar
 
Join Date: Sep 2012
Location: NY
Posts: 3
ECM Recalibration

Before spending money, I had this problem with my 2010 Street Glide, which I replaced with a 2013 Road Glide Custom. Make sure your ECM has the latest update. This applies to ECM's labeled 34245-09 or greater 34246-08A or greater. The Calibration ID I was running was 31882-10B but had it reflashed to 31882-10D, thank you Schoch's Harley, and the problem seemed to disappear. Note: DO NOT install calibrations on ECM/ICM Modules that have been Race Tuned or have Screamin Eagle Performance Parts. I hope this helped
taxfree4 is offline  
post #13 of 21 (permalink) Old 09-25-2012, 11:27 AM
Grey beard
 
rageglide's Avatar
 
Join Date: Dec 2011
Location: San Jose, Ca
Posts: 1,288
Still trying to get used to the TBW on my new 2012. I find it to be both laggy and twitchy. Mostly when opening the throttle or while shifting. I'll have to ask the dealer if they have flashed the ECM to the latest firmware.

I also find the TBW to be twitchy when puttin along in lower gears. Particularly a problem when on rough roads...
rageglide is offline  
post #14 of 21 (permalink) Old 09-26-2012, 08:54 PM
Life Member
 
zemo1017's Avatar
 
Join Date: Sep 2012
Location: Elizabethtown, KY
Posts: 1,788
The first thing I put on my roadie. Huge difference even on a CVO.
zemo1017 is offline  
post #15 of 21 (permalink) Old 11-06-2012, 07:44 AM
Newbie
 
Join Date: Oct 2012
Location: NC, From NJ
Posts: 9
I want to know how the Babe in the linked video changed her sleeve from her left arm to her right, now that's a trick.
farmboy666 is offline  
post #16 of 21 (permalink) Old 12-04-2012, 06:44 PM
Newbie
 
mikeshog's Avatar
 
Join Date: Jul 2011
Location: Gulf Breeze, FL
Posts: 44
Everyone has throttle lag to some degree or another. A tuner will help but there will still be throttle cause from what I am told the TBW will not open up fully until 3000RPM. I have cam'd the bike added a tuner, breather and pipes and after adding the throttle pak I definatly noticed a difference. It causes a hesitation if i jump it too hard once in a while but most times it is a noticable improvement and super easy to install, just make sure and use dialectric (sp) grease to keep the conection solid.

2011 Road Glide Custom
103" Vivid Black w/Blue Tribal
Andrews 54 Cams, PRM Cleaner, Rush Pipes
mikeshog is offline  
post #17 of 21 (permalink) Old 12-04-2012, 06:56 PM
Life Member
 
zemo1017's Avatar
 
Join Date: Sep 2012
Location: Elizabethtown, KY
Posts: 1,788
My '11 CVO had it something fierce. Throttle Pack was the first upgrade I did. Works great.

Red Sled 2011 RGU CVO in Rio Red,V&H Monster Ovals black. V&H Throttle Pack. George's TP relocation bracket. S&S twin tuned intake.
zemo1017 is offline  
post #18 of 21 (permalink) Old 12-04-2012, 08:20 PM
Life Member
 
elbohead's Avatar
 
Join Date: Oct 2012
Location: Rhode Island, USA
Posts: 1,874
My 2012 FLTRX definitely lags from a dead stop. I twist the throttle and release the clutch and, after a couple of seconds it feels like it suddenly "drops" in and then accelerates. Is this what others have experienced? It doesn't happen at any other time. Only when starting from a full stop. I just bought a Power Vision which I was told would correct the problem. Any truth to this?

2012 FLTRX, BBP, 13" MadStad, Fuel Moto Pro Billet AC and 4" Dyno Tuned Jackpots, catless header, DinoJet Power Vision, Horizon Helibars, Iron Aces mount, HD Aileron grips, Ward's cooling fans, Mustang Wide Tripper solo, CD Plasma Rods and LED turns...
elbohead is offline  
post #19 of 21 (permalink) Old 12-04-2012, 09:31 PM
Life Member
 
Harleyagain's Avatar
 
Join Date: Apr 2012
Location: N Dallas
Posts: 1,846
Had it pretty bad as well till I made some adjustments to my PCV. Now if anything it's too sensitive in lower gears. However I can live with it.

Bob
Harleyagain is offline  
post #20 of 21 (permalink) Old 12-05-2012, 05:47 PM
Grey beard
 
rageglide's Avatar
 
Join Date: Dec 2011
Location: San Jose, Ca
Posts: 1,288
Quote:
Originally Posted by mikeshog View Post
Everyone has throttle lag to some degree or another. A tuner will help but there will still be throttle cause from what I am told the TBW will not open up fully until 3000RPM. I have cam'd the bike added a tuner, breather and pipes and after adding the throttle pak I definatly noticed a difference. It causes a hesitation if i jump it too hard once in a while but most times it is a noticable improvement and super easy to install, just make sure and use dialectric (sp) grease to keep the conection solid.
Yeah I hate it when this happens. Drives me crazy. It's limiting the throttle opening based on engine speed, gear and I believe road speed. In the PCV software you can see the factory setting limits in 1st and 2nd gear.

It reminds me of how the traction control works in my wifes corvette. You jump on it and as soon as it starts to get fun, traction control says "NO fun for you!"
rageglide is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome