iSimple - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 11-18-2012, 10:04 AM Thread Starter
Newbie
 
.ShortBus.'s Avatar
 
Join Date: Nov 2012
Location: Maine
Posts: 33
iSimple

Has anyone bought the iSimple from IronAces?

Thoughts ? Pros and Cons?


I just bought my Gilde ... 2012 Pearl Yellow ...
I am looking to upgrade the audio as well..


Thanks ....

Paula
.ShortBus. is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 11-18-2012, 11:07 AM
Life Member
 
Triplej's Avatar
 
Join Date: Oct 2011
Location: Frisco, TX
Posts: 5,299
Use it and the Iphone Mount every time I ride. Works nicely.

2012 RGU / Big Blue Pearl / Woods TW222 Cams / Fuel Moto Ceramic 2-1-2 Headpipe / Fuel Moto 4.5" Pro Touring Mufflers / Fuel Moto Stage 1 A/C / Power Vision Tuner / Heritage Bars / Seat Mod by MCC /Rider and Passenger Bead Riders / BAL Tail Light / 12" & 14" Windvest / Sancho's wings / Iron Aces Phone Mount / Rear Fascia Upgrade / Avon Grips / Mean Mug by Gas Capital Customs


Take OFF! To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click HERE
Triplej is online now  
post #3 of 14 (permalink) Old 11-18-2012, 12:21 PM
Hangaround
 
Join Date: Aug 2012
Posts: 146
I have one as well as the Iron Claw chrome mount. FWIW I have an issue with mine - when I first start the bike and the iphone it will play a song from 1 - 5 seconds, I will hear a tone and it will then skip to another song. after 6-8 minutes it will stop doing this and work fine, UNLESS I ride a bumpy stretch of road.
I downoaded a app that is a player with a 10 band equalizer built in. This problem does NOT happen when I use this other app rather than the built in iphone app. Not sure why.
I just ordered a second isimple cable that I plan on using in my SUV. I plan on testing it out on the bike first to verify that the first cable is bad & then send that one back for replacement.
jrich4411 is offline  
post #4 of 14 (permalink) Old 11-19-2012, 12:04 AM
Grey beard
 
hd4cruzin's Avatar
 
Join Date: Oct 2011
Location: Santa Clarita, CA
Posts: 970
I've had the isimple from Iron Aces for about 10 months. Love it with their mount.

2012 FLTRX BBP
Drago 580 cam, Drago 2 pipe and TTS, 12" Windvest, WO 515
6.5" Focal speakers and Arc 125.2 amp
hd4cruzin is offline  
post #5 of 14 (permalink) Old 11-19-2012, 05:34 AM
Life Member
 
HD_Shock's Avatar
 
Join Date: Aug 2010
Location: Oklahoma - the windy part
Posts: 1,851
Quote:
Originally Posted by jrich4411 View Post
I have one as well as the Iron Claw chrome mount. FWIW I have an issue with mine - when I first start the bike and the iphone it will play a song from 1 - 5 seconds, I will hear a tone and it will then skip to another song. after 6-8 minutes it will stop doing this and work fine, UNLESS I ride a bumpy stretch of road.
I downoaded a app that is a player with a 10 band equalizer built in. This problem does NOT happen when I use this other app rather than the built in iphone app. Not sure why.
I just ordered a second isimple cable that I plan on using in my SUV. I plan on testing it out on the bike first to verify that the first cable is bad & then send that one back for replacement.
You most likely have the "Shake to Shuffle" feature enabled. Turn that off in the music prefs.

-phil

2011 FLTRX 103


VH Dresser Duals | Klock Werks SS | HD Ventilator | Power Vision | Santees 11in Apes | CB SSC Euro 15in
HD_Shock is offline  
post #6 of 14 (permalink) Old 11-19-2012, 05:45 AM
Member
 
Phil_FLTRX's Avatar
 
Join Date: Mar 2011
Location: Central CT
Posts: 616
I think HD-Shock is right. My 1st iPhone used to change songs on me when I jogged. Damn it pi$$ed me off!!! Come to find out the shake to shuffle was on. Now I know.....

2011 Vivid Black FLTRX, 107" Rev Perf, Zippers Thundermax AT, Roland Sands Speed 7 AC, Iron Aces iPhone holder, 8" KW, V&H Duals & Black Widows, DDM HIDs, ARC 6.5's, S.E. ported heads, 30 tooth frt sprocket.


You never see a Harley parked outside of a Psychiatristís office, now do you.....
Phil_FLTRX is offline  
post #7 of 14 (permalink) Old 11-19-2012, 06:45 AM
Prospect
 
Still Grumpy's Avatar
 
Join Date: Sep 2012
Location: Miami Florida
Posts: 277
What's not to Like about it.?
It charges my Iphone while allowing me to listen to Pandora all with one simple connection..
Its a nice clean looking install.

I say do it.

Still Grumpy is offline  
post #8 of 14 (permalink) Old 11-19-2012, 07:42 PM
Hangaround
 
Join Date: Aug 2012
Posts: 146
Quote:
Originally Posted by HD_Shock View Post
You most likely have the "Shake to Shuffle" feature enabled. Turn that off in the music prefs.
I didn't know that feature was an option - thanks Shock! I will still use the other app as having the equalizer does make a difference in the sound quality.
jrich4411 is offline  
post #9 of 14 (permalink) Old 11-19-2012, 09:38 PM
Grey beard
 
dikdark's Avatar
 
Join Date: May 2010
Location: Central PA
Posts: 1,211
I won mine @ SWI and have used it since. Well worth it. Hardest part on the install was sucking the gas out of the tank before taking it off to run the wires. Very clean set up. Highly recommended.

07 RG Vivid Black
FLHX fascia
Stage 1, SE pipes DS baffles,
+2 Sweepers, chrome quickly fading to black
dikdark is offline  
post #10 of 14 (permalink) Old 12-07-2012, 02:40 AM
Newbie
 
Join Date: Oct 2012
Posts: 32
isimple question,.....

a few days ago i got the isimple wiring setup from ironaces too. i was wondering why the instructions say that you have to remove the fuel tank. looks like the tank console is removed anyway in the process. isn't there plenty of room for the wires to lay between the tank and the chrome tank console? from reading the instructions with the great pictures in the install sheets, it looks like it'd be a no brainer that the gas tank doesn't need to be removed. perhaps i'm missing something here.
emwolb is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome