13" shield went on this morning. 125 miles later... - Road Glide Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-03-2012, 09:42 PM Thread Starter
Life Member
 
elbohead's Avatar
 
Join Date: Oct 2012
Location: Rhode Island, USA
Posts: 1,874
13" shield went on this morning. 125 miles later...

I'm so glad i listened when others here advised that I not start a windshield collection and go straight for the MadStad. Installed it in about an hour and then rode around Eastern Connecticut and finally North on I-95 at 80 to 85MPH all the way home. It was a pleasure! I could NOT have enjoyed this ride nearly as much without the MadStad. It does exactly what it's supposed to do and does it amazingly well!
elbohead is offline  
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome