Electrical Problem Tonight - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Troubleshooting for Road Glides

Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #1  
Old 11-08-2012, 07:51 PM
FLTRX372 FLTRX372 is offline
Newbie
 
Join Date: Nov 2012
Location: Redneckistan, Alabama
Posts: 19
Default Electrical Problem Tonight

while riding to work tonight on my 2012 FLTRX, the check engine and battery light came on and the voltage dropped to just above 10 volts. This lasted for about 3 minutes, then the voltage climbed again back to normal and the trouble lights went out. Any ideas?

Chris
__________________
"Those who would give up essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety." -Benjamin Franklin, 17 Feb 1775
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-08-2012, 07:58 PM
Redfish-Joe's Avatar
Redfish-Joe Redfish-Joe is offline
Grey beard
 
Join Date: Sep 2010
Location: Mississippi Gulf Coast
Posts: 1,285
Default

Check all the battery connections. Don't forget the frame ground too.
__________________
2011 FLTRX
Fat Shots Pipes
Wind Vest Windshield
Sundowner seat
Dobeck EJK
Chrome forks
Heritage bars
ISO grips
Cat free head pipes
SE Stage 2 breather
SE 255 cams
Rivera Taper Lite Pushrods
Tour pack
CB radio
More mods to come

Reply With Quote
  #3  
Old 11-08-2012, 08:04 PM
dbell66253's Avatar
dbell66253 dbell66253 is online now
Life Member
 
Join Date: Feb 2011
Location: South Florida
Posts: 8,514
Default

I'd say the voltage regulator is letting you know its going to go.
__________________
2010 FLTRX, Rev Performance 107, S&S 570G cams, Head work, Crank trued and welded, timken conv, PM 21" Wrath, TMax, Dragos Dragula, Top Shop bags and fender, Holeshot LED's, Carlini Bag Drag bars, too many more things to list, and suject to change.
Reply With Quote
  #4  
Old 11-08-2012, 08:33 PM
Triplej's Avatar
Triplej Triplej is offline
Life Member
 
Join Date: Oct 2011
Location: Frisco, TX
Posts: 4,522
Default

Time to check for any DTC's.

http://www.roadglide.org/showthread.php?t=4439

Give us some more info on your bike (year, mileage, recent mods, etc.) and what, if any, codes are showing. Like already said by Redfish-Joe and Dbell66253, among other things it could be a battery/ground problem or a VR on its way out. When checking the Battery cables be sure to check both ends of both cables and apply some dielectric grease to the connections.

If you had noticed a spike in voltage as well as a drop in voltage it would more than likely point to a bad VR.

Electrical issues can be a real booger to narrow down
__________________
2012 RGU / Big Blue Pearl / Woods TW222 Cams / Fuel Moto Ceramic 2-1-2 Headpipe / Fuel Moto 4.5" Pro Touring Mufflers / Fuel Moto Stage 1 A/C / Power Vision Tuner / Heritage Bars / Seat Mod by MCC /Rider and Passenger Bead Riders / BAL Tail Light / 12" & 14" Windvest / Sancho's wings / Iron Aces Phone Mount / Rear Fascia Upgrade / Avon Grips / Mean Mug by Gas Capital Customs
Reply With Quote
  #5  
Old 11-08-2012, 10:02 PM
FLTRX372 FLTRX372 is offline
Newbie
 
Join Date: Nov 2012
Location: Redneckistan, Alabama
Posts: 19
Thumbs up My electrical problem tonight

No mods, stock '12 custom shark. Hopefully call volume will slow down to the point that I can check those battery connections. I just happened to have my service manual at work, so I'll look there to see where the frame ground is. She just turned 10k miles a few weeks ago.

Chris
__________________
"Those who would give up essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety." -Benjamin Franklin, 17 Feb 1775
Reply With Quote
  #6  
Old 11-08-2012, 10:32 PM
tdkkart tdkkart is offline
Life Member
 
Join Date: Jun 2011
Location: East Central Iowa
Posts: 2,168
Default

'12 models with bad voltage regulators are unfortunately a well know problem.
Talk with your dealer and they'll probably swap it out for you.
__________________
2011 Merlot RGU, 103", SE204 cams, V&H Dresser Duals, Ness BS, Power Vision, Progressive 940s/Monotubes, 13" MadStad.
Reply With Quote
  #7  
Old 11-08-2012, 10:40 PM
FLTRX372 FLTRX372 is offline
Newbie
 
Join Date: Nov 2012
Location: Redneckistan, Alabama
Posts: 19
Default

Having trouble finding the frame ground in my service manual, any suggestions?
__________________
"Those who would give up essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety." -Benjamin Franklin, 17 Feb 1775
Reply With Quote
  #8  
Old 11-08-2012, 10:53 PM
FLTRX372 FLTRX372 is offline
Newbie
 
Join Date: Nov 2012
Location: Redneckistan, Alabama
Posts: 19
Default

I checked for codes; for each letter I either got "no rsc" or "none". When I clicked the button again, I was shown a part number for S (68920-07), SP (67261-08), and t (67459-04C).
__________________
"Those who would give up essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety." -Benjamin Franklin, 17 Feb 1775
Reply With Quote
  #9  
Old 11-09-2012, 04:13 AM
Triplej's Avatar
Triplej Triplej is offline
Life Member
 
Join Date: Oct 2011
Location: Frisco, TX
Posts: 4,522
Default

Odd that its not throwing any codes. Being a 12 model I would do like td suggests and let the dealer fix it under warranty.
__________________
2012 RGU / Big Blue Pearl / Woods TW222 Cams / Fuel Moto Ceramic 2-1-2 Headpipe / Fuel Moto 4.5" Pro Touring Mufflers / Fuel Moto Stage 1 A/C / Power Vision Tuner / Heritage Bars / Seat Mod by MCC /Rider and Passenger Bead Riders / BAL Tail Light / 12" & 14" Windvest / Sancho's wings / Iron Aces Phone Mount / Rear Fascia Upgrade / Avon Grips / Mean Mug by Gas Capital Customs
Reply With Quote
  #10  
Old 11-09-2012, 05:06 AM
Mischief's Avatar
Mischief Mischief is offline
Life Member
 
Join Date: Mar 2012
Location: Long Island, New York
Posts: 1,537
Default

Quote:
Originally Posted by dbell66253 View Post
I'd say the voltage regulator is letting you know its going to go.
This is most likely the issue. Many threads on it. Symptoms sound exactly the same. Keep an eye on your voltage and I would go back to the dealer before you get stuck
__________________
Sometimes to achieve the impossible,you have to try the absurd!
2012 FLTRU with assorted chit / 2001 Custom Hayabusa
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 05:36 AM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.