Electrical Problem Tonight - Page 2 - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Troubleshooting for Road Glides

Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #11  
Old 11-09-2012, 06:24 AM
mitchdm's Avatar
mitchdm mitchdm is offline
Grey beard
 
Join Date: Sep 2012
Location: NE FL ~ South of Jax
Posts: 1,474
Default

Could be a variety of things ~ not sure of the miles but I had a stator go out. This is not that uncommon due to possible issues with the automatic primary chain adjuster. There are issues with the adjuster overtightening and causing the stator to get out of line for a period of time. Sounds like a warranty issue for sure.... I was able to narrow mine down to the Regulator/Stator on my 10 before I took it to the boutique.... Good Luck.
__________________
2012 FLTRXSE Skunk S&S 124/HPI 66, PCV w A/T ~ Chopped Tour Pack, Lowers, 11" Tinted MadStad, S&S Power Tune Duals Jet Hot Black, Daymaker LED's, Adaptiv TPX Radar Detector, Fork Baffle, Pro 940's & Pro Monotubes, Baker DD7, Zumo 660, Vulcanworks Solid Sproket, Barnett Scorpion, Jaggs 10 Row oil Cooler w/Fan.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 07:16 PM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.