2013 103" ...ticking? - Page 3 - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Troubleshooting for Road Glides

Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #21  
Old 11-09-2012, 01:39 PM
tmd tmd is offline
Grey beard
 
Join Date: Oct 2010
Location: San Angelo, TX
Posts: 1,303
Default

Quote:
Originally Posted by Hullhorr View Post
Mobil 1 is a Synthetic Oil I believe. Your bike is likely running the HD 20W/50 non synthetic so I wouldn't mix them.
you can mix them without any ill effects.
__________________
2011 RGU with more money then sence in it.
Oh and its black because blacks faster.
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old 11-09-2012, 03:13 PM
Rkfltrx's Avatar
Rkfltrx Rkfltrx is offline
Grey beard
 
Join Date: Mar 2012
Location: Muleshoe Texas
Posts: 1,236
Default

On cold mornings mine will tick until it warms up. After that I don't hear it. Hope they find the problem for ya!
__________________
2012 FLTRX Denim Black,Stock head pipe with Cat removed w/ Jackpot 4" black slash up slip-ons. power vision, Fuel Moto pro billet A/C, Woods TW-222's, 12" Klock Werks . Sanchos Wings. Khrome werks 2+2 Handlebars.
Reply With Quote
  #23  
Old 11-09-2012, 05:23 PM
ChivoChavez321's Avatar
ChivoChavez321 ChivoChavez321 is offline
Member
 
Join Date: Aug 2012
Location: Colorado
Posts: 426
Default

My 2013 RGU with 750 miles on it also has a slight tick, but Ithink its just Harley. I will mention it also at the 1000 mile service. I am also thinking its the break in oil which is not synthetic, but I also hear a slight ticking on my hard tail 113 S&S.
Reply With Quote
  #24  
Old 11-10-2012, 12:38 AM
bikerglasses's Avatar
bikerglasses bikerglasses is offline
Member
 
Join Date: Oct 2012
Location: Tucson, Arizona
Posts: 359
Default

I would know way describe mine as slight.


Sent from my SCH-I535
__________________
Ian -- Tucson, Arizona
+ 2013 Street Glide - Denim Black
- MGS True Duals, Ness Big Sucker, pcV
Reply With Quote
  #25  
Old 11-10-2012, 07:45 AM
VinnyM's Avatar
VinnyM VinnyM is offline
Hangaround
 
Join Date: Oct 2012
Location: Colorado
Posts: 76
Default

My guess is lifter bleed down. I had it on my 11 Road king and got it to stop by changing to Mobil 1 synthetic. My new RGC does it on cold start up for a couple of seconds then quits, sounds like yours is worse than mine. I would try a good syn oil to see if it helps. Trying to duplicate the sound for a dealer is a problem for me and I am not sure that I want them to tear into mine anyway. Good luck and please post up what you figure out.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 09:42 AM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.