won't idle hot - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Troubleshooting for Road Glides

Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #1  
Old 10-25-2012, 05:29 PM
allbrand allbrand is offline
Newbie
 
Join Date: Apr 2012
Posts: 9
Default won't idle hot

Hi I wonder if anybody else has had this problem. I was up in Panama City Beach for the rally and in stop and go traffic. I could smell and feel the motor was hot. It would not idle, even if I turned the throttle forward to run on one cylinder. I have a 2009 and it has the 102 kit in it. I have a oil cooler with fan and the oil presser was low like 10lb. But if I took off and was moving and cooled down the motor it would idle. Any thoughts I will be grateful !
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-25-2012, 06:16 PM
Ironrider's Avatar
Ironrider Ironrider is offline
Member
 
Join Date: Sep 2012
Location: Central Florida
Posts: 355
Default

Did you have the bike dyno'ed ? what intake and exhaust ? what cam? did you upgrade your oil pump? who did your work?
__________________
Ironrider
Reply With Quote
  #3  
Old 10-25-2012, 06:41 PM
Howardsternspenis's Avatar
Howardsternspenis Howardsternspenis is offline
Grey beard
 
Join Date: Mar 2011
Location: Laurel, Maryland
Posts: 934
Question Huh?

Maybe I'm wrong but I didnt think you could switch the EITMS off and on at will.
I think and again, I could be wrong here, it something that can be set to come on when idling and running hot but not something that can be switched on by the driver while idling.
Rolling the throttle forward disengages the cruise control while going down the highway.
As far as losing oil pressure, when the engine is hot, you lose oil viscosity making the oil flow more freely through the engine. Losing some oil pressure is normal while running hot. Not good mind you, but normal.

HSP
Reply With Quote
  #4  
Old 10-25-2012, 08:54 PM
allbrand allbrand is offline
Newbie
 
Join Date: Apr 2012
Posts: 9
Default

I have a JAGG LOW MOUNT 10 ROW FAN ASSISTED OIL COOLER with fan. I bought the bike used. The lady I bought it from said a Harley dealer did the work to make it a 102.I have not dyno'ed it.I have stock air cleaner and Rinehart pipes.I don't know about the cam. Does Harley keep work that they do on bikes on a computer that I can look up by vin number? I was told that in bumper to bumper traffic if I turned the throttle forward it ran on one cylinder.
A small red light come on when I did that.
Thank you for any help!
Reply With Quote
  #5  
Old 10-30-2012, 08:50 PM
Ironrider's Avatar
Ironrider Ironrider is offline
Member
 
Join Date: Sep 2012
Location: Central Florida
Posts: 355
Default

I would talk to the seller and find out as much as you can so you know. Then call her HD service dept to find out what they did.

Sent from my MB860 using Motorcycle.com Free App
__________________
Ironrider
Reply With Quote
  #6  
Old 10-30-2012, 09:31 PM
mark_bert mark_bert is offline
Hangaround
 
Join Date: Oct 2010
Location: Belleville, IL
Posts: 65
Default

I bought my2005 used and it had a similar problem. Turned out that the electrical connector on the fuel injectors were swapped. Cold or at higherRPMs enough fuel made it to the right cylinder but at hot idle, it didn't get enough fuel. I for any reason this is a possibility, I suggest taking a look at it.
__________________
Mark B
2005 FLTRI
Reply With Quote
  #7  
Old 10-30-2012, 09:36 PM
LittleMoe's Avatar
LittleMoe LittleMoe is offline
Member
 
Join Date: Jul 2012
Location: Pittston Pa.
Posts: 310
Default

After i bought my bike, I went to the dealerships that the PO used, told them i just bought the bike, gave them the PO's name and VIN of the bike, and they gave me the FULL records of everything !!!! They didnt even charge me !!!!
__________________
'06 FLTRI/Gel seat/Rheinhart exhaust/PCIII USB/Wind Vest 16" sheild/WAAAY too much chrome Willie G chrome... wanna trade for blacked out parts?
Reply With Quote
  #8  
Old 10-30-2012, 10:18 PM
Ironrider's Avatar
Ironrider Ironrider is offline
Member
 
Join Date: Sep 2012
Location: Central Florida
Posts: 355
Default

Engine Idle Temperature Management System (EITMS) search this and you can find out about it and how it works. You may have to go to the dealer for a flash to activate it . There is a video on it also.
__________________
Ironrider
Reply With Quote
  #9  
Old 10-30-2012, 10:22 PM
Ironrider's Avatar
Ironrider Ironrider is offline
Member
 
Join Date: Sep 2012
Location: Central Florida
Posts: 355
Default

On 2008 model Touring models produced after December 3, 2007, the EITMS is already installed and ready for you to activate using a simple throttle activated switch. When you are stopped and at idle, simply push the throttle forward (closed) to roll off position and hold. After approximately 3 seconds, the cruise control indicator will flash either red (disabled) or green (enabled). Repeat the procedure to toggle between the two.
__________________
Ironrider
Reply With Quote
  #10  
Old 11-13-2012, 01:14 PM
allbrand allbrand is offline
Newbie
 
Join Date: Apr 2012
Posts: 9
Default

Thank you everybody very much!!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 06:16 PM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.