How to Find your Diagnostic Trouble Codes - Page 3 - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Troubleshooting for Road Glides

Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #21  
Old 11-26-2012, 06:05 PM
apbtlvr apbtlvr is offline
Hangaround
 
Join Date: Dec 2010
Location: Louisiana
Posts: 53
Default whew

Thanks so much!!!
__________________
09 FLTR
07 BUSA
03 FXDL
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #22  
Old 11-26-2012, 06:27 PM
ironmark's Avatar
ironmark ironmark is offline
Life Member
 
Join Date: Dec 2010
Location: jackson , michigan
Posts: 4,048
Default

Quote:
Originally Posted by apbtlvr View Post
Thanks so much!!!
Glad you got it figured out . For your throttle problems you should read the sticky on HD service bulletin TT418A and it will explain the problem and provide you the fix.
__________________
08 FLTR candy red sunglo, 103 Stage II, Woods TW-222 cams, V&H Dresser Duals with Monster Rounds, Thundermax tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.

Last edited by ironmark; 11-26-2012 at 06:30 PM.
Reply With Quote Quick reply to this message
  #23  
Old 04-02-2013, 09:55 PM
pcarter79 pcarter79 is offline
Newbie
 
Join Date: Apr 2013
Posts: 1
Default code BUS er

I went through the outlined steps and the code I get is BUS er and it will not pull any other code nor will it clear the code. o4 cvo 103
Reply With Quote Quick reply to this message
  #24  
Old 04-03-2013, 01:09 AM
ironmark's Avatar
ironmark ironmark is offline
Life Member
 
Join Date: Dec 2010
Location: jackson , michigan
Posts: 4,048
Default

Quote:
Originally Posted by pcarter79 View Post
I went through the outlined steps and the code I get is BUS er and it will not pull any other code nor will it clear the code. o4 cvo 103
A 2004 model has a older ecm that needs a scanilizer to read and clear the codes. You can use a jumper and read the codes by counting the flashes of the engine light but the only way to clear the codes without a scanilizer is to cycle the ignition on/off 50 times.
__________________
08 FLTR candy red sunglo, 103 Stage II, Woods TW-222 cams, V&H Dresser Duals with Monster Rounds, Thundermax tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
Reply With Quote Quick reply to this message
  #25  
Old 04-03-2013, 02:52 AM
Snowman7 Snowman7 is offline
Newbie
 
Join Date: Mar 2013
Location: Western, WA
Posts: 31
Default

AWESOME info. Thanks!
Reply With Quote Quick reply to this message
  #26  
Old 08-25-2013, 08:24 PM
mullermj mullermj is offline
Newbie
 
Join Date: Aug 2013
Location: St. Peters, MO
Posts: 13
Default Used as intended

Thanks for posting this! I just had a clutch cable replaced yesterday at 3800 miles on my 08 (I'm 2nd owner) which was supposed to be a fix to my cruise randomly shutting off along with a couple other issues. All seemed to be fixed. Had her out today for the first long ride and used the cc just fine along with using the resume function for the first time. Stopped for a bit and when I tried to set it the cc would set then turn off. Then it would give the green light as if it were set but it wasn't. Then I noticed the cel was lit and began to look/listen for anything different. Nothing seemed out of the ordinary, thankfully, except the cc set/resume button seemed slightly cock-eyed. Got home and knew just where to go. Found the diag instructions and got the code P0577. Not sure if the button is truly cock-eyed but quite a coincidence. Someone did post on that code that it was their set/resume switch so possibly that is my issue as well. But thanks a ton for putting this info on here! And thanks to the other posters for sharing!!!
Reply With Quote Quick reply to this message
  #27  
Old 09-28-2013, 02:30 PM
getrdone's Avatar
getrdone getrdone is offline
Hangaround
 
Join Date: Apr 2013
Location: Plant City/Florida USA!
Posts: 164
Question Engine codes??

I see some of you posted on engine codes and I was wondering if you could help me with my codes.
My check engine light comes on when I first turn the ignition on then goes out after about four seconds like its suppose to. I start the bike and the check engine light comes on again for about 5-6 seconds then goes out. This only happens when I start the bike. Light never comes back on after its started and running.
I ran the code check and this is what it shows.
P-Code po563,po134,po154-no part numbers?
t-Code u1040-pn67348-04d
b-Code co562-pn32836-09a
Hope you can help and thank you if you can.
2012 Road Glide Ultra.
__________________
Life is good but God is Great!
Reply With Quote Quick reply to this message
  #28  
Old 08-12-2014, 06:33 PM
SHREDSURF's Avatar
SHREDSURF SHREDSURF is offline
Newbie
 
Join Date: Jan 2011
Posts: 3
Default

Quote:
Originally Posted by ironmark View Post
The speedometer is capable of displaying & clearing speedometer , tachometer TSM/TSSM , HFSM , ECM , ABS Diagnostic Trouble Codes also known as DTC's . The radios DTC's are retrieved through the radio and displayed through the radio display .

1 - Turn the ignition switch to off & run/stop switch is to run .
2 - Push odometer reset button in & HOLD .
3 - Turn the ignition switch on and then release odometer reset button . The background lighting should illuminate & the speedometer needle should sweep it's full range & indicator lamps ( battery , security , low fuel , check engine and cruise ) should illuminate . The word "DIAG" should then appear .
4 - Push the odometer reset button once and you will see the selection menu "PSSPtb" with the first P flashing .
5 - Each letter represents a area of the diagnostics module . The module that is flashing is the one you are going to check . To move from one letter to the next you must push the odometer reset button one time . ( from P to S to SP to t to b and back to P , ect ect )
P = ECM
S = TSM/TSSM/HFSM
SP = speedometer
t = tachometer
b = ABS codes
6 - To get the DTC code in a area of diagnostics you should PUSH & HOLD the odometer reset button in for 5 seconds and the release . If there are any DTC's the code will be displayed or the word " none " will appear if there are no DTC's . Push the odometer reset button again to view any additional codes if they exist .
7 - Record the codes .
8 - If DTC's are NOT to be cleared , press and release the odometer reset button . Part #of module will be displayed .
9 - If DTC's are to be cleared for that module , PRESS & HOLD the odometer reset button until " clear " is displayed .
10 - Press and release the odometer reset button to continue to the next module .
11 - Turn the ignition switch off to exit the diagnostic mode .
HUGE HELP, THANK YOU! This little bit of info and instructions saved me at least $250.00 at the stealership!
I've had this "limp mode" problem for a while now.
I'll be riding along and the throttle becomes unresponsive, RPM's drop to 1500, the red security key lights up as does the check engine light, I am forced to pull over, shut the bike down and restart it...annoying, but more dangerous than anything else.
I just ran the internal diagnostics test myself using the instructions above and cleared all of the following errors:

P1009 - Incorrect Password
P1511 - Throttle actuator control power management failure of throttle control actuator
P2135 - Correlation Error
B1121(TSM) - Left turn output fault
B1121(HFSM) - Left turn output open
B1122 (TSM) - Right turn output fault
B1122 (HFSM) - Right turn output open

The part #'s associated the error codes were as follows:

Pn - 32933-09
Pn - 68920-07

I will assume that since I've cleared all of the error codes, I'm good?
I will re-check them once I ride again and the limp mode occurrence is intermittent so I'll see what happens while riding.
Thanks again IronMike!!
__________________
'09 FLTR - *Red Hot Sunglo*
Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 09:32 PM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.