Red Key Light on Odometer. - Page 3 - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Troubleshooting for Road Glides

Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #21  
Old 12-28-2012, 07:45 AM
OldNerdGuy's Avatar
OldNerdGuy OldNerdGuy is offline
Life Member
 
Join Date: Oct 2010
Location: St. Peters, MO
Posts: 3,033
Default

Quote:
Originally Posted by Q-Hog View Post
What would cause the Red Key Light to come on several minutes into a ride, stay lite for several minutes, then cut off.?


Sent from my PG86100 using Motorcycle.com Free App
Use the Red Key, not the Blue Key, if you wish to enter the Matrix.
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old 12-28-2012, 08:10 AM
GLYDDN11's Avatar
GLYDDN11 GLYDDN11 is offline
Life Member
 
Join Date: Jan 2011
Location: Virginia Beach, Virginia
Posts: 1,849
Default

My key light comes on and stays on now. I took it to the dealership and the mechanic put it on the machine. Come to find out that if you eliminate or change out your turn signals (ie: leds) that this screws with the security systems loop and it throws this light on to tell you that you have screwed with it. So now I just have an extra light on all the time...kinda sucks but I don't want to put the stock turn signals back on.

I am glad that others have mentioned about changing out the battery on the FOB. My bike is an '11 and I bought it new in Jan 2011 and am still running on the same batteries in the FOB. I am thinking that I make a trip to Radio Shack today to replace them.
__________________
The World ends when you're dead. Until then,
you got more punishment in store. Stand it
like a man....and give some back
Reply With Quote
  #23  
Old 12-28-2012, 09:49 AM
Q-Hog's Avatar
Q-Hog Q-Hog is online now
Life Member
 
Join Date: Jan 2011
Location: Georgia
Posts: 5,087
Default

Thanks for your reply, I did change out my front turn signals and replaced them with Chrome Glow LEDs. That might be my problem as well I put on the CVO Rear-fender.


Sent from my iPhone using Motorcycle.com Free App
__________________
[/SIGPIC][SIGPIC]
Reply With Quote
  #24  
Old 12-28-2012, 09:51 AM
Q-Hog's Avatar
Q-Hog Q-Hog is online now
Life Member
 
Join Date: Jan 2011
Location: Georgia
Posts: 5,087
Default

Quote:
Originally Posted by OldNerdGuy View Post
Use the Red Key, not the Blue Key, if you wish to enter the Matrix.
I'm sticking with the red key


Sent from my iPhone using Motorcycle.com Free App
__________________
[/SIGPIC][SIGPIC]
Reply With Quote
  #25  
Old 12-28-2012, 11:01 AM
TitusPollo's Avatar
TitusPollo TitusPollo is offline
Hangaround
 
Join Date: Nov 2012
Location: KCMO
Posts: 129
Default

Quote:
Originally Posted by GLYDDN11 View Post
My key light comes on and stays on now. I took it to the dealership and the mechanic put it on the machine. Come to find out that if you eliminate or change out your turn signals (ie: leds) that this screws with the security systems loop and it throws this light on to tell you that you have screwed with it. So now I just have an extra light on all the time...kinda sucks but I don't want to put the stock turn signals back on.
I believe that if changing the signals to LED's causes this light to come on, then you should be able to correct that by adding some electronics into the circuit. Basically making the computer think the "correct" load is present. I'm not a whiz at designing electronics but I have had to modify bikes in the past to get lighting to play well with the rest of the bike.

Hopefully an Electronic Technician will chime in here and give us the low down.
__________________
http://www.roadglide.org/signaturepics/sigpic10986_3.gif
2012 RG ULTRA - V&H Slip-Ons - 14" Santee apes & a decatted head pipe
Reply With Quote
  #26  
Old 12-30-2012, 01:28 PM
Howardsternspenis's Avatar
Howardsternspenis Howardsternspenis is offline
Grey beard
 
Join Date: Mar 2011
Location: Laurel, Maryland
Posts: 947
Talking Thanks!

if you can't remember what you programmed your code, go out to your bike, with a working fob.
ignition: on-off-on
left turn signal: press 3 times
right turn signal: press 1 time

your current code will be flashing in the odometer. if you don't want to change it, just shut your ignition off. if you do wish to change it, you use your left turn signal to cycle through the digits, and the right turn signal to enter one. just set it to something you can remember.[/QUOTE]

Gawd I love this forum!
Such a plethora of information!
You guys are great!

I mean that, it ain't the beer talkin!

HSP
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 05:17 PM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.