Fuel gauge different problem - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Troubleshooting for Road Glides

Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #1  
Old 09-19-2012, 08:53 PM
papa roc's Avatar
papa roc papa roc is offline
Hangaround
 
Join Date: May 2012
Location: Phoenix Az
Posts: 136
Default Fuel gauge different problem

I have an 06. When i turn on the switch, the gauge sweeps to full, But the low fuel light is on.
Here's what happened... Riding home had just under half a tank. Got caught in a little bit on rain nothing heavy. After riding about 20 miles, the gauge was showing full and the fuel light was on. Took of the cap, shake the bike,,and I can see gas. I know there are post here about this, but I thought this might be something different.
__________________
06 RG detachable tour pack,sissy bar and rack. J&M rokker speakers, CFR knockoff, lowering kit
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-03-2013, 03:39 PM
papa roc's Avatar
papa roc papa roc is offline
Hangaround
 
Join Date: May 2012
Location: Phoenix Az
Posts: 136
Default

Bump no advice?
__________________
06 RG detachable tour pack,sissy bar and rack. J&M rokker speakers, CFR knockoff, lowering kit
Reply With Quote
  #3  
Old 01-03-2013, 05:15 PM
SickRick SickRick is offline
Grey beard
 
Join Date: Jul 2011
Posts: 1,179
Default

Since you're getting bad readings from both the gauge and the light, it would suggest a problem with the sending unit inside the fuel tank. I'd pull the unit and see if something appears to be stuck.
Reply With Quote
  #4  
Old 01-03-2013, 05:59 PM
tmd tmd is offline
Grey beard
 
Join Date: Oct 2010
Location: San Angelo, TX
Posts: 1,401
Default

If you say it happened after getting caught in the rain I would check your electrical connector to the sending unit for moisture or corrosion.
__________________
2011 RGU with more money then sence in it.
Oh and its black because blacks faster.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 10:47 PM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.