Engine and battery light - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Troubleshooting for Road Glides

Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #1  
Old 01-12-2013, 06:09 PM
Onthehunt49's Avatar
Onthehunt49 Onthehunt49 is offline
Hangaround
 
Join Date: Apr 2012
Location: Fairhope, Alabama
Posts: 108
Default Engine and battery light

a couple times recently...my battery and engine light have come on few times(first ride in a month) whenever it does it battery guage drops from just under 14 to about 11.

then after few minutes goes back to normal????

any ideas ?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-12-2013, 06:38 PM
Triplej's Avatar
Triplej Triplej is offline
Life Member
 
Join Date: Oct 2011
Location: Frisco, TX
Posts: 4,677
Default

I did not see what year your bike is but there is a recall on the 2012 bikes for the voltage regulator which sounds like may well be your problem.
Also you need to check your battery cable connections.

http://www.roadglide.org/showthread....gulator+recall
__________________
2012 RGU / Big Blue Pearl / Woods TW222 Cams / Fuel Moto Ceramic 2-1-2 Headpipe / Fuel Moto 4.5" Pro Touring Mufflers / Fuel Moto Stage 1 A/C / Power Vision Tuner / Heritage Bars / Seat Mod by MCC /Rider and Passenger Bead Riders / BAL Tail Light / 12" & 14" Windvest / Sancho's wings / Iron Aces Phone Mount / Rear Fascia Upgrade / Avon Grips / Mean Mug by Gas Capital Customs
Reply With Quote
  #3  
Old 01-12-2013, 07:05 PM
Onthehunt49's Avatar
Onthehunt49 Onthehunt49 is offline
Hangaround
 
Join Date: Apr 2012
Location: Fairhope, Alabama
Posts: 108
Default

my road glide is a 2008
Reply With Quote
  #4  
Old 01-12-2013, 07:40 PM
Triplej's Avatar
Triplej Triplej is offline
Life Member
 
Join Date: Oct 2011
Location: Frisco, TX
Posts: 4,677
Default

Start with checking for any Diagnostic Trouble Codes.
http://www.roadglide.org/showthread.php?t=4439
If you find any this will help explain what they are.
http://www.roadglide.org/showthread.php?t=5748
__________________
2012 RGU / Big Blue Pearl / Woods TW222 Cams / Fuel Moto Ceramic 2-1-2 Headpipe / Fuel Moto 4.5" Pro Touring Mufflers / Fuel Moto Stage 1 A/C / Power Vision Tuner / Heritage Bars / Seat Mod by MCC /Rider and Passenger Bead Riders / BAL Tail Light / 12" & 14" Windvest / Sancho's wings / Iron Aces Phone Mount / Rear Fascia Upgrade / Avon Grips / Mean Mug by Gas Capital Customs
Reply With Quote
  #5  
Old 01-13-2013, 10:16 AM
ironmark's Avatar
ironmark ironmark is offline
Life Member
 
Join Date: Dec 2010
Location: jackson , michigan
Posts: 3,860
Default

As suggested check for codes. On my 08 I only had a problem with the stator and it needed to be replaced so I would lean toward a stator problem. I haven't had any problems with the voltage regulator yet, most of the time the voltage regulator is either good or bad but the stator can go bad a little at a time.
__________________
08 FLTR candy red sunglo, 103 Stage II, Woods TW-222 cams, V&H Dresser Duals with Monster Rounds, Thundermax tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
Reply With Quote
  #6  
Old 01-13-2013, 12:36 PM
Ironrider's Avatar
Ironrider Ironrider is offline
Member
 
Join Date: Sep 2012
Location: Central Florida
Posts: 355
Default

Do you have any codes ?

Sent from my MB860 using Motorcycle.com Free App
__________________
Ironrider
Reply With Quote
  #7  
Old 01-14-2013, 04:46 PM
Onthehunt49's Avatar
Onthehunt49 Onthehunt49 is offline
Hangaround
 
Join Date: Apr 2012
Location: Fairhope, Alabama
Posts: 108
Default

if i did this right...the only code that came up was
P0562 (battery voltage low) from link to chart triple j put up

could my battery be bad? i just replaced battery last spring?
Reply With Quote
  #8  
Old 01-14-2013, 05:12 PM
Triplej's Avatar
Triplej Triplej is offline
Life Member
 
Join Date: Oct 2011
Location: Frisco, TX
Posts: 4,677
Default

Quote:
Originally Posted by Onthehunt49 View Post
if i did this right...the only code that came up was
P0562 (battery voltage low) from link to chart triple j put up

could my battery be bad? i just replaced battery last spring?
Could be a lot of things including the battery, loose/corroded cable(s), Bad VR and/or Stator. I doubt its the battery but you never know until you have it checked out. Any chance you have had the bike on a battery charger?
__________________
2012 RGU / Big Blue Pearl / Woods TW222 Cams / Fuel Moto Ceramic 2-1-2 Headpipe / Fuel Moto 4.5" Pro Touring Mufflers / Fuel Moto Stage 1 A/C / Power Vision Tuner / Heritage Bars / Seat Mod by MCC /Rider and Passenger Bead Riders / BAL Tail Light / 12" & 14" Windvest / Sancho's wings / Iron Aces Phone Mount / Rear Fascia Upgrade / Avon Grips / Mean Mug by Gas Capital Customs
Reply With Quote
  #9  
Old 01-14-2013, 05:33 PM
Triplej's Avatar
Triplej Triplej is offline
Life Member
 
Join Date: Oct 2011
Location: Frisco, TX
Posts: 4,677
Default

Check out post # 3 in the attached thread by tmd. It may be of some help finding your problem. If you don't have the Service and Electrical Diagnostic Manuals they will be the best $ spent for dealing with these type issues.

http://www.roadglide.org/showthread....harging+system
__________________
2012 RGU / Big Blue Pearl / Woods TW222 Cams / Fuel Moto Ceramic 2-1-2 Headpipe / Fuel Moto 4.5" Pro Touring Mufflers / Fuel Moto Stage 1 A/C / Power Vision Tuner / Heritage Bars / Seat Mod by MCC /Rider and Passenger Bead Riders / BAL Tail Light / 12" & 14" Windvest / Sancho's wings / Iron Aces Phone Mount / Rear Fascia Upgrade / Avon Grips / Mean Mug by Gas Capital Customs
Reply With Quote
  #10  
Old 01-14-2013, 05:38 PM
FloridaFLTRU's Avatar
FloridaFLTRU FloridaFLTRU is offline
Hangaround
 
Join Date: Aug 2012
Location: Orlando, FL
Posts: 150
Default

My '08 Street Glide did that. Turned out to be the voltage regulator. Good luck!
__________________

FloridaFLTRU
Orlando, FL
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 09:10 PM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.