Battery tender - Road Glide Forums
Road Glide Forums






Go Back   Road Glide Forums > Road Glide Specific Discussions > Road Glide Equipment


Advertisement
Order T-Shirts Here

Motorcycle Superstore

Make sure to Visit our Sponsors. They keep this site FREE!








Partner Links


Motorcycle Superstore









 
Reply
 
Thread Tools Display Modes
  #1  
Old 07-29-2013, 07:38 PM
crossbonesglide crossbonesglide is offline
Prospect
 
Join Date: Nov 2012
Location: Illinois
Posts: 264
Default Battery tender

So after charging all night the light still shows charging. It's never taken that long to charge. The battery isn't a year old yet, I'm thinking the tender may be bad.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-29-2013, 07:55 PM
Tourhog's Avatar
Tourhog Tourhog is offline
Hangaround
 
Join Date: Sep 2012
Location: South Florida
Posts: 63
Default

Had same issue once. It turned out to be the pigtail hooked up to the battery was bad. Not the charger or battery.

Sent from Motorcycle.com Free App
__________________
2013 RGU BBP
Reply With Quote
  #3  
Old 07-29-2013, 07:58 PM
Bull_Duck's Avatar
Bull_Duck Bull_Duck is offline
Member
 
Join Date: May 2011
Location: N FL USA. 86 miles south of GA
Posts: 612
Default

Quote:
Originally Posted by crossbonesglide View Post
So after charging all night the light still shows charging. It's never taken that long to charge. The battery isn't a year old yet, I'm thinking the tender may be bad.

If the charger lights on, then likely ok. Loo to your battery connection. All the terminal connections + & -, not only trickle charger.
__________________
2008 Road Glide 105th; 2008 FXDSE(2), FXSTD -SE
1998 FXD For Sale
Photo Albums
Reply With Quote
  #4  
Old 07-30-2013, 01:42 PM
CSM11's Avatar
CSM11 CSM11 is offline
Member
 
Join Date: Feb 2011
Location: Middle TN
Posts: 403
Default

I agree check connections
Reply With Quote
  #5  
Old 07-30-2013, 02:23 PM
PGR's Avatar
PGR PGR is offline
Life Member
 
Join Date: Aug 2010
Location: Western Illinois
Posts: 1,550
Default

Depends on which version you have. I have the HD version.

Flashing Amber = Disconnected

Solid Amber = Begin charging

Flashing Green = Almost charged

Solid Green = full charge
__________________







...................... Ron..........................


........2011 Cool Blue Pearl FLTRX........
.............RoboGlide .............

Reply With Quote
  #6  
Old 07-30-2013, 02:36 PM
HogPro's Avatar
HogPro HogPro is online now
Resident wheel expert
 
Join Date: Feb 2012
Location: Los Angeles CA
Posts: 1,207
Default

Some pigtails have fuses in tehm. Check the fuse.
Reply With Quote
  #7  
Old 07-30-2013, 03:13 PM
moose1's Avatar
moose1 moose1 is offline
Grey beard
 
Join Date: Sep 2012
Location: Blanchard Oklahoma
Posts: 1,198
Default

I had a battery on my 2011 heritage go bad at about 6 months old and it cooked my battery tender


Sent from Motorcycle.com App
__________________
2012 FLTRU vivid black
life has no remote
get up and change it yourself
Reply With Quote
  #8  
Old 07-30-2013, 03:17 PM
throttles&triggers's Avatar
throttles&triggers throttles&triggers is offline
Grey beard
 
Join Date: Jun 2013
Location: Kansas
Posts: 806
Default

Quote:
Originally Posted by crossbonesglide View Post
So after charging all night the light still shows charging. It's never taken that long to charge. The battery isn't a year old yet, I'm thinking the tender may be bad.
Unplug the tender from the outlet or extension cord and plug it right back in. The light should go to green if it is charged, if not something may not be connected properly, most likely at the battery. If your connections are all good, it could be the battery tender.

The other option is that you have a bad regulator and there was a VIN recall on those. That should be looked into, as well. My tender did not indicate a full charge until the regulator was changed out under warranty.
Reply With Quote
  #9  
Old 07-30-2013, 04:10 PM
crossbonesglide crossbonesglide is offline
Prospect
 
Join Date: Nov 2012
Location: Illinois
Posts: 264
Default

It is the HD battery tender. It worked last week with no problems. This week solid amber for 12 hours. Pulled the fuse and the amber flashed, replaced the fuse and checked all the connections, all tight. Is there a way to check the voltage with a voltmeter from the tender without killing myself? Don't think the battery is already bad on a 2013 model.
Reply With Quote
  #10  
Old 08-01-2013, 11:36 AM
crossbonesglide crossbonesglide is offline
Prospect
 
Join Date: Nov 2012
Location: Illinois
Posts: 264
Default


After giving it a couple more hours yesterday it finally turned green.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


All times are GMT -5. The time now is 08:13 AM.



Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
H-D, Harley-Davidson, and Harley-Davidson Logos are registered trademarks of H-D Michigan, Inc. Harley-Davidson in no way endorses or is affiliated with this site.