12000km road trip, technical aftermath - Road Glide Forums
Road Trip Discussions/Stories/Pictures Show your trips here!

 19Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 08-31-2018, 04:17 PM Thread Starter
Member
 
Join Date: Apr 2016
Location: Europe
Posts: 417
12000km road trip, technical aftermath

As you know I went to NordKapp Norway, riding 12000km under severe heat, some winter like cold and heavy rain. Bike got severely dirt, especially with sand and mud collected up north.
The RGU is now showing the bill that I’m on my way to fix, here they are:
1) cooling system: I had an overtemp for 3 consecutive days, just a few miles after start-up and then system worked ok the rest of the day. I was still in the north, as soon as temperatures raised going south the issue disappeared. The main suspect was the thermostat, replaced it under warranty.
2) gear indication sometimes disappearing dumping the cruise control, in some case neutral light was coming on despite bike in 6th gear at highway speed. No code, main suspect is the clutch switch being dirty, I will try to clean it tomorrow and I will check for it. I do not think it is the CKP because that would have shut down the bike.
3) rider headset not activating anymore the VOX, if PTT is pushed (have the lighted switches but not the CB) the rider hear the voice very low and only if no noise is around ( meaning 0 with engine on). Passenger headset works fine. Tomorrow I will take it to the dealer.
4) found a HUGE amount of dirt beneath the seat, the battery caddy was full of sand and the 2 bolt in charge of secure it were loose almost out of thread. The battery bolts were loose and it took almost a complete turn to have them at torque.
5) air filter was ok, everytime I was in the rain the rain sock was in to protect and it did its job.
Next appointment is a 1000km final transfer to Italy trip in 2 weeks, I hope no other surprises will show up before that, but I can declare myself satisfied for the overall performance of my beloved shark

Last edited by Beaver; 08-31-2018 at 04:19 PM.
Beaver is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 09-01-2018, 08:25 PM
Life Member
 
08Zinc's Avatar
 
Join Date: Jun 2011
Location: Frederick, MD
Posts: 1,979
Garage
For a minute there, I thought on was on the ADV forum. (Adventure riders forum for bikes like the BMW GS 1200 or Triumph Tiger.
Beaver and geo8866 like this.

Blessings, Zinc -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

"But when I leave I want to go out like Elijah, with a whirlwind to fuel my chariot of fire." Rich Mullins
08Zinc is offline  
post #3 of 12 (permalink) Old 09-03-2018, 04:35 PM Thread Starter
Member
 
Join Date: Apr 2016
Location: Europe
Posts: 417
just a little update.
1. overtemp light not coming out anymore, the thermostat change fixed the issue.
2. Cruise Control dump with flickering gear indication together with Neutral light: the clutch switch cleaning did not work, in the following ride I had the "N" light coming out steady a lot, even without the cruise control on. Still no codes.
coming home I checked the Neutral switch, found both connectors covered by a fluffy ball of greasy debris. Cleaned and to be checked again
3. Rider Intercom not working with both VOX and PTT, got dealer appointment for next Saturday, if the cruise control is not fixed by the the "N" switch cleaning it will be checked out as well.
Will update on findings

butaway..... my 10 years old, 100000 km Dyna, ridden by my son during the trip needed only a simple wash and came back as new, like an old bitch........ love that bike!
ChromeSpark likes this.
Beaver is offline  
 
post #4 of 12 (permalink) Old 09-06-2018, 10:07 PM
Life Member
 
Woodman's Avatar
 
Join Date: Apr 2015
Location: Washington
Posts: 2,386
Garage
Post some pictures it would be cool to see where you have been.
Woodman is offline  
post #5 of 12 (permalink) Old 09-06-2018, 10:49 PM
Newbie
 
10th Mountain's Avatar
 
Join Date: Aug 2018
Location: Macon County TN
Posts: 14
yes pictures please, and thank you for taking the time to write the post. Safe travels!
10th Mountain is offline  
post #6 of 12 (permalink) Old 09-07-2018, 01:19 AM Thread Starter
Member
 
Join Date: Apr 2016
Location: Europe
Posts: 417
Quote:
Originally Posted by Woodman View Post
Post some pictures it would be cool to see where you have been.
The whole trip is in here: https://www.roadglide.org/10-road-tr...th-europe.html
Beaver is offline  
post #7 of 12 (permalink) Old 09-08-2018, 03:44 PM Thread Starter
Member
 
Join Date: Apr 2016
Location: Europe
Posts: 417
update following dealer visit today:
cruise control dump with gear indication flickering: the CKP (crank position) sensor was found to be erratic and changed under warranty. tested on the way back home and everything seems to be fine now. No wrong neutral light at all, even before arriving to dealer. Cleaning the connectors seemed to have solved that as well.
Rider intercom not working: dealer said my freeware wiring is faulty while bike is ok. ordered a spare wire on amazon, will see if that is true.

main point is that now bike is ready for the 700miles ride to Italy next week
ultra98, ChromeSpark and geo8866 like this.
Beaver is offline  
post #8 of 12 (permalink) Old 09-09-2018, 12:21 PM
Life Member
 
geo8866's Avatar
 
Join Date: Apr 2017
Location: Eastern Pennsylvania
Posts: 1,843
Quote:
Originally Posted by Beaver View Post
update following dealer visit today:
cruise control dump with gear indication flickering: the CKP (crank position) sensor was found to be erratic and changed under warranty. tested on the way back home and everything seems to be fine now. No wrong neutral light at all, even before arriving to dealer. Cleaning the connectors seemed to have solved that as well.
Rider intercom not working: dealer said my freeware wiring is faulty while bike is ok. ordered a spare wire on amazon, will see if that is true.

main point is that now bike is ready for the 700miles ride to Italy next week
Thank you for using miles instead of km this time. We Americans suck at math. LOL

I'm just curious, what year is your bike?
Beaver likes this.

2017 RGS Hard Candy Hot Rod Red Flake
geo8866 is offline  
post #9 of 12 (permalink) Old 09-09-2018, 02:31 PM Thread Starter
Member
 
Join Date: Apr 2016
Location: Europe
Posts: 417
Quote:
Originally Posted by geo8866 View Post
Thank you for using miles instead of km this time. We Americans suck at math. LOL

I'm just curious, what year is your bike?
it is a '16 RGU, I bought it new with a huge discount (not normal here in europe) the same days the first M8s hit the dealer, suddenly here the twin cams were looking soooooo old to everybody but me.
ChromeSpark and geo8866 like this.
Beaver is offline  
post #10 of 12 (permalink) Old 09-10-2018, 03:35 PM
Life Member
 
Woodman's Avatar
 
Join Date: Apr 2015
Location: Washington
Posts: 2,386
Garage
Quote:
Originally Posted by Beaver View Post
it is a '16 RGU, I bought it new with a huge discount (not normal here in europe) the same days the first M8s hit the dealer, suddenly here the twin cams were looking soooooo old to everybody but me.
Nice , keep on riding that puppy.
How is the bike on cobblestone roads?
Was it crazy riding in Copenhagen?
Woodman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Harley technical blueprints hotrodad General Off-Topic Discussions 1 11-21-2013 05:23 AM
Alarm technical help! ctalbot6983 Troubleshooting for Road Glides 5 01-05-2013 06:54 PM
2013 Harley-Davidson Motorcycles New Product Technical Cosmic Charlie *General Road Glide Discussions/Pictures 7 01-03-2013 08:55 PM
Front rotor warp? Need technical input! zman Troubleshooting for Road Glides 14 09-17-2011 12:56 AM
New Wheels on ABS bike - Technical Question twalte Aftermarket Accessories 3 09-02-2011 12:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome