2015 trouble questions - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 04-08-2015, 03:55 PM Thread Starter
Hangaround
 
Mickeyv's Avatar
 
Join Date: May 2013
Location: South east oklahoma
Posts: 64
2015 trouble questions

I have a few question. To see if anyone else has had this happen on a 2015. Washed the bike and now it will not start in gear. Has to be n neutral now to start. 2nd .The gear numbers also went off for about 30 miles. They have now come back on. 3nd question. touch screen goes dark and I have to turn the bike off and back on. I love the touch screen radio and gps, that is why I upgraded. But I did worry about this kind of problem. Anyone?
Mickeyv is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-08-2015, 04:02 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,055
Garage
Did you hose high pressure water right at the controls and HU ? Maybe the water got onto the wiring. Rain don't come down high pressure like a hose can produce, just be more careful next time in those area's.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 13 (permalink) Old 04-08-2015, 04:14 PM
Life Member
 
HellInABucket's Avatar
 
Join Date: Nov 2012
Location: SE Michigan
Posts: 1,812
Just a thought - I know there were some software updates, did you get them?

2020 FLTRK - Roll away the dew...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HellInABucket is offline  
 
post #4 of 13 (permalink) Old 04-08-2015, 09:51 PM
Hangaround
 
Johndeere's Avatar
 
Join Date: Feb 2013
Location: Springfield IL
Posts: 94
I have had all of the above happen. Your cruise will not work either with no gear indicator. I think it does have something to do with cleaning and water. Now the radio that is the great gremlins of the new Rushmore bikes. SG and RG owners alike are having this problem.

15 RGS ported and polished, big sucker, Manlly springs, 10.5 Pistons, ported throttle body, Dragula 2, 12in Apes, Drago's 580 cam and 21 17 Southern MC wheels. ?HP/?TQ
Johndeere is offline  
post #5 of 13 (permalink) Old 04-08-2015, 10:23 PM
Newbie
 
Join Date: Mar 2015
Location: SWFL
Posts: 12
Add to the list of issues with the Infotainment system.....GPS map upgrades.

The most recent map available is dated 2013 Q2....at a cost of $149 -$159. The MOCO site Infotainment software upgrades don't have anything to do with the maps in the GPS. You must go to https://harley-davidson.naviextras.com/shop/portal

Pretty sad how they are taking top dollar, for a touring product that is outdated before it even hits the road. GPS systems and Touring kind of go hand-in-hand

2013 BMW K1600GTL
2011 FLHX
2015________ TBD
K1600FLHX is offline  
post #6 of 13 (permalink) Old 04-09-2015, 08:54 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,055
Garage
Quote:
Originally Posted by K1600FLHX View Post
Add to the list of issues with the Infotainment system.....GPS map upgrades.

The most recent map available is dated 2013 Q2....at a cost of $149 -$159. The MOCO site Infotainment software upgrades don't have anything to do with the maps in the GPS. You must go to https://harley-davidson.naviextras.com/shop/portal

Pretty sad how they are taking top dollar, for a touring product that is outdated before it even hits the road. GPS systems and Touring kind of go hand-in-hand
What does it have to do with ?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #7 of 13 (permalink) Old 04-09-2015, 08:41 PM Thread Starter
Hangaround
 
Mickeyv's Avatar
 
Join Date: May 2013
Location: South east oklahoma
Posts: 64
No power wash just hand washed it. Going to tell the stealer when get it service. Still will not start in gear been over 100 miles. Thanks for all of the help
Mickeyv is offline  
post #8 of 13 (permalink) Old 04-10-2015, 08:25 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,055
Garage
Quote:
Originally Posted by Mickeyv View Post
No power wash just hand washed it. Going to tell the stealer when get it service. Still will not start in gear been over 100 miles. Thanks for all of the help
Try working the clutch lever a few quick times a before you try to start in gear. My switch sticks once in a while.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #9 of 13 (permalink) Old 04-13-2015, 05:43 AM
Hangaround
 
Join Date: Sep 2014
Location: Canfield, Ohio
Posts: 71
Quote:
Originally Posted by Mickeyv View Post
No power wash just hand washed it. Going to tell the stealer when get it service. Still will not start in gear been over 100 miles. Thanks for all of the help

The 15s will not start while in gear. New safety feature.
CVOLEO is offline  
post #10 of 13 (permalink) Old 04-17-2015, 12:40 AM
Newbie
 
Join Date: Aug 2012
Location: Andover Mn
Posts: 44
My 15X I know I have started it in gear even after washing, as for the gear indicator working... it only works while in gear clutch fully released, so this may be a clutch switch issue with your bike & a stealer should be able to monitor switches via computer like I can with the SERPT. Now for the touch screen, I have had the same issues! Factory setup leaves options open... I suggest turning off the adaptive display simply because it uses the clock not where you are located or daylight savings or a ambient light sensor to determine how much backlight you may need. I turned off the adaptive display settings because I either travel from dark/sunrise or sunset/dusk which left my display miserable to see almost all the time. P.s. if your running an O.E. wind shield be sure to do the update via thumb drive & website to your radio OMFG I can finally hear the radio w/o horrible distortion that I never had on my old 07 FLTR. Still not up to par but it was like I was deaf before the update. Best of luck!!!
justchillaxin1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2015-2016 RG Stereo and removal questions i_timmers Audio 16 03-23-2016 04:48 AM
Accessory switch questions 2015 RGS Keithw1961 Aftermarket Accessories 2 08-29-2015 04:09 PM
Upgrading to a 2015 FLTRXS: Plethora of questions and decisions. Rasconzo *General Road Glide Discussions/Pictures 14 04-06-2015 07:11 PM
2015 model Questions Jetman *General Road Glide Discussions/Pictures 7 01-27-2015 08:05 AM
2015 Road Glide questions? Biggy *General Road Glide Discussions/Pictures 35 11-21-2014 10:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome