2015 charging issue - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-11-2015, 11:47 PM Thread Starter
Hangaround
 
vtglide's Avatar
 
Join Date: Apr 2012
Posts: 68
2015 charging issue

I have a 2015 flrtx and tonight when i was pulling my bike into the garage i noticed that my battery light was on my bike only showed 12v on the gauge. I shut the bike off and then just turned the ignition to the on position and it showed 12 volts. I then started the bike and it still only showed 12v. I think that its not charging the battery when its running. I didnt really have much time to mess around with it but was hoping someone could point me in the right direction to checking out the charging system and where i can find the voltage regulator and other things to check to trouble shoot the issue. The owners manual says to check for a bad grounding strap connection. Where can i find that? The bike is completely stock and only has 5xx miles on it. I am planning on riding to laconia on Saturday and i hope to find a loose wire or something easy. I also plugged it into a battery tender to charge the battery overnight. I hope i can find the issue tomorrow or it looks like no laconia for me this year thanks guys!

2015 FLTRX vivid black...
vtglide is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-11-2015, 11:53 PM
Life Member
 
rlaf75's Avatar
 
Join Date: Sep 2011
Location: East Hartford CT
Posts: 7,107
If you want to check it yourself and not take it to the dealer for warranty get a volt meter and check the voltage at the battery. Not running the battery should be 12+ volts. Cranking it should read no less than 10 volts and running should read close to or slightly over 14 volts. Also check to see if it has any codes

09 Mirage Orange Pearl

Some people just need a high-five. In the head. With a chair
rlaf75 is offline  
post #3 of 3 (permalink) Old 06-12-2015, 12:07 AM Thread Starter
Hangaround
 
vtglide's Avatar
 
Join Date: Apr 2012
Posts: 68
i have multi meter already. I will check that tomorrow. I plan on calling a couple local dealers to see if either can take a look at it tomorrow but i doubt they will be able to get it in which is why i want to look at it myself. It would be nice if my dealer would let me drop it off and lend me a bike to ride to laconia on saturday but im pretty sure that is out of the question. I also just realized that this thread is in the wrong place so i started it in the troubleshooting area. I can not seem to delete this thread here so i apologize for the double post.

2015 FLTRX vivid black...

Last edited by vtglide; 06-12-2015 at 04:35 PM.
vtglide is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 charging issue vtglide Troubleshooting for Road Glides 4 07-02-2015 10:44 AM
Ground studs/Intermittant charging issue thedrill Engine Related 3 07-17-2014 06:54 PM
iPhone 4S - Charging/Not Charging dinggus Audio 8 11-01-2013 08:25 AM
charging system issue crosen41 Troubleshooting for Road Glides 6 05-07-2013 01:03 PM
Charging Issue EasternSP Troubleshooting for Road Glides 2 08-13-2010 10:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome