Clutch issue??? - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-18-2015, 06:46 PM Thread Starter
Prospect
 
MASQUEDMANN's Avatar
 
Join Date: Nov 2013
Posts: 295
Clutch issue???

Ok 2013 RGC on my current build I got extended clutch cable due to new 16inch bars also took apart the tranny to powdercoat the cover. Everything is back together. Now once the bike is all warmed up neutral is impossible to find and the bike pulls forward hard with the clutch lever pulled in. I adjusted the cable and it's still happening. Any idea what could be going on?

Masque
Thanks
MASQUEDMANN is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-18-2015, 07:04 PM
Life Member
 
Mike U's Avatar
 
Join Date: Aug 2012
Location: New York
Posts: 5,734
Maurice, try adjusting the clutch pack.
Make sure there is plenty of free play and that the bike is cold when you do.
The cable is only for taking in the slack.
Mike U.

USMC 1975-1977
Semper Fi!
Nothing else matters!
Mike U is online now  
post #3 of 6 (permalink) Old 06-18-2015, 07:09 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 7,976
Garage
I always collapse the cable all the way before adjusting the clutch pack. Then you can watch the hand lever to see when it bottoms out.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
 
post #4 of 6 (permalink) Old 06-18-2015, 07:16 PM Thread Starter
Prospect
 
MASQUEDMANN's Avatar
 
Join Date: Nov 2013
Posts: 295
Thanks guys will give that a try
MASQUEDMANN is offline  
post #5 of 6 (permalink) Old 06-18-2015, 07:32 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 7,976
Garage
Quote:
Originally Posted by MASQUEDMANN View Post
Thanks guys will give that a try
https://www.roadglide.org/showthread....tch+adjustment

Do it like redfifh joe describes, so easy a monkey couldn't screw it up.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #6 of 6 (permalink) Old 06-18-2015, 09:14 PM Thread Starter
Prospect
 
MASQUEDMANN's Avatar
 
Join Date: Nov 2013
Posts: 295
Cool big_ Gary thanks
MASQUEDMANN is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I talk to Redline about clutch issue. Hillglide *General Road Glide Discussions/Pictures 13 04-01-2013 05:26 PM
Apparently, this isn't my week. Possible clutch issue RGCBandit Troubleshooting for Road Glides 3 10-15-2012 08:53 AM
Clutch issue - adjust itself.. TheDon81 Troubleshooting for Road Glides 3 07-19-2012 09:52 AM
Clutch issue BaggerBrian Troubleshooting for Road Glides 7 05-31-2012 09:46 AM
Clutch issue... ZachB Troubleshooting for Road Glides 21 04-19-2012 07:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome