08 road glide (throttle problem - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 2Likes
  • 1 Post By Big_gary
  • 1 Post By hoosierboarder
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-27-2016, 03:47 PM Thread Starter
Newbie
 
Join Date: May 2016
Posts: 5
08 road glide (throttle problem

This has happen about three times in the last month. Rideing along and suddenly no throttle and check engine light goes on. Pull over the bike is still running . Turn it off reset the ignition switch starts and runs fine again. Any help would be appreciated
Thanks CB
Bacanater is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-27-2016, 04:39 PM
Member
 
FDR's RGC's Avatar
 
Join Date: Jan 2013
Posts: 546
Check your connection at twist sensor. The little green plug has been known to cause problems.
FDR's RGC is online now  
post #3 of 9 (permalink) Old 06-27-2016, 05:49 PM Thread Starter
Newbie
 
Join Date: May 2016
Posts: 5
Where is the green plug located
Bacanater is offline  
 
post #4 of 9 (permalink) Old 06-27-2016, 06:26 PM
Grey beard
 
ERod62's Avatar
 
Join Date: Aug 2013
Location: Florida
Posts: 967
Did you check DTC error codes?
Green connector end of the TGS
Either inside handle bars or in the cable run out side the bars. Green plug POS cut and solder wires using shrink tubing.
ERod62 is offline  
post #5 of 9 (permalink) Old 06-27-2016, 07:30 PM Thread Starter
Newbie
 
Join Date: May 2016
Posts: 5
Ok thanks, I will start there. I appreciate your help
Bacanater is offline  
post #6 of 9 (permalink) Old 06-27-2016, 08:40 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,047
Garage
You really need to recover the error codes.
hoosierboarder likes this.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #7 of 9 (permalink) Old 06-28-2016, 11:19 AM
Member
 
hoosierboarder's Avatar
 
Join Date: Jun 2012
Location: Indianapolis,IN
Posts: 448
More than likely (without knowing the codes) it would be the TCA(throttle control actuator) pull the plug off behind the air cleaner. put some dielectric grease on the pins & reconnect, clear the codes. Happens about every 5k miles on mine.
ironmark likes this.

'09 Road Glide
hoosierboarder is offline  
post #8 of 9 (permalink) Old 06-28-2016, 11:50 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
There is a lot of info in the troubleshooting section that can help you with your problem.
The TCA plug on the throttle body is the problem not the green connector inside the handlebars.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #9 of 9 (permalink) Old 06-28-2016, 03:26 PM Thread Starter
Newbie
 
Join Date: May 2016
Posts: 5
Thanks for your help.
Chris
Bacanater is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No throttle 08 road glide Bacanater Troubleshooting for Road Glides 8 05-28-2018 06:38 AM
Very loud clank when shifting or getting on throttle or letting off throttle Callahan69 Engine Related 28 11-14-2016 01:09 PM
08 Electra Glide - Cruise Control Problem gaillarry Controls & Handlebars 7 03-29-2013 03:34 PM
08' Ultra Tour pack to 08' Road Glide Chain Link Aftermarket Accessories 2 03-02-2013 04:17 AM
08 glide Power Commander mounting problem skidmark1964 Troubleshooting for Road Glides 0 09-14-2012 11:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome