Complete Instrument cluster failure - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-06-2016, 11:54 AM Thread Starter
Newbie
 
scopet563's Avatar
 
Join Date: Jan 2014
Posts: 6
Complete Instrument cluster failure

2016 FLTRXS, 7500 miles. Bought in December 2015, first failure was May 2016 all instruments quit working, ECU changed, September 3rd 2016 I started bike and low fuel icon was blinking yellow and L RNG was in the odometer window at next stop light all instruments dead. Bike is at dealer waiting on Milwaukee to advise. Anybody else seeing this type of issue?
scopet563 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-06-2016, 01:10 PM
Life Member
 
RFG7680's Avatar
 
Join Date: Jul 2015
Location: North East Ohio
Posts: 3,267
Garage
Yup. Mine is in the shop right now waiting on a new dash. A mile from my house on the way to work. No lights on the dash. All gauges dead. Fuel on E. Volt meter on 0, speedo at 60 and tach at 1900.

I should have thought to upgrade to the CVO gauges. But. Too late.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

"That which we manifest is before us."
BUYER BEWARE @ BATTLEFIELD HARLEY IN GETTYSBURG PA.
RFG7680 is online now  
post #3 of 7 (permalink) Old 09-07-2016, 09:41 AM
Newbie
 
Join Date: Nov 2015
Location: Quincy, Washington
Posts: 17
Quote:
Originally Posted by scopet563 View Post
2016 FLTRXS, 7500 miles. Bought in December 2015, first failure was May 2016 all instruments quit working, ECU changed, September 3rd 2016 I started bike and low fuel icon was blinking yellow and L RNG was in the odometer window at next stop light all instruments dead. Bike is at dealer waiting on Milwaukee to advise. Anybody else seeing this type of issue?

I lost all of my gauges and indication on my 2016 FLTRXS after riding in a bad rain storm. Long story short.... they replaced the tach/speedometer cluster and all is well. Went to Sturgis and experienced a lot of rain and hail and it continued to work. I submitted a complaint to NHSTA for this but haven't heard anything back. Harley claimed to no nothing of the problem but you are the 8th person that has had the issue, and that doesn't take into account those that don't use the forums.
Hog Happy is offline  
 
post #4 of 7 (permalink) Old 09-07-2016, 02:50 PM Thread Starter
Newbie
 
scopet563's Avatar
 
Join Date: Jan 2014
Posts: 6
I misstated. ECU wasn't changed, Instrument cluster which has brains it was changed back in May, today on the advice of Hd Milwaukee they changed it again. Now I want to know how long they will keep doing it for free, I cant seem to find anywhere online the warranty details. Someone told me if it was identified during the warranty period its always covered. I aint buying that.
scopet563 is offline  
post #5 of 7 (permalink) Old 09-07-2016, 03:21 PM
Life Member
 
RFG7680's Avatar
 
Join Date: Jul 2015
Location: North East Ohio
Posts: 3,267
Garage
I had some warranty work done on my 08 just before the warranty was up. The part failed 6 months after the warranty expired. They fixed it. No cost. That's not to say another dealer would. But in my experience the statement is true.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

"That which we manifest is before us."
BUYER BEWARE @ BATTLEFIELD HARLEY IN GETTYSBURG PA.
RFG7680 is online now  
post #6 of 7 (permalink) Old 09-07-2016, 03:27 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 7,964
Garage
I wonder if any changes were made on the M8's?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #7 of 7 (permalink) Old 09-07-2016, 05:14 PM
Life Member
 
RGKen's Avatar
 
Join Date: May 2012
Location: Jax, FL
Posts: 3,783
Garage
Quote:
Originally Posted by scopet563 View Post
Someone told me if it was identified during the warranty period its always covered. I aint buying that.

This only applies if you have the issue again within the warranty period and can't get an appointment or get it in to the dealership until after the warranty expires. Dealerships have gone to bat for the customer and still been able to get things covered if it has been a historical problem but usually once they have deemed to have fix the issue it's a whole new claim after that.


Sent from Motorcycle.com Free App

2018 FLTRXS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RGKen is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
instrument cluster dw.usa Troubleshooting for Road Glides 3 08-22-2018 11:32 AM
Modding the Instrument Cluster toallow for Risers jm7480 Controls & Handlebars 5 09-18-2015 09:16 AM
Looking for RED instrument cluster lights SIG556 Lighting 17 10-22-2013 09:17 PM
complete inner fairing / instrument housing wenchal Classifieds Archive (3 months old+) 4 01-19-2012 07:52 AM
guage cluster / fairing izzi 75093 *General Road Glide Discussions/Pictures 6 10-18-2011 12:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome