I'm not as good at PM'ing as I thought I was - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-22-2016, 06:18 AM Thread Starter
Life Member
 
Bleachey's Avatar
 
Join Date: Mar 2014
Location: Southside of Indianapolis
Posts: 1,582
Garage
I'm not as good at PM'ing as I thought I was

So last Saturday I do my PM. Oil, tranny, primary, oil filter, check the air filter/tires, go through the checklist in the service manual, I thought. Found an issue with the clutch cable rubbing, but the service guy at the dealership said it would be ok for a few months so I will take it in under my ESP in November or December when the riding season slows. Anyway, I'm cruising home last night on the slab, get to my exit, and when I go to downshift the pedal is rattling around loose, look down and the linkage and come off the shifter shaft. I may not be using the proper terms here, but I hope it makes sense. No idea, guess as I was looking everything over I didn't notice, or didn't look at it when I was trying to "check all fasteners". Anyway, loosened the nut a little, slipped it about halfway back on because that's all the further it would go without something to put behind it to hold it in place. Burnt my hand in about 5 or 6 spots, but she got me home. Funny thing is a couple of months ago a guy down the street had the same issue and I helped him get his back together (he isn't a DIY type of guy, but he is good at cleaning and keeps his spotless), so you think I would have known to check this.

2011 Road Glide Ultra

Last edited by Bleachey; 09-22-2016 at 08:01 AM.
Bleachey is online now  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-22-2016, 07:27 AM
Administrator
 
JacktheBagger's Avatar
 
Join Date: Apr 2010
Location: Bama
Posts: 9,476
Garage
If you still have the stock linkage on there , it is just waiting to fall off , either keep the stock rod and put heim joints on the ends or get a new rod ..

So Many Highways So Little Time
2011 Ultra
JacktheBagger is offline  
post #3 of 3 (permalink) Old 09-22-2016, 08:02 AM Thread Starter
Life Member
 
Bleachey's Avatar
 
Join Date: Mar 2014
Location: Southside of Indianapolis
Posts: 1,582
Garage
Quote:
Originally Posted by HarleyJack View Post
If you still have the stock linkage on there , it is just waiting to fall off , either keep the stock rod and put heim joints on the ends or get a new rod ..
It's the stock rod. It just slid off the shaft that goes through the primary. Nothing broke. The strange thing is, I had to loosen the set screw to get it back on. It has me dumbfounded

2011 Road Glide Ultra
Bleachey is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
F'ing MOFOCO SickRick Audio 15 04-03-2012 08:54 PM
Well Nuts are you F****ING kidding me HarleyArcher Windshields 31 03-25-2012 08:47 PM
FaceBook-ing BlackBetty11 General Off-Topic Discussions 41 07-02-2011 01:41 AM
B-ing Thankful on Thanksgiving Neano62 General Off-Topic Discussions 2 11-27-2010 10:29 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome