Cuts out at Higher RPM's - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 03-21-2017, 11:29 AM Thread Starter
Newbie
 
Join Date: Nov 2014
Posts: 10
Cuts out at Higher RPM's

2010 RG with A Dyna Jet Having several issues. It started with one cylinder not firing. Shut off engine and restated fine. Next when I get above 4500rpm its just like I hit the kill switch on the bars but let off throttle and it comes back to life. This is intermittent does not do it all the time. So far have changed voltage regulator and battery. Also get O2 sensor trouble codes that can clear but come back as soon as the engine is restarted. Any ideas? This has been in the shop now for the 3rd time. And of course wont happen for the mechanic while on dyno or test ride. The only difference I am 300Lbs and he is 175Lbs not sure if that would make any diffference.
goplay is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 03-21-2017, 11:37 AM
Grey beard
 
sfcusaret2004's Avatar
 
Join Date: Oct 2013
Location: michigan
Posts: 1,178
RPM limiter set too low?

Life is too short to put up with stupidity. Strive every day to educate someone, including yourself!
sfcusaret2004 is offline  
post #3 of 11 (permalink) Old 03-21-2017, 11:48 AM Thread Starter
Newbie
 
Join Date: Nov 2014
Posts: 10
Only intermittent. Rev limiter set to 5600.
goplay is offline  
 
post #4 of 11 (permalink) Old 03-21-2017, 01:13 PM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,816
What kind of testing did the 3 shops perform, any recent service work or related history and what tuner do you have?
BH#103 is offline  
post #5 of 11 (permalink) Old 03-21-2017, 01:16 PM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,816
My bad, what kind of testing did the shop do each time?
BH#103 is offline  
post #6 of 11 (permalink) Old 03-21-2017, 01:51 PM
Member
 
Join Date: Dec 2014
Location: westford mass.
Posts: 590
Cylinder heat sensor? Located horn side top of front cylinder. This happen to me and nobody could figure it out.
dozer23 is offline  
post #7 of 11 (permalink) Old 03-21-2017, 01:58 PM
PGR
GONE BUT NOT FORGOTTEN
 
PGR's Avatar
 
Join Date: Aug 2010
Location: Western Illinois
Posts: 2,338
Garage
Check the wire going to the map sensor on the induction module. If it's bad, you can touch it. with a stick, with the bike at idle, and the engine will shut down.








......................
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ron..........................


........2011 Cool Blue Pearl FLTRX........
.............RoboGlide .............


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PGR is offline  
post #8 of 11 (permalink) Old 03-21-2017, 03:05 PM Thread Starter
Newbie
 
Join Date: Nov 2014
Posts: 10
They checked ECM and some connections as well as change fuel filter.
goplay is offline  
post #9 of 11 (permalink) Old 03-21-2017, 03:11 PM Thread Starter
Newbie
 
Join Date: Nov 2014
Posts: 10
Dozer23 was your problem intermittent?
goplay is offline  
post #10 of 11 (permalink) Old 03-21-2017, 03:28 PM
Member
 
Join Date: Dec 2014
Location: westford mass.
Posts: 590
Yes! It did seem to do it more wile hot or under a load.
Two different dealer were unable to figure it out.
Call who ever looked at the bike last and ask the ? Seems to be over looked often.
Good luck.the part was 40.00 I believe?
dozer23 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio volume cuts out when bike is started denharrigan Audio 0 03-25-2017 03:28 PM
Motor cuts out mpowered Engine Related 14 05-26-2014 08:40 AM
Harley's new direction - Higher quality or just Higher Profits? Uncle Fuzzy *General Road Glide Discussions/Pictures 25 04-20-2012 06:29 AM
Radio cuts out on engine start? dbbarton00 Troubleshooting for Road Glides 4 02-18-2012 08:02 PM
cuts out after warmed up... chuckp *General Road Glide Discussions/Pictures 1 03-05-2011 08:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome