Need Help No Clutch - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 3Likes
  • 3 Post By JacktheBagger
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-14-2017, 01:41 AM Thread Starter
Newbie
 
SOMERG's Avatar
 
Join Date: May 2017
Location: Long Island, New York
Posts: 18
Need Help No Clutch

Well my shift seal went bad on a 2012 RG and of course the whole primary case had to be removed, so I got all the parts started the job this morning. Everything went back fine and now I have no clutch, hard as hell and doesn't engage the clutch pack, everything went back the right way and I adjusted the clutch pin by the book and I have tighten the adjustment all the way and lever has a large gap add feels like a brick.

Well I fix the leak but now have another problem and since' I knew to this bike my knowledge is limited, my son by mistake did engage the clutch lever without the basket on and I"m wondering did that do something on the transmission side. Thanks in advance for any help.

Last edited by SOMERG; 05-14-2017 at 02:13 AM.
SOMERG is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-14-2017, 05:57 AM
Administrator
 
JacktheBagger's Avatar
 
Join Date: Apr 2010
Location: Bama
Posts: 9,474
Garage
sounds like the ramps came off the ball bearings on the trans side . There are two ramps , inner and outer and there are ball bearings between them , one of the ramps has the clutch cable attached .. But alas , how did the clutch get adjusted correctly ?
You will have to remove the exhaust and drain the transmission to get in there ..

Question One : Do you have a service manual ? They explain everything very well .. Should be the first accessory you buy ..
JayKS, Road dawg and Swomack like this.

So Many Highways So Little Time
2011 Ultra
JacktheBagger is offline  
post #3 of 6 (permalink) Old 05-14-2017, 08:03 AM Thread Starter
Newbie
 
SOMERG's Avatar
 
Join Date: May 2017
Location: Long Island, New York
Posts: 18
Quote:
Originally Posted by HarleyJack View Post
sounds like the ramps came off the ball bearings on the trans side . There are two ramps , inner and outer and there are ball bearings between them , one of the ramps has the clutch cable attached .. But alas , how did the clutch get adjusted correctly ?
You will have to remove the exhaust and drain the transmission to get in there ..

Question One : Do you have a service manual ? They explain everything very well .. Should be the first accessory you buy ..
Thanks I'll take apart the tranny side, yeah will need a service manual for sure.
SOMERG is offline  
 
post #4 of 6 (permalink) Old 05-14-2017, 10:34 AM
Life Member
 
Road dawg's Avatar
 
Join Date: Oct 2011
Location: Long Island, New York
Posts: 2,172
Quote:
Originally Posted by SOMERG View Post
Thanks I'll take apart the tranny side, yeah will need a service manual for sure.
Best investment you can do, first thing i bought for my glide the day i picked her up.

When all else fails, hell there is always beer!
Road dawg is offline  
post #5 of 6 (permalink) Old 05-14-2017, 04:45 PM Thread Starter
Newbie
 
SOMERG's Avatar
 
Join Date: May 2017
Location: Long Island, New York
Posts: 18
Quote:
Originally Posted by HarleyJack View Post
sounds like the ramps came off the ball bearings on the trans side . There are two ramps , inner and outer and there are ball bearings between them , one of the ramps has the clutch cable attached .. But alas , how did the clutch get adjusted correctly ?
You will have to remove the exhaust and drain the transmission to get in there ..

Question One : Do you have a service manual ? They explain everything very well .. Should be the first accessory you buy ..
Thanks for your help I fixed it, Like you said.
SOMERG is offline  
post #6 of 6 (permalink) Old 05-15-2017, 07:53 AM
Administrator
 
JacktheBagger's Avatar
 
Join Date: Apr 2010
Location: Bama
Posts: 9,474
Garage
Glad to help , bill on the way ............

So Many Highways So Little Time
2011 Ultra
JacktheBagger is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help-Clutch Cable Lever Change-Tight Cable SNemet Controls & Handlebars 6 04-28-2016 05:42 PM
Need help with adjusting clutch maurij1 Troubleshooting for Road Glides 14 06-08-2015 11:22 AM
need help no marker lights BklynRGU Lighting 12 05-06-2014 08:01 PM
Need help- clutch hub nut THEMASTERDESTROYER Engine Related 5 03-06-2013 11:15 AM
Need help: No sound from Factory Stereo when Running DED HD Audio 8 06-30-2011 08:48 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome