low speed cut out - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 1Likes
  • 1 Post By ironmark
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-10-2017, 05:04 AM Thread Starter
Newbie
 
mydime's Avatar
 
Join Date: Sep 2015
Posts: 8
low speed cut out

i have a 2015 rg special with 14996 miles
it has a heavy breather and not cat .
why does motor cut out at low rpm?
it does have a modest ecm tune to run richer.
it just stared to doing this and just not sure why.
thank you
mydime is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-10-2017, 07:29 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,055
Garage
Quote:
Originally Posted by mydime View Post
i have a 2015 rg special with 14996 miles
it has a heavy breather and not cat .
why does motor cut out at low rpm?
it does have a modest ecm tune to run richer.
it just stared to doing this and just not sure why.
thank you
Explain your tune, modesty.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 7 (permalink) Old 06-10-2017, 10:15 AM Thread Starter
Newbie
 
mydime's Avatar
 
Join Date: Sep 2015
Posts: 8
i took it to HD dealership to have the ecm flashed supposedly it runs alittle richer than before .
and for 6 months i had no issues,
now at low rpm,s it back fires or pops through heavy breather and it seems to stumble and pop at 75 mph at around 3k rpms ,,like it will surge forward then feel like it is being held back.weird thing it wasnt like this before or after that ecm flash months back
mydime is offline  
 
post #4 of 7 (permalink) Old 06-10-2017, 10:34 AM
Life Member
 
Thermodyne's Avatar
 
Join Date: Jan 2014
Location: South Central PA
Posts: 1,764
Garage
Check it for codes, it might just tell you what it's issue is.

Other than that, has all the maintenance been done, new plugs and such. Plug wires checked.

It could be a lot of stuff. Way to much for poking and hoping. Bad crank sensor, bad coil, fuel pump issues, vacuum leak.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Thermodyne is offline  
post #5 of 7 (permalink) Old 06-10-2017, 10:38 AM Thread Starter
Newbie
 
mydime's Avatar
 
Join Date: Sep 2015
Posts: 8
hmm well it has new plugs and the 10 mm SE wires ,they are new.
maintenance is done,
thought it might have something to do with the tca behind the air cleaner
mydime is offline  
post #6 of 7 (permalink) Old 06-11-2017, 09:22 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
The first thing I would check is the vacuum stem on the top of the throttle body, if the cap is broken or missing then you could have running issues. Is the bike still under warranty ? If so this may be a good time to use it.
mydime likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #7 of 7 (permalink) Old 06-12-2017, 12:56 PM Thread Starter
Newbie
 
mydime's Avatar
 
Join Date: Sep 2015
Posts: 8
i think i might have found my problem
when i took my air breather off i noticed my gasket was not sealed completely at the bottom of the throttle body to the air cleaner.i have yet to test it but i think maybe that was the problem
mydime is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
5 speed or 6 speed?? Pooh63 *General Road Glide Discussions/Pictures 8 06-22-2017 01:20 PM
Contrast Cut VS Platinum Cut RhinoHD Wheels and Tires 23 02-03-2014 10:27 PM
to cut or not to cut mroach Controls & Handlebars 6 03-06-2012 07:17 PM
Slight front end shake/wobble at low speed smitty901 Troubleshooting for Road Glides 2 04-28-2011 10:59 PM
Low Speed Wobble and New Bars??? jbrawkus Controls & Handlebars 14 04-13-2010 07:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome