Cruise Control ? What do you think ? - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 4Likes
  • 3 Post By Big_gary
  • 1 Post By Arkie
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 03-27-2018, 01:07 PM Thread Starter
Newbie
 
Join Date: Jan 2017
Posts: 25
Cruise Control ? What do you think ?

I am in process of converting Street glide to Road glide - nothing new. But I am trying to put a cruise control on a bike that did not come stock with one, The factory wiring harness by part # is same as the Road glide that came with a cruise. I am swapping the right hand switch lower 1/2 to the correct items. But here is my question. The factory cruise control is N/A from Harley and on ebay I have found several used units. The correct # is 70989-04 and the question is for a 70955-98 obviously the 98 being on the earlier models that came with cruise. They both use the same actuator cable,same factory 10 pin plug by part # and are both Delphi brand. Even though the earlier unit was used with Marilee ignition and injection. I cannot justify the $100 difference between the two units unless someone knows what I am missing as to why 98 would not work where it shows an 04.
Question #2 so my tach does not have the light to tell me if it is turned on. Surely the ECU would not recognize that ? So I just wondered if anyone had a tach light out to know if there were any issues with that scenario.
Any help would be appreciated, Thank you, Arkie
Attached Images
File Type: jpg 20180327_130249.jpg (2.85 MB, 54 views)
File Type: jpg 20180327_130309.jpg (3.17 MB, 49 views)
Arkie is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-27-2018, 04:55 PM Thread Starter
Newbie
 
Join Date: Jan 2017
Posts: 25
The bike I am converting is a 2007. The question is not to do with the cable. The need for Harley digital tech that you described would apply to 2014 and later can bus bikes. Earlier ECM's literally are activated by the handlebar switch telling the function to the ecm and controll module that I am asking about. I really wondered if anyone with a 2013 or earlier with a cruise controll could say if theirs worked without the idiot light in the tach telling you that it was on?
And then if someone had tried the 98 module in anything through 2007. Sorry I was not real clear in my questions. Thank you ,Arkie
Arkie is offline  
post #3 of 9 (permalink) Old 03-27-2018, 07:41 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,055
Garage
Quote:
Originally Posted by Arkie View Post
The bike I am converting is a 2007. The question is not to do with the cable. The need for Harley digital tech that you described would apply to 2014 and later can bus bikes. Earlier ECM's literally are activated by the handlebar switch telling the function to the ecm and controll module that I am asking about. I really wondered if anyone with a 2013 or earlier with a cruise controll could say if theirs worked without the idiot light in the tach telling you that it was on?
And then if someone had tried the 98 module in anything through 2007. Sorry I was not real clear in my questions. Thank you ,Arkie
My 2010 came without CC . With TBW , all I had to do was add the rocker switch and change out the right side handlebar control housing. I was told by the dealer it needed flashed, but it didn't. I don't know if it was already flashed , or it just sensed the CC and automatically activated.
PS. The CC light in the tach works too.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.

Last edited by Big_gary; 03-27-2018 at 07:44 PM.
Big_gary is offline  
 
post #4 of 9 (permalink) Old 03-27-2018, 08:35 PM Thread Starter
Newbie
 
Join Date: Jan 2017
Posts: 25
Thank you, I am running cables and I do not see how the c/c light could affect the function. I'm just not sure, i want a cruise but sure do not want to buy a Tach just to get a light to make it all work. Then again I don't want to purchase everything else to find out the light is required because of some quirk in the ECM. Thanks again,Arkie - still fishing for an answer !
Arkie is offline  
post #5 of 9 (permalink) Old 03-28-2018, 02:03 AM
Newbie
 
Cobal59's Avatar
 
Join Date: Feb 2013
Posts: 27
Cruise Control ? What do you think ?

I added a cruise control to my 05 road king. When I connected the module and new handle bar switches the bike recognized the cruise and the light came on. Besides the module I had to run a power line to the fuse box. I donít know whats the difference in module year. Good luck.


Sent from my iPhone using Tapatalk
Cobal59 is offline  
post #6 of 9 (permalink) Old 03-28-2018, 07:45 AM Thread Starter
Newbie
 
Join Date: Jan 2017
Posts: 25
Thank you for your input. I will go look at factory manual and look into the power wire. I assumed the factory 10 pin plug connector would have offered a fused power source, but you know about asumming. Appreciate your reply. Thanks Arkie
Arkie is offline  
post #7 of 9 (permalink) Old 03-28-2018, 08:03 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,055
Garage
Quote:
Originally Posted by Arkie View Post
Thank you for your input. I will go look at factory manual and look into the power wire. I assumed the factory 10 pin plug connector would have offered a fused power source, but you know about asumming. Appreciate your reply. Thanks Arkie
Are you sure there's 2 tacs back then and not just one? Like I stated, my bike came w/o CC, and when CC was added, the light in the tac illuminates when CC is engaged.
Bruce00, RGKen and reds4 like this.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #8 of 9 (permalink) Old 03-28-2018, 12:09 PM Thread Starter
Newbie
 
Join Date: Jan 2017
Posts: 25
Thank you Big Gary ! I think you are correct. I had not considered that possibility,I checked factory part #'s and that is true. One tach for everything concerned. So when I hook up the rest of the parts the light should come on ! Thanks again, Arkie
Hope yopu have a great Good Friday and Wonderful Easter !
Big_gary likes this.
Arkie is offline  
post #9 of 9 (permalink) Old 03-29-2018, 09:50 AM
Life Member
 
geo8866's Avatar
 
Join Date: Apr 2017
Location: Eastern Pennsylvania
Posts: 2,170
I would kill to have the mechanical skills you guys have. I love reading these threads just to make myself feel stupid. I'm happy when I change my oil without bumping into the drain pain and getting oil everywhere! You guys never cease to impress me!!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2017 RGS Hard Candy Hot Rod Red Flake
geo8866 is offline  
Reply

Tags
cruise control help ?

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
red cruise light, no cruise piggs Troubleshooting for Road Glides 1 05-08-2014 05:47 PM
What do you think would be a Good Deal? Ofthirty3 Road Glide Specific Discussions 15 03-17-2011 08:17 PM
Check this out! What do you think Sedona Blue *General Road Glide Discussions/Pictures 11 03-06-2011 09:40 PM
What do you guys think? Sedona Blue *General Road Glide Discussions/Pictures 30 12-26-2010 08:03 PM
After you install J&M or other speakers, what do you do with the factory speakers? Black09inOK Do-IT-Yourself 6 10-01-2010 01:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome