Front brake issue on 2016 roadglide - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 1Likes
  • 1 Post By aviscomi
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-10-2018, 07:41 PM Thread Starter
Newbie
 
Sheinen's Avatar
 
Join Date: Dec 2018
Posts: 2
Front brake issue on 2016 roadglide

Need help I recently have had my front brake stop activating the brake light? The rear works fine but my front doesn’t work at all. Could this be the switch?
Sheinen is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-10-2018, 08:35 PM
Hangaround
 
Join Date: Sep 2015
Posts: 67
Garage
It's likely to be the switch. Assuming both bulbs are good of course. Have you done any mods recently that might have damaged the switch like new handlebars, grips, etc. It's easy to damage the switch when changing things up in that area.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
USMCEOD is offline  
post #3 of 5 (permalink) Old 12-10-2018, 11:35 PM
Member
 
BigBlockBobby's Avatar
 
Join Date: Apr 2018
Posts: 467
I agree with USMCEOD.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Good decisions come from experience, and experience comes from bad decisions.
BigBlockBobby is offline  
 
post #4 of 5 (permalink) Old 12-11-2018, 01:26 AM Thread Starter
Newbie
 
Sheinen's Avatar
 
Join Date: Dec 2018
Posts: 2
i did have my bars off.
Sheinen is offline  
post #5 of 5 (permalink) Old 12-11-2018, 05:58 AM
Prospect
 
Join Date: Sep 2018
Location: Philadelphia, PA
Posts: 215
Garage
Quote:
Originally Posted by Sheinen View Post
i did have my bars off.
There's your answer.
BigBlockBobby likes this.

2018 Road Glide Special Wicked Red SVT BoneShaker Exhaust, RCX Tormentor Headers, FP3, Vance & Hines VO2 Naked Air Intake, AIMS Light Force Slave Cylinder, Legends REVO-A Shocks

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
aviscomi is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changed front tire now no front brake??? jrbean1 Troubleshooting for Road Glides 9 07-24-2014 10:05 PM
2012 RoadGlide Ultra Electrical Issue H-Town Defender Troubleshooting for Road Glides 1 07-01-2012 11:38 AM
Brake light, Cruise issue Joker659 Troubleshooting for Road Glides 14 04-24-2012 12:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome