Red Light on after battery change. - Road Glide Forums
Tech Area For Tutorials and Instructional Materials

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-30-2019, 08:54 AM Thread Starter
Newbie
 
FeMoRg's Avatar
 
Join Date: Aug 2016
Posts: 37
Garage
Red Light on after battery change.

I changed the battery on my 2016 RG and after the change out the red light is on and I have no brake lights. Running lights work and blinkers work. Cruise control doesn't work. It does have LED's installed. It is giving me a code for ECM, BCM, and speedometer. It cranks and runs fine. Is there a reset that can be done or could low battery in fob cause the issue...I'm lost on this deal.
FeMoRg is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-30-2019, 09:09 AM
Member
 
Join Date: Apr 2016
Location: Europe
Posts: 445
i think that a run with the DIGITAL TECHNICIAN at dealership will fix the issue. it is possible that the BCM memory connection went lost.
with DT they will be able to troubleshoot the codes as well
Beaver is online now  
post #3 of 12 (permalink) Old 03-30-2019, 09:53 AM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,794
Cruise control probably does not work because the brake lights so not work. Double check your work and inspect your fuses first. You say red light is on, what red light?

2019 Silver Flux/Black Fuse FLTRU
"SLIVER"
BH#103 is offline  
 
post #4 of 12 (permalink) Old 03-30-2019, 10:41 AM
Life Member
 
Thermodyne's Avatar
 
Join Date: Jan 2014
Location: South Central PA
Posts: 1,748
Garage
Did you turn the key on and pull the main fuse before you swapped the battery?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Thermodyne is offline  
post #5 of 12 (permalink) Old 03-30-2019, 02:31 PM Thread Starter
Newbie
 
FeMoRg's Avatar
 
Join Date: Aug 2016
Posts: 37
Garage
Quote:
Originally Posted by BH#103 View Post
Cruise control probably does not work because the brake lights so not work. Double check your work and inspect your fuses first. You say red light is on, what red light?
The red light that is on the speedometer next to the cruise light
FeMoRg is offline  
post #6 of 12 (permalink) Old 03-30-2019, 02:32 PM Thread Starter
Newbie
 
FeMoRg's Avatar
 
Join Date: Aug 2016
Posts: 37
Garage
Quote:
Originally Posted by Thermodyne View Post
Did you turn the key on and pull the main fuse before you swapped the battery?
No I didnt...
FeMoRg is offline  
post #7 of 12 (permalink) Old 03-30-2019, 02:33 PM Thread Starter
Newbie
 
FeMoRg's Avatar
 
Join Date: Aug 2016
Posts: 37
Garage
Quote:
Originally Posted by Thermodyne View Post
Did you turn the key on and pull the main fuse before you swapped the battery?
No I didnt...
FeMoRg is offline  
post #8 of 12 (permalink) Old 03-30-2019, 04:41 PM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,794
Quote:
Originally Posted by FeMoRg View Post
The red light that is on the speedometer next to the cruise light
The weather is still pretty shitty here in Illinois so I have not been on my bike long enough in recent days to have memorized what red light is next to the cruise light on the speedometer. Maybe a picture, is it the battery light?

2019 Silver Flux/Black Fuse FLTRU
"SLIVER"
BH#103 is offline  
post #9 of 12 (permalink) Old 03-30-2019, 04:46 PM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,794
Quote:
Originally Posted by FeMoRg View Post
The red light that is on the speedometer next to the cruise light
The weather is still pretty shitty here in Illinois so I have not been on my bike long enough in recent days to have memorized what red light is next to the cruise light on the speedometer. Maybe a picture, is it the battery light?

2019 Silver Flux/Black Fuse FLTRU
"SLIVER"
BH#103 is offline  
post #10 of 12 (permalink) Old 03-30-2019, 05:26 PM
Life Member
 
Thermodyne's Avatar
 
Join Date: Jan 2014
Location: South Central PA
Posts: 1,748
Garage
Quote:
Originally Posted by FeMoRg View Post
No I didnt...
I'm thinking that might be what caused the issue. Assuming that everything went correctly with the battery and all the cables got back where they belong.

You might try turning it on and pulling the main. Give it a few minutes and put it back in, see what happens.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Thermodyne is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Change and Alarm System+ Instructions? BDMastiff Do-IT-Yourself 5 05-18-2016 06:05 AM
Blue led bling light set (used) HUTMO Sold 6 05-05-2016 10:07 PM
wonder bar light on my glide dosnt light my ride is a glide Troubleshooting for Road Glides 1 07-02-2012 07:18 AM
New Bike - Engine & Battery Light pscan5150 Troubleshooting for Road Glides 15 06-08-2012 05:02 PM
Custom Dynamics Genesis II LED Tail light review Sonar_Chris *General Road Glide Discussions/Pictures 6 11-11-2009 05:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome