What is the oil usage on a 103 per ? mile - Road Glide Forums
Fluids and Lubricants discussion of all fluids and lubricants

 6Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 30 (permalink) Old 09-04-2016, 11:21 PM Thread Starter
Prospect
 
vontoughguy's Avatar
 
Join Date: Aug 2010
Location: Yuba City, Ca
Posts: 217
Garage
Angry What is the oil usage on a 103 per ? mile

I have used up to a qt. in 1000 miles.
I'm being told a qt. every 1000 miles, that seems a lot of oil.
So if that is true in 5,000 mile you have already done a oil change.
Need feed back.
My motor has been pulled apart by dealer 5 times to repair problems. Have been using Syn3.

jjones
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
vontoughguy is offline  
Sponsored Links
Advertisement
 
post #2 of 30 (permalink) Old 09-04-2016, 11:31 PM
Hangaround
 
PsychoCycle's Avatar
 
Join Date: Jul 2016
Location: Edmonton, Alberta
Posts: 58
Let us know the year and how many miles on your bike. I run a 2009 with 50,000 miles and it does not use/burn oil. I do not have to add oil between oil changes but there is a huge difference between these bikes and their oil consumption as you will see as some of the guys chime in.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2009 Road Glide
Red Hot Denim with loads of extras
PsychoCycle is offline  
post #3 of 30 (permalink) Old 09-04-2016, 11:56 PM
Member
 
Join Date: Jul 2015
Location: Vacaville, CA
Posts: 317
My 2013 RG does not use any oil either. I think I added a very small amount once, but over all it is not an issue. Bike has 25K on it, and I doubt if I have even added a Qt over the whole time. if your going through that much oil, you need to find out where it is going. Out the exhaust, on the ground, Out the valve seals, around the rings. Once you know where it is leaking, then you have the chance to fix the problem.

Illegitimus non carburundum. Or something to that effect. Jack of all trades, master of none.
Diverrick is offline  
 
post #4 of 30 (permalink) Old 09-05-2016, 01:33 AM
Grey beard
 
Spazz's Avatar
 
Join Date: Aug 2015
Location: Reno, NV
Posts: 1,178
Garage
Quote:
Originally Posted by vontoughguy View Post
I have used up to a qt. in 1000 miles.
I'm being told a qt. every 1000 miles, that seems a lot of oil.
So if that is true in 5,000 mile you have already done a oil change.
Need feed back.
My motor has been pulled apart by dealer 5 times to repair problems. Have been using Syn3.
I have the 120ST was was using around 1.5 qts per 1000 miles.... they took it down at 7300 miles and replaced the pistons, rings, jugs and rebuilt the heads since the valve guide seals were leaking as well.

What were the readings on the leakdown and compression checks? Sounds like they are avoiding it.... I doubt it has been torn down 5 times and nothing was found... unless you personally saw it torn apart each time... I would be very suspicious.

My jugs were scored, rings never seated and valves stems showed oil deposits and pistons were coated with wet/oily carbon.







Im showing you my teardown to let you see what can be seen when they tear it down.... you should have deposits like this on the pistons and valves at least, which means SOMETHING is wrong.

I have over 11K on it now... all is good
reds4 likes this.

2015 RGS 120ST | D&D Boss Boarzilla | 4.5" Topshop Ass | Soundz SS4.100 amp, HD-DSP ,(4) Carbon 65's and Iron 69.2's
RENO BAGGER AUDIO

Last edited by Spazz; 09-05-2016 at 01:36 AM.
Spazz is offline  
post #5 of 30 (permalink) Old 09-05-2016, 02:01 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 7,925
Garage
Almost 40k and not a drop.Even running across country, it never used a drop.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #6 of 30 (permalink) Old 09-05-2016, 05:20 AM
Member
 
cookie114's Avatar
 
Join Date: Sep 2015
Location: Cornelia GA
Posts: 492
Garage
My 13 with 17k on it uses about 1 qt-1.5 qt in 4000 miles. Its uses mainly when riding on the freway at higher speeds. It wont hardly use a drop until then. Its been doing that since I got it in September 2015 with 5000 miles on it. I hate it but its just how tje cookie crumbled because its not enough usage to have anything done about it under ESP. This is the first out of six harleys I've had to use any.

2013 FLTRX, stage 1 w/vance and hine power duals and rinehart slipons, TTS mastertune and some other odds and ins. Long ways to go
cookie114 is offline  
post #7 of 30 (permalink) Old 09-05-2016, 05:30 AM
Life Member
 
RFG7680's Avatar
 
Join Date: Jul 2015
Location: North East Ohio
Posts: 3,133
Garage
My 08 used 1 to 1.5qts every 2k. Did it from day 1 to 45k. My 11 used a qt every 1500ish. Only had that 11 months and put on 7k. My 16 with 6k has not used a drop in between the 2 services so far.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

"That which we manifest is before us."
BUYER BEWARE @ BATTLEFIELD HARLEY IN GETTYSBURG PA.
RFG7680 is online now  
post #8 of 30 (permalink) Old 09-05-2016, 06:30 AM
Life Member
 
mastergunnera8's Avatar
 
Join Date: Dec 2011
Location: Northern Virginia
Posts: 1,648
5 times? Dang, what year is it? Check the lemon law where you're at...my 2010 doesnt use anything between changes, 28K miles...

If you love your freedom, thank a Vet!!
2016 RGU Superior Blue...with a bunch of stuff..
mastergunnera8 is offline  
post #9 of 30 (permalink) Old 09-05-2016, 07:36 AM
Member
 
staush's Avatar
 
Join Date: Jan 2011
Location: LAS VEGAS,NV
Posts: 593
Oil usage

My 2005 had 58k on it and my 2011 has 41k on it. They both used about 1/2 qt. between 5k oil changes.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2011 Road- Glide Custom-stock engine w/K&N air filter. I like it quiet.
staush is offline  
post #10 of 30 (permalink) Old 09-05-2016, 09:28 AM
Administrator
 
JacktheBagger's Avatar
 
Join Date: Apr 2010
Location: Bama
Posts: 9,305
Garage
Mine has over 50000 and uses very little , most of mine is blown out because of high speed interstate running , I added 12 ounces last week to bring it up to the middle of the hash marks and the oil has 6500 miles on it ....

So Many Highways So Little Time
2011 Ultra
JacktheBagger is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Spark Plug Usage Top Gun *General Road Glide Discussions/Pictures 16 09-24-2017 05:24 PM
RG Miles per year bagger51 *General Road Glide Discussions/Pictures 82 02-24-2015 10:19 AM
My 95's Oil Usage Mystery(sort of) hawk06Glide Engine Related 20 02-11-2015 11:54 AM
data usage and schmartt phones JacktheBagger GPS 14 01-28-2015 06:11 AM
PER Forum: TracyB Happy Birthday! FLTRXS18 *General Road Glide Discussions/Pictures 33 12-17-2010 12:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome