rpms didn't go down after letting off throttle. - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-22-2015, 09:27 AM Thread Starter
Hangaround
 
Join Date: Nov 2013
Location: Fort Worth Tx.
Posts: 66
Garage
rpms didn't go down after letting off throttle.

Thismorning i walked out and cranked my bike while standing beside it. I twisted the throttle and raced it upand let go. It didn,t spring back like itshould and the engine reved high. I twisted it back and it came down toidle. I shut offthe inition and did it again the throttletwisted back slowly. Didn't springback. It is a 13 RG ULTRA. Isit the throttle sensor.
Straitline is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-22-2015, 09:42 AM
Hangaround
 
Claudiov's Avatar
 
Join Date: Jun 2014
Location: McAllen, TX
Posts: 85
Sounds like your throttle grip could possibly be getting stuck. I've had that issue, I just put some WD-40 and problem solved.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Colt .45...Absolutely NEVER leave home without it.
Claudiov is offline  
post #3 of 7 (permalink) Old 03-22-2015, 09:45 AM Thread Starter
Hangaround
 
Join Date: Nov 2013
Location: Fort Worth Tx.
Posts: 66
Garage
Ill give that a try. Thanks
Straitline is offline  
 
post #4 of 7 (permalink) Old 03-22-2015, 09:50 AM
Life Member
 
Ohiobellboy's Avatar
 
Join Date: Nov 2012
Location: Canton, oHIo
Posts: 4,703
I had a little burr on my handlebars on my '11 causing it to stick. Pulled the grip, hit it with some fine sandpaper and problem solved. Another thing could be the grip is pushed in against the control housing causing a slight bind.

A.K.A OBB
Check out the Ohio Glide Riders community page:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ohiobellboy is offline  
post #5 of 7 (permalink) Old 03-22-2015, 09:56 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
WD 40 isn't going to help. Did you do any work to the switch housing or throttle grips lately.
It sound like the throttle grip is in to tight on the TGS (Twist Grip Sensor) loosen the switch assembly a little and slide the throttle grip out about a 1/16 to a 1/8 of a inch then tighten everything down.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #6 of 7 (permalink) Old 03-22-2015, 10:13 AM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,263
Garage
I had a similar problem recently, it ended up being the intake gasket on the TB.

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
post #7 of 7 (permalink) Old 03-22-2015, 10:34 AM Thread Starter
Hangaround
 
Join Date: Nov 2013
Location: Fort Worth Tx.
Posts: 66
Garage
I took the the brake and the twist grip off and checked the throttle position indicator for spring back return. There was no problem there. So I put it back together and it working just fine now. Thanks for the info brothers.
Straitline is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Some go Black Some go Chrome I go my way BACA POPEYE *General Road Glide Discussions/Pictures 66 06-21-2019 09:58 AM
Very loud clank when shifting or getting on throttle or letting off throttle Callahan69 Engine Related 28 11-14-2016 01:09 PM
Thinking of letting Candy go!! g1shadow *General Road Glide Discussions/Pictures 21 01-15-2016 08:32 PM
Spring cleaning so I'm letting some things go Othello7213 Parts for Sale 27 05-02-2013 08:46 PM
2005 Roadglide starting to sputter between 2500-3000 rpms Hawkydog Troubleshooting for Road Glides 5 09-14-2012 09:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome