Power Vision works intermittently - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-27-2015, 08:24 AM Thread Starter
Life Member
 
elbohead's Avatar
 
Join Date: Oct 2012
Location: Rhode Island, USA
Posts: 1,874
Power Vision works intermittently

I like to keep my PV mounted on the bike to use the gauges while riding. The engine temp and gear indicator gauges specifically. I've been having issues lately where they go blank after a short period of time. By this I mean the screen still reads "Engine Temp" and "Gear" but there are no longer numeric values. The only way to reset is to pull the connection, and plug it back in. Or shut the bike off and start over.

Occasionally, all will be fine for 30 minutes or more, but most times this happens after only a minute or two.

Anyone else run into this problem?

Thanks!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2012 FLTRX, BBP, 13" MadStad, Fuel Moto Pro Billet AC and 4" Dyno Tuned Jackpots, catless header, DinoJet Power Vision, Horizon Helibars, Iron Aces mount, HD Aileron grips, Ward's cooling fans, Mustang Wide Tripper solo, CD Plasma Rods and LED turns...
elbohead is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-27-2015, 08:32 AM
Life Member
 
tdkkart's Avatar
 
Join Date: Jun 2011
Location: East Central Iowa
Posts: 3,042
Garage
Where do you have the cable running up to the bars. Lock-ups cause by electrical interference are quite common if the cable is just tucked up over the motor under the tank. Too close to the plug wires.
I've had mine running on the bars for thousands of miles. Had problems initially when the cable was temporarily installed. Once I pulled the tank and ran the cable through the wiring tray under the tank I've never had another problem.

2015 RGU CVO........under continuous change......
tdkkart is offline  
post #3 of 8 (permalink) Old 05-27-2015, 08:48 AM
Grey beard
 
Join Date: Apr 2013
Location: lawnguyland
Posts: 1,461
Quote:
Originally Posted by tdkkart View Post
Where do you have the cable running up to the bars. Lock-ups cause by electrical interference are quite common if the cable is just tucked up over the motor under the tank. Too close to the plug wires.
I've had mine running on the bars for thousands of miles. Had problems initially when the cable was temporarily installed. Once I pulled the tank and ran the cable through the wiring tray under the tank I've never had another problem.
this was exactly my problem when I first installed mine and had the same symptoms that you are having!!!

2013 RGU, black of course....
y2kflhr is offline  
 
post #4 of 8 (permalink) Old 05-27-2015, 09:05 AM Thread Starter
Life Member
 
elbohead's Avatar
 
Join Date: Oct 2012
Location: Rhode Island, USA
Posts: 1,874
Thanks for the help. It is appreciated!

Here is a pic of the PV wire coming out from the side cover and running on top of the tank. Should I pull the tank and run it underneath?



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2012 FLTRX, BBP, 13" MadStad, Fuel Moto Pro Billet AC and 4" Dyno Tuned Jackpots, catless header, DinoJet Power Vision, Horizon Helibars, Iron Aces mount, HD Aileron grips, Ward's cooling fans, Mustang Wide Tripper solo, CD Plasma Rods and LED turns...
elbohead is offline  
post #5 of 8 (permalink) Old 05-27-2015, 09:22 AM
Grey beard
 
Join Date: Apr 2013
Location: lawnguyland
Posts: 1,461
no that is the way it should be run, is it possible the cable is kinked?

2013 RGU, black of course....
y2kflhr is offline  
post #6 of 8 (permalink) Old 05-27-2015, 09:33 AM Thread Starter
Life Member
 
elbohead's Avatar
 
Join Date: Oct 2012
Location: Rhode Island, USA
Posts: 1,874
Quote:
Originally Posted by y2kflhr View Post
no that is the way it should be run, is it possible the cable is kinked?
Maybe. I'll check it from end to end.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2012 FLTRX, BBP, 13" MadStad, Fuel Moto Pro Billet AC and 4" Dyno Tuned Jackpots, catless header, DinoJet Power Vision, Horizon Helibars, Iron Aces mount, HD Aileron grips, Ward's cooling fans, Mustang Wide Tripper solo, CD Plasma Rods and LED turns...
elbohead is offline  
post #7 of 8 (permalink) Old 05-27-2015, 09:44 AM
PGR
GONE BUT NOT FORGOTTEN
 
PGR's Avatar
 
Join Date: Aug 2010
Location: Western Illinois
Posts: 2,338
Garage
Here's who you need to ask

http://www.dynojet.com/powervision/p...ontact-us.aspx








......................
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ron..........................


........2011 Cool Blue Pearl FLTRX........
.............RoboGlide .............


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PGR is offline  
post #8 of 8 (permalink) Old 05-27-2015, 10:00 AM
Hangaround
 
quikcarl61's Avatar
 
Join Date: Jun 2013
Location: North Carolina
Posts: 131
That's the way I ran mine and have had zero problems, also using the Iron Aces mount
quikcarl61 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
$799 Power Package Street Outlaw mufflers, Power Vision, FM Stage 1 AC fuelmoto Fuel Moto 7 06-16-2018 02:37 PM
LED's, power commander, power vision, and other items for touring models. Gasitman Parts for Sale 5 08-23-2014 12:29 AM
Engine skips on roll-on after deceleration intermittently. KiloGolf4 Engine Related 4 08-19-2014 09:53 PM
Cruise control working intermittently? motodrummer Controls & Handlebars 4 03-23-2012 07:31 AM
Power Command Power Vision problem help! BigDave55 ECM/Fuel Management systems 11 08-06-2011 07:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome