Disconnect the PC III?? - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

 3Likes
  • 2 Post By fuelmoto
  • 1 Post By Smarty
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-02-2016, 01:41 PM Thread Starter
Life Member
 
Join Date: Jun 2012
Location: Pac NW
Posts: 4,091
Disconnect the PC III??

figured I'd ask first, really in doubt

So 03 FLTri, 95in, stock cams, open KN, Hooker exh (left side to T, rt side to HP), 99k^miles on motor

lil things like polished heads when doing rocker covers and other gaskets long time ago, put new fuel injectors in @ 50k.....

Anyway wanted to see if I disconnected the pcIII and road it around TO see if there is a difference,

I suspect it was never maped right back in '05, or mapped at all, other than my setting it to take it to get dynoed, never noticed much difference after, pinged some so I may have made it right then? or just running even way back then

I mean the leds run up and down fine, but always lean

WIll the pcIII when reconnected know a difference, I've long lost the maps and instructions (and a pc set up to check)

So ??, I can plug the bike back into stock TO SEE, then If I want put the pcIII back....No Harm No Foul?
reds4 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-02-2016, 02:30 PM
EFI tuning and Exhaust Expert
 
fuelmoto's Avatar
 
Join Date: Dec 2010
Posts: 806
Quote:
Originally Posted by reds4 View Post
figured I'd ask first, really in doubt

So 03 FLTri, 95in, stock cams, open KN, Hooker exh (left side to T, rt side to HP), 99k^miles on motor

lil things like polished heads when doing rocker covers and other gaskets long time ago, put new fuel injectors in @ 50k.....

Anyway wanted to see if I disconnected the pcIII and road it around TO see if there is a difference,

I suspect it was never maped right back in '05, or mapped at all, other than my setting it to take it to get dynoed, never noticed much difference after, pinged some so I may have made it right then? or just running even way back then

I mean the leds run up and down fine, but always lean

WIll the pcIII when reconnected know a difference, I've long lost the maps and instructions (and a pc set up to check)

So ??, I can plug the bike back into stock TO SEE, then If I want put the pcIII back....No Harm No Foul?
Assuming it was tuned correctly back in 2005, the bike was maintained properly and there are no mechanical issues there would have been no real reason to adjust the PC III along the way, nothing should have changed tune wise and everything should continue to work as normal. I would advise against removing the unit and riding the bike unless it is a very short test, with your 95" kit you run the risk of damage from an extreme lean condition running off the stock EFI calibration.
reds4 and Smarty like this.

Jamie Long / Fuel Moto USA

Dynojet Power Vision info is here
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


The USA's source for EFI Tuning, exhaust, & engine components

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Contact 920-423-3309
Email
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
fuelmoto is offline  
post #3 of 5 (permalink) Old 02-02-2016, 03:25 PM
Grey beard
 
mocotom's Avatar
 
Join Date: May 2012
Location: Pa
Posts: 1,110
Like Jamie said you will be running very lean on the stock ecm calibration. You added 7 additional cubic inches with the big bore kit. That is a lot more air passing thru the motor and your 2003 Delphi system has no sensors to help the ecm make fuel adjustments for that extra volume.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2005 RG 98cu in
USMC 1968-1972
mocotom is offline  
 
post #4 of 5 (permalink) Old 02-02-2016, 05:00 PM Thread Starter
Life Member
 
Join Date: Jun 2012
Location: Pac NW
Posts: 4,091
Thanks^^

Makes sense, just had the urge

Just looking for something fix to Not break, as it goes

"with your 95" kit you run the risk of damage from an extreme lean condition running off the stock EFI calibration".

Has had 95" from mile one....I put the PC in '05, plugs have always looked good (little lean)

Did the Dealership (closed long ago) change the unit when they installed the 95 kit???
think Iam over thinking FI

Last edited by reds4; 02-02-2016 at 05:13 PM.
reds4 is offline  
post #5 of 5 (permalink) Old 02-02-2016, 05:41 PM
Life Member
 
Smarty's Avatar
 
Join Date: Apr 2015
Location: Royse City, Texas
Posts: 2,928
Quote:
Originally Posted by reds4 View Post
Thanks^^

Makes sense, just had the urge

Just looking for something fix to Not break, as it goes

"with your 95" kit you run the risk of damage from an extreme lean condition running off the stock EFI calibration".

Has had 95" from mile one....I put the PC in '05, plugs have always looked good (little lean)

Did the Dealership (closed long ago) change the unit when they installed the 95 kit???
think Iam over thinking FI
If you just want to tinker with it. Get online and download the power commander programing data base, look up your build and pipes, and download it to your unit. You never know with data, some could be messed up or whatever. I would do it for piece of mind.
reds4 likes this.
Smarty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
PC III USB issue on install Mvfdfire Tech Area 3 12-02-2012 12:00 PM
PC III USB issue on install Mvfdfire ECM/Fuel Management systems 3 12-01-2012 02:30 PM
pc iii map needed 07 deluxe with 48cam bigpete1 Map Section 1 06-25-2012 07:53 AM
Pc iii #818-510 RTWRK Classifieds Archive (3 months old+) 0 07-19-2011 08:41 AM
Map for PC III USB for 06 RG kimmer127 ECM/Fuel Management systems 2 10-15-2010 03:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome