Power Vision Troubles - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 02-17-2016, 08:55 PM Thread Starter
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Power Vision Troubles

Brand new PV and it doesn't seem to like my bike.
I hooked up the PV cable to the Diagnostic port on my 08 FLTR and now when I turn the bikes ignition to "ON" I get "BUS ERROR" showing up in the odometer. When I start the bike I automatically get the U1301 DTC in all sections of the Diag except for "P" , U1301 is serial data error.
In the "P" section of the diag I get P0132 & P0152 which is front and back O2 sensors high open. I can understand the O2 sensors may be bad so I order new ones and I am waiting on them, but what I can't understand is these O2 sensors worked when I took them out and installed the Thundermax O2 sensors so why wouldn't they still work when I put them back in and also what is the chance of both O2 sensors going bad at the same time and why would they go bad sitting in the box with the stock ECM.
By the way I am using the stock ECM.
Now for the kicker I UNHOOK the PV data cord at the diagnostic port and everything works just dandy, no more BUS ERROR, no more DTC's but I haven't rode the bike yet so the O2 sensor DTC's may or may not pop up we will have to see. I did try unhooking the PV data cord from the PV module but it didn't do a thing to solve the problem.
Do I have a bad PV data cord? I did run the cord under the dash on the fuel tank as suggested by Fuel Moto and it didn't help a thing either, when riding the bike the PV gauges kept going out and I would have to reset them all the time.
Anyone else have these problems or am I the first?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-17-2016, 09:37 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,175
Garage
Your probably the first. . Subscribed.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 9 (permalink) Old 02-17-2016, 10:48 PM
EFI tuning and Exhaust Expert
 
fuelmoto's Avatar
 
Join Date: Dec 2010
Posts: 812
Quote:
Originally Posted by ironmark View Post
Brand new PV and it doesn't seem to like my bike.
I hooked up the PV cable to the Diagnostic port on my 08 FLTR and now when I turn the bikes ignition to "ON" I get "BUS ERROR" showing up in the odometer. When I start the bike I automatically get the U1301 DTC in all sections of the Diag except for "P" , U1301 is serial data error.
In the "P" section of the diag I get P0132 & P0152 which is front and back O2 sensors high open. I can understand the O2 sensors may be bad so I order new ones and I am waiting on them, but what I can't understand is these O2 sensors worked when I took them out and installed the Thundermax O2 sensors so why wouldn't they still work when I put them back in and also what is the chance of both O2 sensors going bad at the same time and why would they go bad sitting in the box with the stock ECM.
By the way I am using the stock ECM.
Now for the kicker I UNHOOK the PV data cord at the diagnostic port and everything works just dandy, no more BUS ERROR, no more DTC's but I haven't rode the bike yet so the O2 sensor DTC's may or may not pop up we will have to see. I did try unhooking the PV data cord from the PV module but it didn't do a thing to solve the problem.
Do I have a bad PV data cord? I did run the cord under the dash on the fuel tank as suggested by Fuel Moto and it didn't help a thing either, when riding the bike the PV gauges kept going out and I would have to reset them all the time.
Anyone else have these problems or am I the first?
As I noted in your other thread last week please update your firmware, if you are getting a bus error the newest firmware will 100% take care of your issues. You are welcome to call me tomorrow and i can assist if necessary

Jamie Long / Fuel Moto USA

Dynojet Power Vision info is here
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


The USA's source for EFI Tuning, exhaust, & engine components

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Contact 920-423-3309
Email
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
fuelmoto is offline  
 
post #4 of 9 (permalink) Old 02-18-2016, 12:18 PM Thread Starter
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
I did update the firmware and I just linked the PV module to my PC and checked again and I am currently running the current firmware version.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #5 of 9 (permalink) Old 02-18-2016, 12:23 PM Thread Starter
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Quote:
Originally Posted by Big_gary View Post
Your probably the first. . Subscribed.
Someone has to be the first.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #6 of 9 (permalink) Old 02-18-2016, 12:36 PM
EFI tuning and Exhaust Expert
 
fuelmoto's Avatar
 
Join Date: Dec 2010
Posts: 812
Quote:
Originally Posted by ironmark View Post
I did update the firmware and I just linked the PV module to my PC and checked again and I am currently running the current firmware version.
Email me [email protected] and I will send you the firmware patch that will fix it.

Jamie Long / Fuel Moto USA

Dynojet Power Vision info is here
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


The USA's source for EFI Tuning, exhaust, & engine components

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Contact 920-423-3309
Email
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
fuelmoto is offline  
post #7 of 9 (permalink) Old 02-20-2016, 11:21 AM Thread Starter
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
I was running the current firmware but Jamie sent me a firmware upgrade which is designed to help with the "BUS ERROR" and U1301 DTC and I installed it and so far so good.
I am still getting the O2 DTCs but less often so I am going to do a few auto tune rides and see if that helps, if that doesn't work I'll put in the new O2 sensors and see what happens.
The folks at Fuel Moto are a great bunch of people to work with.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #8 of 9 (permalink) Old 02-22-2016, 11:23 AM Thread Starter
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Put some miles on the bike this weekend and I am still having problems with the Power Vision. The "Bus Error" doesn't come up when I turn the bike ignition on but I am still getting the U1301 DTC along with the P0132 DTC also getting turn signals and speedometer under the serial data error. Put new O2 sensors in so I took that out of the equation. Also when the Power Vision data cord is unplugged from the bikes data port all the DTC's but the P0132 go away so I am thinking that since the front cylinder is running rich it may be a tune issue.
The good folks at Fuel Moto are looking into the problem.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #9 of 9 (permalink) Old 03-21-2016, 12:47 PM
Prospect
 
Join Date: May 2010
Posts: 206
Ironmark,

Were you able to get your problem resolved?
bbass is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
$799 Power Package Street Outlaw mufflers, Power Vision, FM Stage 1 AC fuelmoto Fuel Moto 7 06-16-2018 03:37 PM
LED's, power commander, power vision, and other items for touring models. Gasitman Parts for Sale 5 08-23-2014 01:29 AM
Inner Fairing troubles Mailman Paint & Bodywork Section 20 04-09-2012 01:38 AM
More monkey bar troubles homeboy58 Controls & Handlebars 11 11-21-2011 07:46 PM
Power Command Power Vision problem help! BigDave55 ECM/Fuel Management systems 11 08-06-2011 08:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome