I've got a glitch - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-18-2013, 07:25 PM Thread Starter
Prospect
 
Join Date: Aug 2011
Posts: 219
I've got a glitch

I'll try to keep it short. Installed dual head pipes and a Fuel Moto PCIII tuner w/aircleaner. Tuner came loaded with map per my specs on pipes, a/c, etc. Intermittent stumbling at warmup and at hot idle. Quit completely after slowing to pull into a gas station. Restarts and runs perfectly at speed and all rpm ranges. 2008 RG w/TBW, reset with the 3 cycles of ignition switch method. Checked new intake gasket, retorqued exhaust flange nuts, checked battery terminals. Bike has been garaged with 100% full tank of fuel with Sta-Bil added. No issues until I made the mods. I've got a note in for Jamie or Keith @ FuelMoto, but thought I might get some input here. Thanks.
xshovelfreak is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-18-2013, 07:36 PM
Life Member
 
Triplej's Avatar
 
Join Date: Oct 2011
Location: Nevada, TX
Posts: 5,434
Any warning light or codes showing up?

https://www.roadglide.org/showthread.php?t=4439

If yes this will tell you what they are.

https://www.roadglide.org/showthread.php?t=5748

Might be worth a try unhooking the PCIII and checking all the connections and pins to make sure nothing got bent during the install. When reinstalling the PC its a good idea to use Dielectric Grease on the connections as well.

Good luck and let us know if you find anything.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Triplej is offline  
post #3 of 4 (permalink) Old 02-18-2013, 07:50 PM Thread Starter
Prospect
 
Join Date: Aug 2011
Posts: 219
Quote:
Originally Posted by Triplej View Post
Any warning light or codes showing up?

https://www.roadglide.org/showthread.php?t=4439

If yes this will tell you what they are.

https://www.roadglide.org/showthread.php?t=5748

Might be worth a try unhooking the PCIII and checking all the connections and pins to make sure nothing got bent during the install. When reinstalling the PC its a good idea to use Dielectric Grease on the connections as well.

Good luck and let us know if you find anything.
No codes, but I was only able to put about 30 miles on it. I think if it was going to throw a code it would do it quicker than that. Will check the plugs on the PC again, already put the Di grease on while installing.
xshovelfreak is offline  
 
post #4 of 4 (permalink) Old 02-19-2013, 03:43 AM
Grey beard
 
FrankieB's Avatar
 
Join Date: May 2011
Location: Kentucky
Posts: 809
Pull the PC3 off and see if the bike runs the same. If it runs the same then the problem isn't the pc3, if the bike runs better then the pc3 map probably needs tweeking .

06 RK
11 RGU
FrankieB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I found a glitch in the matrix today MarkL *General Road Glide Discussions/Pictures 4 05-22-2017 10:30 AM
"Hey...! You've got space in your saddlebags, right?" garvin90 *General Road Glide Discussions/Pictures 36 12-12-2012 07:18 PM
I've got this sickness HogBreath New Members Welcome Area 20 05-31-2011 08:07 AM
1913 HD You've got to see! pfoushee Road Glide Specific Discussions 8 01-20-2011 04:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome