Right muffler turning gold already - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 03-20-2011, 12:07 AM Thread Starter
Newbie
 
Join Date: Feb 2011
Location: Sun Prairie, WI
Posts: 3
Question Right muffler turning gold already

2011 FLTRU, only 250 miles on the bike, I had Bassani Reverse Megaphone slip-on's put on at the dealership with an SE Stage I air cleaner and a "download". I get "pops" when I rev the motor and I've even had a couple of them during normal decelleration. I also noticed tonight after only 250 miles on the bike, the right slip-on is already turning gold where it meets the stock headers.

I'm no mechanic, but I think all this means I'm running way lean ... I'm just wondering what that means long term. Should I inspect the plugs already? Do I spend even more money now on headers, SE SuperTuner and dyno tune? Is there a less expensive way to fix this? And is there a way I can tell if the dealership actually performed the "download"?

Last edited by FishGlide; 03-20-2011 at 12:09 AM.
FishGlide is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 03-20-2011, 12:35 AM
GONE BUT NOT FORGOTTEN
 
Join Date: Oct 2010
Location: Sacramento Ca.
Posts: 3,813
I'm sure you plan on taking it back to the dealer that did the work. You didn't say when it started to pop. You paid good money for the work. They need to make it right. I had BUB 7 & se A/C & remapped on my 07 & never had any of the problems you mentioned. I'm sure someone else will give you some info. Good luck.
Hillglide is offline  
post #3 of 22 (permalink) Old 03-20-2011, 06:50 AM
Life Member
 
hotrodad's Avatar
 
Join Date: Feb 2010
Location: Ontario, Canada
Posts: 2,017
Garage
I'm sure the dealer will give you the usual response 'that's how all Harleys are' so be ready and don't accept it. They do run lean and that is one reason of the popping on decell. Another reason could be air leaks in the exhaust. If you hear popping when you rev it that is my guess. Either a manifold gasket got displaced when the Bassinis were installed or they didn't bother putting new manifold gaskets in thinking they'd get away with it being almost new. (if they had the headers off) There are ways to fix the lean problem but it means spending money. Get after the dealer and see what they can do for you.

2005 FLTRi
Black Pearl
Live to Ride ~ Ride to Live
hotrodad is offline  
 
post #4 of 22 (permalink) Old 03-20-2011, 07:12 AM
Newbie
 
The instigator's Avatar
 
Join Date: Dec 2010
Location: To far from the Sun Edinburgh, Scotland
Posts: 33
I had the same problem on a 07 Ultra Classic. It all started when I fitted the stage 1 to the bike using VH turned down pipes along with VH fuel pak and air fitter. I was told by VH that this was caused by the motor running to lean, which also made it run hotter than it would on leaded fuel.
This was noticeable on the right hand pipe due to it only having a single wall. A few friends using the same set up with twin walled pipes where fine as the excessive heat never reached the outer wall.
I was told by VH there was no fix.
The instigator is offline  
post #5 of 22 (permalink) Old 03-20-2011, 08:02 AM
Prospect
 
easyrider9809's Avatar
 
Join Date: May 2010
Location: Wisconsin
Posts: 248
Quote:
Originally Posted by FishGlide View Post
2011 FLTRU, only 250 miles on the bike, I had Bassani Reverse Megaphone slip-on's put on at the dealership with an SE Stage I air cleaner and a "download". I get "pops" when I rev the motor and I've even had a couple of them during normal decelleration. I also noticed tonight after only 250 miles on the bike, the right slip-on is already turning gold where it meets the stock headers.

I'm no mechanic, but I think all this means I'm running way lean ... I'm just wondering what that means long term. Should I inspect the plugs already? Do I spend even more money now on headers, SE SuperTuner and dyno tune? Is there a less expensive way to fix this? And is there a way I can tell if the dealership actually performed the "download"?
Sounds like whatever the dealer downloaded is not giving your motor the proper fuel/air ratios thru certain rpms. I would take it back to the dealer to see if they can get it right. Your slip-on should not be turning brown on 50 degree day in March. These new bikes are set very lean out of the factory and will run hot. With the addition of the stage one air cleaner, you could be running even leaner. Long term....getting tuner like a SE SuperTuner, TTS, or Power Commander will reap benefits. The dyno tuner you select will probably have a preference of a certain tuning software that they feel comfortable with or have experience to tune that could be part of your decision.
easyrider9809 is offline  
post #6 of 22 (permalink) Old 03-20-2011, 08:53 AM
Member
 
hodgeaaco's Avatar
 
Join Date: Dec 2009
Location: Maryland
Posts: 395
Sounds like there may be an exhaust leak somewhere. A slip-on should not cause that much of an issue, especially since you still have the stock header and cats. The catalytic converters are a big part of the issue with the pipes turning gold. My head pipes were blue and gold by the time I got home from the dealer (20 miles) and that was with an HD nightstick with open end pipe, SE AC, and the download, but I didn't have any popping.

Short of it is, yes, the bikes run lean and will cause some popping on decel when you change parts, but it sounds like you may have a leak somewhere. The short-term fix is take it back to the dealer to check all of the gaskets and bolts. Long-term fix is to get yourself a tuner; PC-V, TTS, HD SE, etc.

2010 FLTRX - "Black Plague"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hodgeaaco is offline  
post #7 of 22 (permalink) Old 03-20-2011, 01:28 PM
Newbie
 
firerodder's Avatar
 
Join Date: Jan 2011
Location: Athens, GA.
Posts: 28
I'm no mech. either.... but if the bike "pops" on decel, wouldn't that be a cause from too much unburned fuel?? The unburned tends to be caused by richer conditions instead of lean. My '07 runs a bit on the rich side and you can always tell this after a longer ride due to the black powdery residue on the rear of the bags. I'd like to get tuned leaner and extend my range... I enjoy the comments either way, just my $.02
firerodder is offline  
post #8 of 22 (permalink) Old 03-20-2011, 01:44 PM
Member
 
Join Date: Apr 2010
Posts: 559
Quote:
Originally Posted by hodgeaaco View Post
Sounds like there may be an exhaust leak somewhere. A slip-on should not cause that much of an issue, especially since you still have the stock header and cats. The catalytic converters are a big part of the issue with the pipes turning gold. My head pipes were blue and gold by the time I got home from the dealer (20 miles) and that was with an HD nightstick with open end pipe, SE AC, and the download, but I didn't have any popping.

Short of it is, yes, the bikes run lean and will cause some popping on decel when you change parts, but it sounds like you may have a leak somewhere. The short-term fix is take it back to the dealer to check all of the gaskets and bolts. Long-term fix is to get yourself a tuner; PC-V, TTS, HD SE, etc.
what kind of exhaust are you running
Jerry W. is offline  
post #9 of 22 (permalink) Old 03-20-2011, 02:30 PM
Member
 
hodgeaaco's Avatar
 
Join Date: Dec 2009
Location: Maryland
Posts: 395
Quote:
Originally Posted by WAACKO1%ER View Post
what kind of exhaust are you running
I have the Rush 2-1.

2010 FLTRX - "Black Plague"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hodgeaaco is offline  
post #10 of 22 (permalink) Old 03-20-2011, 04:02 PM
Hangaround
 
Join Date: Dec 2010
Posts: 71
The harley stage 1 download only works with harley parts, ie, se a/c, and se slip ons. If you use different slip ons, then the download is not matched to those mullfers, hence, this could be the issue because it is likely that the harley slip ons don't flow as well as the ones you put on. I've got the harley se a/c, stage 1 down load, and the se slip ons and everything works great.

2009 Road Glide
Black Pearl, ABS, Security, and Cruise
Stage 1 A/C, download, and SE Slipon's
S&S Flywheel-balanced and welded
Timken Bearings in the case
Progressive 412 12" shocks
2011 Seat.

Last edited by jcanrun; 03-20-2011 at 04:05 PM.
jcanrun is offline  
Reply

Tags
decel pop , download , lean , muffler bluing

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Swapping D&D Louvered baffle muffler out for the wrapped perforated muffler question bigshaqa Intake and Exhaust 6 03-25-2016 02:23 PM
Dragula Chrome Muffler (Only the Muffler) for Sale Tytanium Parts for Sale 8 08-30-2014 07:39 PM
Rinehart Slip Ons turning yellow? REDRUM Intake and Exhaust 16 01-06-2014 09:49 PM
Survived a left turning car. akjeff Safety Area 21 09-14-2013 09:47 PM
Muffler turning blue at the neck...... Steve-ALA Intake and Exhaust 2 06-06-2010 09:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome