What to do about Ethanol /PC3 - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 04-06-2011, 11:04 AM Thread Starter
Newbie
 
Join Date: Jan 2011
Location: Valley View, Texas
Posts: 37
What to do about Ethanol /PC3

okay first sorry if long, but I've got a problem. I bought the 02 RG with a 95" kit on it.My indy says looking at the pistons and the mid cam it was high compression of close to 10-1. I cant seem to get it to run on straight 93 octane gas. I had a PC3 with a canned map installed when purchased...ran good , strong but needed to put Amsoil quick shot additive in it so it didn't buck or miss or spit while running. I've read other threads where this has happened to others, but they did'nt find a fix. I have now purchased a new PC3 ( last week old PC quit working and put the bike on 1 cylinder and popped the 15 amp ECM fuse). So I went to Sabine performance here in Dallas and had him install new PC and tune it. Bike came back with okay results as far as performance, but after she runs for 20 sometimes as much as 50 miles it starts the bucking, missing again.

My questions are does anyone else heard or know of someone who has this problem with the Ethanol? Is it a gas problem? ...or should'nt the PC be tuned for this type of problem and be set to compensate the Ethanol. Is there a fix or am I going to stuck with a bike ( without removeing motor upgrades) that requires an additive every fill up?

Sorry for the ramble...been dealing with this since I purchased and getting fed up with dropping more $$. I know mpg's will be sacrificed, and this bike doesn't have that much comprression to warrent this type of performance. Any thoughts, remedies and advice is appreciated.
monte312 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 04-06-2011, 11:41 AM
Prospect
 
Join Date: Dec 2010
Location: Peoria, IL
Posts: 202
Man, you must be redain' my mail!

I have an '01 RG. Fought the same symptoms for years. YES YEARS! 5 OR 6 different dealers. Always something but NEVER really fixed this thing. It's fixed now, thanks to Frank Drago.

And no, I ain't Franks biotch! HA! You being in Big D seeing him is probably not an option.

I always tended to blame the M&M EFI. Put completely new Thundermax in it. Still had problems. Ovr the years I about did everything imaginable.

You know that bike is not getting any younger. I tell ya I think you should look for intermittent shorts to ground. My bike had 3!! All of them are/were located along the bottom right side frame rail. ABout in line with the rear end of the floorboard. If you put it on a lift it will be in the way. The crank position sensor harness will run right there. It was one of the shorts. I can't remember the others.

Shorts that are intermittent will play hell with ya, I know that.

Good Luck Monte
FGOWI is offline  
post #3 of 12 (permalink) Old 04-06-2011, 12:39 PM Thread Starter
Newbie
 
Join Date: Jan 2011
Location: Valley View, Texas
Posts: 37
I'll certainly take a look under there...I changed the regulator out last month , so know where your talking about. But not sure how this would explain why it runs well when I use that Amsoil additive...I'm puzzeled and frustrated....but thanks for the suggestion.
monte312 is offline  
 
post #4 of 12 (permalink) Old 04-06-2011, 05:09 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,007
Garage
I agree todays Gas sucks and does not save anything . Seems like you should be able to tune the bike down to meet the fuel standard with 10:1 compression.

You sure your not over looking something ?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #5 of 12 (permalink) Old 04-06-2011, 06:51 PM
Member
 
EdY39's Avatar
 
Join Date: Jan 2011
Location: Kokomo, MS
Posts: 505
I've got a 2002 RG with 57,000 miles on it. It's 95" with cams and Headquarters heads, probably around 9.7 or so compression. It is tuned with Direct Link software which modifies the HD ECM. It's been running 10% ethanol for years with no problems. It was tuned on a Dyno.

You've got something else causing your problems other than ethanol.

Ed
2002 RoadGlide
DPCM, USN (Retired)
EdY39 is offline  
post #6 of 12 (permalink) Old 04-06-2011, 08:20 PM
Prospect
 
Join Date: Dec 2010
Location: Peoria, IL
Posts: 202
Quote:
Originally Posted by monte312 View Post
I'll certainly take a look under there...I changed the regulator out last month , so know where your talking about. But not sure how this would explain why it runs well when I use that Amsoil additive...I'm puzzeled and frustrated....but thanks for the suggestion.
Not doubting you at all. I chased phantom "patterns" forever. Jus' sayin'.

I tend to agree with edy39. I've ridden at 10,000 feet on cheap, low octane gas and to tell the truth is really was not that much of a factor. Thing ran fine. And I'm referring to an engine not unlike yours.

Wish I could be more help. Good Luck with it. If nuthin' else I can relate how damn frustrating some of these Harley bugs can be.
FGOWI is offline  
post #7 of 12 (permalink) Old 04-06-2011, 08:44 PM Thread Starter
Newbie
 
Join Date: Jan 2011
Location: Valley View, Texas
Posts: 37
Talked to my dyno guru ...he said we'll put her back on and re-check settings to see if he missed something...will fix it or find out the problem ...then fix it or we'll just blow it up ! ...I said either one sounds good to me...so heres to some good luck...lol
monte312 is offline  
post #8 of 12 (permalink) Old 04-07-2011, 07:32 AM Thread Starter
Newbie
 
Join Date: Jan 2011
Location: Valley View, Texas
Posts: 37
Thank you for all of those check points....will discuss with the tuner today.
monte312 is offline  
post #9 of 12 (permalink) Old 04-08-2011, 06:44 AM
Newbie
 
Join Date: Feb 2011
Location: Louiville,KY
Posts: 12
While I agree that you may have other problems the fact that Quickshot SE helps really suggests that your ethanol fuel is a big part of the problem.

One thing Quickshot SE is designed to do is to disperse the ethanol into fine enough molecules that it can get through the fuel system. Ethanol attracts water from the atmosphere and creates a set of problems very similar to having water in the gas. Ethanol combined with water can be too large to pass through carb jets and fuel injectors though the fact that fuel injectiors are under pressure may allow it to be pushed through the injector but still not be atomized properly and therefore not properly combust. When you use Quickshot you are dispersing the ethanol droplets better and that may mean more complete combustion which causes the engine to run smoother.

I know it's a pain in the ass to carry fuel additive but when it prevents a problem such as yours I think it's a small price to pay.

Glide to Live... Live to Glide
Devilhog is offline  
post #10 of 12 (permalink) Old 04-08-2011, 10:45 AM
Prospect
 
Join Date: Dec 2010
Location: Peoria, IL
Posts: 202
The '11 is great except for a little hiccup when taking off from standing start. Not your issue obviously. Being without that coffin on there is great! And, obviously having ALL the original controls.

Turns out the '01 had a crack in the swingarm. And, to top it off I had already replaced wheel bearings etc. Thru the years I had always heard that an '02 swingarm is better. '01s fail. True enough. What peeps didn't add, and I did not know, what that the pivot shafts are different 5/8ths on the '01 and 3/4 pm the '02. Same drill if I'd jumped to '07.

So, ended up welding the original swingarm. Bought new enhanced axle adjusters. All that's finallly done. I sanded it down last night. Ready to paint it and put it back together.

Sorry 'bout the hijack Monte. Hope you get her running like it should soon.
FGOWI is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed with PC3 davey1%er ECM/Fuel Management systems 1 08-02-2014 08:55 AM
Ethanol-Free Gas RGKen General Off-Topic Discussions 25 06-21-2013 02:18 PM
I want to tweak my map PC3, who's done it? JL Sargent ECM/Fuel Management systems 0 08-12-2012 02:44 PM
What to do about Ethanol /PC3 monte312 ECM/Fuel Management systems 0 04-06-2011 10:58 AM
Ethanol in Fuel Jayray ECM/Fuel Management systems 15 07-08-2010 02:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome