Terry Components TV-3 Install - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 04-28-2011, 04:00 PM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Florida
Posts: 237
Terry Components TV-3 Install

Has anybody here installed a TV-3 on a 2011 FLTRU? If so I'd like to hear a quick report on lessons learned, etc. If not, I'll be the Guinea Pig.
Timinfla2 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 04-28-2011, 05:01 PM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
I installed one on my 2010, and 2011 is the same setup. Real easy to do, but you if your like me, the service manual really helps in identifying everything it talks about. Terry components directions have no pictures.






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
post #3 of 16 (permalink) Old 04-28-2011, 05:42 PM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Florida
Posts: 237
Yeah, I need to find a service manual. Ebay here I come - wish I could just download it.
Timinfla2 is offline  
 
post #4 of 16 (permalink) Old 04-28-2011, 10:31 PM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
People offer downloadable ones on ebay,. or at least they used to. If memory serves they were only like $25 or something.






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
post #5 of 16 (permalink) Old 04-29-2011, 05:50 PM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Florida
Posts: 237
Installing it now - have a couple questions.

1. Does it matter which O2 sensor gets hooked in to which harness? The instructions do not indicate.

2. What is a data link connector? And do I need to hook both the red wire to that and the other red/white wire to the battery cable or will one or the other suffice? The instructions make note that 2008-2009 switched key-on 12v has a gray wire and talk about tapping into it with the T-Tapa and blade-terminal connection. I wonder if I have to do this on my 2011.

3. Is there a better spot to install instead of under the seat? Was hoping for something less-obvious...

4. Also, I am installing my Ventilator A/C and when I removed my stock football style A/C, a part came off with it - take a look and tell me what this is and do I need to reinstall when I put on the Ventilator of leave it off?

http://www.flickr.com/photos/[email protected]/5670471723/



http://www.flickr.com/photos/[email protected]/5670472583/



Thank you,
Tim

Last edited by Timinfla2; 04-29-2011 at 05:52 PM.
Timinfla2 is offline  
post #6 of 16 (permalink) Old 04-29-2011, 09:29 PM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Florida
Posts: 237
FML -

So the install goes fine (I thought). Got a red blinking light then eventually a green light as per the instructions. Riding around for a bit tonight - about 20 miles into it, total loss of power and engine light comes on.

Limp home at 20 mph trying not to get rear-ended on US1, cussing the TV-3 the whole way home.

Get home, restart the bike and engine light is gone and full throttle capabilities are back.

Any ideas here?

Thank you,
Tim
Timinfla2 is offline  
post #7 of 16 (permalink) Old 04-29-2011, 09:46 PM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
Yes,.. buy some diaelectic grease and smear it on all the connections you made.






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
post #8 of 16 (permalink) Old 04-29-2011, 09:50 PM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Florida
Posts: 237
Quote:
Originally Posted by CHAINSAW View Post
Yes,.. buy some diaelectic grease and smear it on all the connections you made.
OK - i'm not real smart about this stuff, as I thought that stuff was only used to prevent corrosion. How is that going to help?

One of my thoughts was that the wire leading to the TPS behind the intake is very near the fins of the rear cylinder. Is it possible it's getting heat soaked?

Sorry for the stupid questions.

-Tim
Timinfla2 is offline  
post #9 of 16 (permalink) Old 04-30-2011, 06:11 AM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Florida
Posts: 237
So I just pulled all my TDC codes and this is what I found waiting for me - oh joy.

P0120-Throttle position sensor 1 range error
P0123-TP sensor high
P0131-Front 02 sensor low (lean)
P0131-Front 02 sensor low (lean)
P0132-Front 02 sensor high (rich)
P0134-Front 02 sensor open/not responding
P0151-Rear 02 sensor low (lean)
P0152-Rear 02 sensor high (rich)
P0220-Throttle position sensor 2 range error
P0222-Throttle position sensor 2 low/open
P0577-Cruise control input high
P1510-Throttle actuator control limited performance
P1511-Throttle actuator limited power management mode
P2101-Throttle actuator control motor circuit range error

Awesome. So I guess I'm ripping the TV-3 out today :-/

I go on LOOONG rides with my club and I can't afford to be in limp mode with the whole crew waiting on me. I should've gone TTS or PCV in the first place I guess... Crap. I hope I can get them to take this unit on return.

I guess I'll post this in troubleshooting as well.
Timinfla2 is offline  
post #10 of 16 (permalink) Old 04-30-2011, 07:22 AM
Life Member
 
HD_Shock's Avatar
 
Join Date: Aug 2010
Location: Oklahoma - the windy part
Posts: 1,851
Quote:
Originally Posted by Timinfla2 View Post
So I just pulled all my TDC codes and this is what I found waiting for me - oh joy.

P0120-Throttle position sensor 1 range error
P0123-TP sensor high
P0131-Front 02 sensor low (lean)
P0131-Front 02 sensor low (lean)
P0132-Front 02 sensor high (rich)
P0134-Front 02 sensor open/not responding
P0151-Rear 02 sensor low (lean)
P0152-Rear 02 sensor high (rich)
P0220-Throttle position sensor 2 range error
P0222-Throttle position sensor 2 low/open
P0577-Cruise control input high
P1510-Throttle actuator control limited performance
P1511-Throttle actuator limited power management mode
P2101-Throttle actuator control motor circuit range error

Awesome. So I guess I'm ripping the TV-3 out today :-/

I go on LOOONG rides with my club and I can't afford to be in limp mode with the whole crew waiting on me. I should've gone TTS or PCV in the first place I guess... Crap. I hope I can get them to take this unit on return.

I guess I'll post this in troubleshooting as well.
I have no experience with this tuner but I'm guessing those codes are related to your first question:

"1. Does it matter which O2 sensor gets hooked in to which harness? The instructions do not indicate."

If you're talking about the harnesses on the bike, it matters very much. Black is the rear sensor and grey is the front.

-phil

2011 FLTRX 103


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

VH Dresser Duals | Klock Werks SS | HD Ventilator | Power Vision | Santees 11in Apes | CB SSC Euro 15in

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HD_Shock is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Terry components TV-3 review CHAINSAW ECM/Fuel Management systems 47 02-20-2013 09:23 AM
AUTO-TUNER: Terry Comanents TV-3 MidniteRyder ECM/Fuel Management systems 0 02-19-2013 02:26 PM
Terry TV-3 Illiniroads ECM/Fuel Management systems 4 02-12-2012 09:46 PM
WTB Used AutoTuner - i.e. Terry TV-3 240Q Timinfla2 Classifieds Archive (3 months old+) 0 04-24-2011 11:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome