ECM flash update - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 05-12-2011, 12:41 PM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Southern California
Posts: 268
ECM flash update

Just thought I would pass this along. I have been having intermittent problems with my 6th gear light and my cruise control not working. Everyone blamed it on the PCV and Auto Tuner. Well it seems the real problem lies with the factory ECM. It needs to be flashed with the latest upgrade for the bike. I talked to Dyna Jet and they said they have had several of these calls. They have checked all the returned units and have heard back from people that even with new units they have the same problem. Once the flash was done no more problems, so if you go this thats the answer. I'm taking my bike down as soon as I get the PCV and Auto tuner off. (Ca. dealers have all said that these units void your warranty). It's a AQMD thing (smog people)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
scsharp2260
'09 Road Glide
PC V w/ Auto Tuner
Bub Series 7 Stealth Mufflers
scsharp2260 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 05-12-2011, 01:17 PM
Life Member
 
Rowdy's Avatar
 
Join Date: Apr 2010
Location: Port Orchard, WA
Posts: 5,189
Send a message via Yahoo to Rowdy
I will be interested to hear the outcome you get after taking your bike in. It seems a little odd to me that you put an aftermarket tuner on your bike, and an HD flash puts in sync.
I am not disputing what they are telling you just sayin, it sounds odd.

Rowdy




Ridin a two lane montser, feedin on one cage at a time ...
Rowdy is offline  
post #3 of 11 (permalink) Old 05-12-2011, 01:29 PM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Southern California
Posts: 268
Well I guess I should have added that this problem started after I updated the software and the firmware for the PCV. So my thinking is that something in the old flash does not work with the updated stuff from PCV. I know I should have left well enough alone, put if there is a update I do it, just the kind of guy I am.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
scsharp2260
'09 Road Glide
PC V w/ Auto Tuner
Bub Series 7 Stealth Mufflers
scsharp2260 is offline  
 
post #4 of 11 (permalink) Old 05-12-2011, 04:58 PM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Southern California
Posts: 268
Okay NO trip to the dealer, called Keith at Fuel Moto and he talked me thur fixing the problem. And we even did a few things to make it run even better. So much for Dyna Jet knowing there own product.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
scsharp2260
'09 Road Glide
PC V w/ Auto Tuner
Bub Series 7 Stealth Mufflers
scsharp2260 is offline  
post #5 of 11 (permalink) Old 05-13-2011, 06:55 PM
Hangaround
 
Q-Dog's Avatar
 
Join Date: Apr 2010
Location: Columbia, Maryland
Posts: 184
Quote:
Originally Posted by scsharp2260 View Post
Okay NO trip to the dealer, called Keith at Fuel Moto and he talked me thur fixing the problem. And we even did a few things to make it run even better. So much for Dyna Jet knowing there own product.
You gotta love that...!!!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2009 FLTR Mirage Orange Pearl
Get Sancho's Wings, they boosted HP & TQ...!!!
No heel shifter.
You'll recognize me...black jacket & boots with a T-shirt...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Dog is offline  
post #6 of 11 (permalink) Old 06-06-2011, 11:11 AM
Hangaround
 
Join Date: Jan 2011
Location: Norcal
Posts: 96
What was the fix? I am having the same problem.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rc_chico is offline  
post #7 of 11 (permalink) Old 06-07-2011, 08:38 AM Thread Starter
Prospect
 
Join Date: Apr 2011
Location: Southern California
Posts: 268
The fix was unchecking a box in the PC V so it didn't draw data from the ECM, then had to reset the warm up procedures.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
scsharp2260
'09 Road Glide
PC V w/ Auto Tuner
Bub Series 7 Stealth Mufflers
scsharp2260 is offline  
post #8 of 11 (permalink) Old 06-08-2011, 08:59 PM
Life Member
 
uhpilot's Avatar
 
Join Date: Oct 2010
Location: Alexandria, AL
Posts: 1,718
I wonder if it is a Cali thing. Since both of you guys that have had this are from CA I wonder if it's some kind of setting the CA models have. Don't they have different (aka stricter) settings than the other states bikes?

Just wondering.


Ricky
uhpilot is offline  
post #9 of 11 (permalink) Old 06-09-2011, 07:08 PM
Hangaround
 
Join Date: Jan 2011
Location: Norcal
Posts: 96
My problem started when I updated the Software and firmware from Dynojet. I called them and the tech hadn't heard of this problem. He talked to another tech there and then told me there was three potential fixes, uncheck the box under "Power Commander Tools, Configure, Harley ECM data" the only time this data is used is when you have your laptop plugged in to display things like engine temp.
The second is to have your ECM re-flashed by the dealer to "Blast 9 revision"
The third is to reload your software to an earlier version and reflash your Power Commander to an earlier firmware. The problem seems to be Software 1.0.5.8 and firmware V0.1.6.11.
I unchecked the box in the Power Commander "Use Harley ECM data" box and haven't had anymore problems.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rc_chico is offline  
post #10 of 11 (permalink) Old 06-09-2011, 10:34 PM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Never have these problems when you use the SE race tuner, the bike runs better too.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Magic Box or Biketronics? or Flash No Flash ? Justposts Audio 28 06-14-2018 07:27 PM
Fuel Moto ECM-E-Flash ?? George W ECM/Fuel Management systems 12 11-08-2016 08:31 PM
ECM Flash after Cat Removal FeMoRg ECM/Fuel Management systems 4 08-16-2016 08:48 AM
To flash or not to flash onemanpossee Audio 13 12-28-2015 12:54 PM
flash no flash???? buddy75 Audio 1 03-20-2015 11:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome