MM EFI adjustment question - Road Glide Forums
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 09-16-2013, 11:31 AM Thread Starter
Newbie
 
Sobrbiker's Avatar
 
Join Date: Sep 2013
Location: Sunny AZ, USA
Posts: 20
MM EFI adjustment question

Hey guys, FNG EFI owner. I just got a 99FLTR with 3k miles on a 97" S&S top end, 585G cams in a Fueling camplate with Fueling oil pump (66k mi total).
It runs great, pops a little on decel, but nothing bad. It has a PCIII that was tuned by the shop that did the upgrades.

Problem is my idle hangs at 1500 warm. When I start it cold it will run 1500 or so then drop down to 1050 or so as it warms up, just hangs high once I start riding.

My question is, before I pay someone that knows MM setups at a buddy's shop, can I fire it up, let it cycle through the warm up and shut it down, pull the fuse for 15 minutes or so to reset the ECM's idle memory without diddling up the PCIII or any other settings? Seems logical to me, but I don't think MM injection is logical from what I hear...
Sobrbiker is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 09-16-2013, 09:21 PM
Grey beard
 
mocotom's Avatar
 
Join Date: May 2012
Location: Pa
Posts: 1,110
Pulling the fuse will not mess-up anything. One of the MM injection weak spots is the durability of the idle air control.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2005 RG 98cu in
USMC 1968-1972
mocotom is offline  
post #3 of 9 (permalink) Old 09-16-2013, 10:07 PM
Hangaround
 
Join Date: Sep 2010
Location: Central NJ
Posts: 53
high idle

on the lower right side of the face of the throttle body is an allen adjusting screw that is set back in a threaded hole. Once warmed up good back it out a half turn and see if that helps. Mine did the same thing and I was able to get it down.
Quickster is offline  
 
post #4 of 9 (permalink) Old 09-16-2013, 10:30 PM
Life Member
 
tdkkart's Avatar
 
Join Date: Jun 2011
Location: East Central Iowa
Posts: 3,026
Garage
Quote:
Originally Posted by Sobrbiker View Post
My question is, before I pay someone that knows MM setups at a buddy's shop, can I fire it up, let it cycle through the warm up and shut it down, pull the fuse for 15 minutes or so to reset the ECM's idle memory without diddling up the PCIII or any other settings? Seems logical to me, but I don't think MM injection is logical from what I hear...

Yes, this is one of the secrets to the M-M system, alot of issues can be solved by resetting the ECM.
The other thing to do is to look up the proceedure for recalibrating the throttle position portion of the PCIII, this will also cure some ills.

If the above doesn't do any good, check to see that you don't have an intake leak showing up once the engine is warm. Check to see that the intake flange bolts are tight.

2015 RGU CVO........under continuous change......
tdkkart is offline  
post #5 of 9 (permalink) Old 09-17-2013, 11:10 PM
Hangaround
 
Join Date: Aug 2013
Location: Central IL
Posts: 67
Sounds like it should run hard.

Just got rid of my 2001FLTRSEI2.
Do a search to set the TPS, looks hard but not to bad need a good meter.
PM me I will try to find the procedure I used to use.
Did mine every winter.

Also start saving for a new tuner, one that flashes the ECM.
On those year bikes the CPS (crank position sensor) does not put out a strong
enough signal and sometimes it will fry the PCIII. I went through 3 of them.
I finally emailed K&N and received an email that stated the above.
Bike just dies.......then have to unplug the PCIII.

Not trying to be a debbie downer just FYI from my experience.
I rode mine for 6 yrs and had a blast. I still dont know if trading for a 13 was the right choice? I liked it a lot.
Also search for an upgrade from the circuit breaker to a fused link.

MM bikes are NOT bad bikes you just have to dig in a little bit and get dirty.
I don't know it all but I sure did learn alot after 6 yrs with that bike.
rode that bitch like i stole it....
I used to get alot of crap form people about that MM, until I out ran them and them got better milage!!
Had it bored out from BC heads.
festus is offline  
post #6 of 9 (permalink) Old 09-17-2013, 11:27 PM Thread Starter
Newbie
 
Sobrbiker's Avatar
 
Join Date: Sep 2013
Location: Sunny AZ, USA
Posts: 20
I did 1/4 turn out on the warm idle and she seems better.
Runs right at 1100 for the most part, but does still sit as high as 1300, or as low as 900-1000.
Got me almost 26 mpg the last 86 miles (woohoo)...
Festus, I'd appreciate any info you'd like to share!
Sobrbiker is offline  
post #7 of 9 (permalink) Old 09-17-2013, 11:56 PM
Hangaround
 
Join Date: Aug 2013
Location: Central IL
Posts: 67
ok
I will look at my hard drive tomorrow to find the procedure.
26MPG? You should be getting alot better than that.
I had 2006 heads, BC TB 42mm, tw-37's, 10.25 pistons, true dual bassani's.
I had a DD6 that was a final drive of 3.06. used a 27 tooth on comp.
I almost always got over 40MPG. 60mph=44-46mpg.

Sometimes people tune these to get ALL of the ping out.
It does not work, i tried it. Just kills your mileage.
Try to get it tuned to run good and you will have to down shift a little more than some. I.E. passing a car on two lane just down shift, no big deal. I only had trouble when loaded for a trip or two up.
If you bought it used check the gearing? these bikes were geared low, 3.37 final drive. guys I know geared them up changed the pulley to a 34 and then had problems with pinging.

that 585 is a big cam.
you might check the power commander site to see if there is a tune close to your set up from another tuner? Save your tune on a computer and load another one that is close and see how it runs? this will give you a better feel for the tunes and how the bike runs.

What altitude are you at?
Mine always gave me more problems on vacation due to my tune being for
750ft. When in the mountains it never seemed to idle good. up and down.

Ahhhh and the crap we do when its not stock!!! juaaaaaa.
I am in the same boat with my 13, changing tunes and checking mileage, drivability, starting-hot and cold.
festus is offline  
post #8 of 9 (permalink) Old 09-18-2013, 09:56 AM Thread Starter
Newbie
 
Sobrbiker's Avatar
 
Join Date: Sep 2013
Location: Sunny AZ, USA
Posts: 20
Actually it was geared the other way, it has a 29 tooth pulley...
Good part is the guy gave me the 32 tooth pulley and belt, and a primary gasket set.
Just have to prioritize what I throw money at right now but pretty sure yanking the primary will be right up there.
Sobrbiker is offline  
post #9 of 9 (permalink) Old 10-24-2013, 03:34 PM
Hangaround
 
Therocks01's Avatar
 
Join Date: Aug 2013
Location: Rock Falls, IL
Posts: 122
I'm having similar idle issues. The only mods are slip-ons and a high flow air filter. My '01 has gotten a new Idle Speed Control Actuator, New Engine Temp Sensor, TPS voltage checked with meter, and new intake manifold gaskets.

The engine idles at 1500 more often than not and sometimes up to 1700. Every once in a while it will idle down around 1100. I just got it back from an indy, so I haven't had a lot of time to ride and see if turning down the warm idle will help. I am concerned that when the bike would idle at 1100, that will now drop to 700-800.

I have tried everything I can find to get this right. I only have so much cash as I just bought this bike in August. Converting to carb might be the best option at this point.
Therocks01 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
MM EFI to Carb conversion Lunchboxx ECM/Fuel Management systems 7 02-12-2015 02:39 PM
Thundermax for MM efi replacement RGSRULE ECM/Fuel Management systems 15 03-05-2014 04:11 AM
Why do the MM bikes have a different gear? SilverGhost *General Road Glide Discussions/Pictures 8 08-06-2012 11:08 PM
MM EFI to Carb Conversion for a '01 RG v-rodder *General Road Glide Discussions/Pictures 10 05-19-2011 10:37 PM
MM Injection BIGMO ECM/Fuel Management systems 7 07-29-2010 09:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome