My GPS won't work on Some locations - Road Glide Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-25-2018, 10:54 PM Thread Starter
Newbie
 
Join Date: May 2018
Posts: 14
My GPS won't work on Some locations

My GPS seems to have issues but appears to be fine at the same time. It's not working on some locations while my friends have no problem in all locations. I'm quite confuse with it.
Jaferwen is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-26-2018, 05:37 AM
Life Member
 
twowheeladdict's Avatar
 
Join Date: Feb 2016
Location: Tennessee
Posts: 3,660
It is definitely not a Garmin Zumo. I mostly use it as a display so I can see road names long before I can read the road sign. I also have my speed displayed on the lower left corner so I don't have to look down at the speedo, and temperature on the lower right corner because experiencing the changes in temperature while riding the tree lined back roads along streams and rivers is one of the joys of motorcycling.

When I do use it for routing it always comes back with route does not have complete data even though my Zumo 660 never had issues with any of those roads.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2018 Road Glide Special, 2018 Moto Guzzi V7III Carbon, 2019 Royal Enfield Himalayan, 2017 Suzuki Van Van 200

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
twowheeladdict is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Radio won't work conn-e-rot Audio 18 06-05-2016 01:11 PM
Accent Lighting Locations OKBigD Lighting 8 01-19-2014 09:04 AM
PBR 300x2 mounting locations? HogPro Audio 9 09-15-2013 04:33 AM
Amp mount locations with 4 speakers in the fairing Best things come in pairs Audio 6 04-22-2013 09:10 PM
Photo Shoot locations in/near Dayton? Defy *General Road Glide Discussions/Pictures 11 04-12-2011 12:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome