Installed new Bars - Road Glide Forums
Controls & Handlebars Controls and Handlebars for Road Glides

 10Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 (permalink) Old 01-29-2018, 07:48 AM Thread Starter
Hangaround
 
mfgator's Avatar
 
Join Date: Mar 2014
Location: Roswell, GA
Posts: 161
Garage
Installed new Bars

Took the plunge and installed 14” Wild1 Chubby Reapers on my 2009. Replaced the bushings, hard wired the TBW and had to replace the clutch cable and brake lines. Besides the time to hardware and pull the cables and one dumb asssss mistake (over tightened the front brake line and striped the master reservoir), Not that bad of a process.


Sent from my iPhone using Tapatalk
mfgator is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 01-29-2018, 09:22 AM
Grey beard
 
BlazingSaddle's Avatar
 
Join Date: Aug 2014
Location: Florida
Posts: 926
Garage
They look good! Sounds like a spendy project that turned even more spendy. Sucks about the master cylinder.
BlazingSaddle is offline  
post #3 of 24 (permalink) Old 01-29-2018, 09:55 AM
Grey beard
 
Join Date: Apr 2013
Location: lawnguyland
Posts: 1,461
I am going to be doing the bars on my 13 in a few weeks...any words of wisdom besides don't strip the bolts?....

2013 RGU, black of course....
y2kflhr is offline  
 
post #4 of 24 (permalink) Old 01-29-2018, 10:00 AM
Life Member
 
Swomack's Avatar
 
Join Date: Oct 2014
Location: Prosper, Texas
Posts: 6,144
Garage
Quote:
Originally Posted by mfgator View Post
Took the plunge and installed 14” Wild1 Chubby Reapers on my 2009. Replaced the bushings, hard wired the TBW and had to replace the clutch cable and brake lines. Besides the time to hardware and pull the cables and one dumb asssss mistake (over tightened the front brake line and striped the master reservoir), Not that bad of a process.


Sent from my iPhone using Tapatalk
Those new bars look killer brother

Congrats

Swomack


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Gallery / Click Below Link

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Swomack is offline  
post #5 of 24 (permalink) Old 01-29-2018, 10:27 AM Thread Starter
Hangaround
 
mfgator's Avatar
 
Join Date: Mar 2014
Location: Roswell, GA
Posts: 161
Garage
Quote:
Originally Posted by y2kflhr View Post
I am going to be doing the bars on my 13 in a few weeks...any words of wisdom besides don't strip the bolts?....


Take pictures of your wires and connectors. Reconnecting them is much easier. Also if you decide to get rid of the green TBW connector, and hard wire, stagger the connections so it is not so bulky going thru the bars.


Sent from my iPhone using Tapatalk
madmat likes this.
mfgator is offline  
post #6 of 24 (permalink) Old 01-29-2018, 11:47 AM
Grey beard
 
Join Date: Apr 2013
Location: lawnguyland
Posts: 1,461
Quote:
Originally Posted by mfgator View Post
Take pictures of your wires and connectors. Reconnecting them is much easier. Also if you decide to get rid of the green TBW connector, and hard wire, stagger the connections so it is not so bulky going thru the bars.


Sent from my iPhone using Tapatalk
thanks! I don't really see a reason for the connector and it seems to be a problem for a lot of people so its probably going in the trash!
bosshogg123 likes this.

2013 RGU, black of course....
y2kflhr is offline  
post #7 of 24 (permalink) Old 01-29-2018, 12:19 PM
Member
 
bosshogg123's Avatar
 
Join Date: Jul 2014
Location: Economy, PA
Posts: 781
Garage
Send a message via Skype™ to bosshogg123
Quote:
Originally Posted by y2kflhr View Post
thanks! I don't really see a reason for the connector and it seems to be a problem for a lot of people so its probably going in the trash!

I concur! When I did my former 13 RGU Last winter, I picked up a SE TBW unit without the connector (great deal on EBay); in fact, if you mess yours up I still have the stock TBW somewhere in my garage...


Sent from my iPhone using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2017 Road Glide Ultra, Mysterious Red/Velocity Red
"The Difficult will be done Immediately, the Impossible will take a bit longer." - U. S. Military Slogan
bosshogg123 is online now  
post #8 of 24 (permalink) Old 01-29-2018, 01:16 PM
Hangaround
 
Join Date: Sep 2016
Location: Missoula, MT
Posts: 85
what length cables did you get and what brand cables did you go with? just for reference. my apes should be here on thursday and i am really dreading measuring it always seems that the brake line is right but the clutch cable is too long.
Booger099 is offline  
post #9 of 24 (permalink) Old 01-29-2018, 01:42 PM
Member
 
Rubimad's Avatar
 
Join Date: Oct 2017
Location: Madrid (Spain)
Posts: 721
Beautiful bars, congratulations
Rubimad is offline  
post #10 of 24 (permalink) Old 01-29-2018, 02:08 PM
Newbie
 
mtbutler's Avatar
 
Join Date: Oct 2012
Posts: 41
They look nice!
mtbutler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed new bars and now I have no brake lights or rear 4 way soup22 Controls & Handlebars 1 04-21-2016 08:17 PM
New Heritage Style bars installed. MyDNA Controls & Handlebars 6 02-25-2014 09:29 AM
Engine Light on after new bars installed RADDBUS Controls & Handlebars 15 11-02-2013 10:35 PM
Bars bars and more bars Deadstroke Controls & Handlebars 6 10-09-2013 08:59 AM
Tail light not working after new bars installed ksarauer Controls & Handlebars 8 06-17-2013 12:09 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome