Check engine light with p0577 code tripped help needed - Road Glide Forums
Controls & Handlebars Controls and Handlebars for Road Glides

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 06-02-2013, 02:20 PM Thread Starter
Member
 
neuropac's Avatar
 
Join Date: Nov 2011
Location: Abingdon Va
Posts: 713
Check engine light with p0577 code tripped help needed

Bike has been running great except blowing taillights 2 in the last week, 200 miles into a ride Friday the check engine light came on and the cruise quit working no other problems. Checked the code and found p0577 cruise control input high. Finished the ride another 150 miles without any issues seems to running fine. Did the drop down test for the cruise without identifying the problem not sure where to go next. Prefer to repair it myself if I can no longer under warranty. Thanks Chris

2011 FLTRX 103
2005 Big Dog Ridgeback
1982 FXR Superglide 1340 shovel
neuropac is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 06-02-2013, 02:42 PM
Gray Beard
 
lundboy1's Avatar
 
Join Date: Jan 2013
Location: Eastern Idaho
Posts: 1,521
Garage
Here's the code
www.fuelmotousa.com/site/harleycodes.html
Harley Trouble codes. ... 81. P0577 Cruise Control Input High Priority/DTC/Fault condition HFSM = Hands Free Security Module TSM = Turn signal module 1.

" wishin' my knees were in the breeze!!!"
lundboy1 is offline  
post #3 of 18 (permalink) Old 06-02-2013, 04:13 PM Thread Starter
Member
 
neuropac's Avatar
 
Join Date: Nov 2011
Location: Abingdon Va
Posts: 713
Lundboy1 thanks, I had seen this before, while researching the code and I also found info on doing the diagnostic drop down test of the cruise to check the sensors but so far everything check out fine. I cleared the code but after a few miles of riding the light returns and the cruise still doesn't work, I even did a hard reset by disconnecting the power by removing the 40 amp fuse no luck.

2011 FLTRX 103
2005 Big Dog Ridgeback
1982 FXR Superglide 1340 shovel
neuropac is offline  
 
post #4 of 18 (permalink) Old 06-02-2013, 06:23 PM
Gray Beard
 
lundboy1's Avatar
 
Join Date: Jan 2013
Location: Eastern Idaho
Posts: 1,521
Garage
Well that sucks I wish it were that simple .... Any mods , work , or hard hits the bike has had lately?

" wishin' my knees were in the breeze!!!"
lundboy1 is offline  
post #5 of 18 (permalink) Old 06-02-2013, 06:50 PM
Life Member
 
HellInABucket's Avatar
 
Join Date: Nov 2012
Location: SE Michigan
Posts: 1,742
Last year I had a '12 Road King, on the way to Sturgis my cruise quit and the check engine light came on - not sure what the codes were but it was a bad cruise switch, Mankato HD swapped it out and I was good to go.

2018 FLTRU
Roll away the dew...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HellInABucket is offline  
post #6 of 18 (permalink) Old 06-02-2013, 07:14 PM Thread Starter
Member
 
neuropac's Avatar
 
Join Date: Nov 2011
Location: Abingdon Va
Posts: 713
Lundboy1 last big mods was over the winter with new bars and new gauges, install was straight forward without problems and no other electrical problems so far over 1500 miles since install. I continue to wander if the problem with the taillights is related.

Hellinabucket I wandered about the switch given all that has been reported on the forums about failure but from what I have read the cruise drop out test is suppose to identify a switch failure or sensor problem but if passed I performed it 4 times. Any other thoughts?

2011 FLTRX 103
2005 Big Dog Ridgeback
1982 FXR Superglide 1340 shovel
neuropac is offline  
post #7 of 18 (permalink) Old 06-02-2013, 08:15 PM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,519
Blowing the fuse on the taillights and the cruise control not functioning may be related. You may have a short or a overload somewhere in the taillight system. Try to isolate the problem, start with pulling the rear light bulbs and if the fuse still blows then unplug the rear lighting harness, you may have a pinched wire under the seat or under the fender which is more common with bikes that have been lowered. It is hard to diagnose electrical problems some times with out the right equipment so taking it for repairs may be a better option if you cant find a obvious problem.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #8 of 18 (permalink) Old 06-05-2013, 09:47 PM Thread Starter
Member
 
neuropac's Avatar
 
Join Date: Nov 2011
Location: Abingdon Va
Posts: 713
Problem solved, the cruise set/resume switch was bad, replaced switch and no problems after a 40 mile ride this evening. I initially thought the switch was good but i was misinterpreting the drop down test. I am not sure what caused the premature failure of my taillight bulbs but I didn't find a ground. It may be time to replace the 11/57 bulbs with LEDs. Thanks to the members that responded for my call for help. I am not sure if the cruise and taillight failure is related.

2011 FLTRX 103
2005 Big Dog Ridgeback
1982 FXR Superglide 1340 shovel
neuropac is offline  
post #9 of 18 (permalink) Old 06-05-2013, 09:49 PM Thread Starter
Member
 
neuropac's Avatar
 
Join Date: Nov 2011
Location: Abingdon Va
Posts: 713
Quote:
Originally Posted by ironmark View Post
Blowing the fuse on the taillights and the cruise control not functioning may be related. You may have a short or a overload somewhere in the taillight system. Try to isolate the problem, start with pulling the rear light bulbs and if the fuse still blows then unplug the rear lighting harness, you may have a pinched wire under the seat or under the fender which is more common with bikes that have been lowered. It is hard to diagnose electrical problems some times with out the right equipment so taking it for repairs may be a better option if you cant find a obvious problem.
Ironmark it has been blowing the bulbs not the fuse. Thanks for your help and info from other posts of yours on how to check the codes and interpret them.

2011 FLTRX 103
2005 Big Dog Ridgeback
1982 FXR Superglide 1340 shovel

Last edited by neuropac; 06-05-2013 at 09:52 PM.
neuropac is offline  
post #10 of 18 (permalink) Old 06-05-2013, 10:29 PM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,519
Glad you found the problem and it was a easy fix.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error code question or at least I think it's an error code wvdave Troubleshooting for Road Glides 1 07-15-2015 10:21 AM
Check Engine Light and Battery Light following Jackpot 2-1-2 install PearlBlueUltra Troubleshooting for Road Glides 9 06-15-2014 03:59 PM
P0577 Cruise Control Input High Priority Illiniroads Troubleshooting for Road Glides 1 07-02-2013 09:10 PM
P0577 windup Troubleshooting for Road Glides 6 12-04-2012 03:45 PM
need Help Check Engine light issue jprider4life Troubleshooting for Road Glides 4 06-01-2012 04:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome