New Bars installed today - Road Glide Forums
Controls & Handlebars Controls and Handlebars for Road Glides

 2Likes
  • 1 Post By RGKen
  • 1 Post By gman
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-02-2018, 05:01 PM Thread Starter
Hangaround
 
gman's Avatar
 
Join Date: Feb 2010
Posts: 81
New Bars installed today

Well decided to get rid of the stock bars for some Khrome Werks bobber 12" bars. Bars are very nicely made and they they give me the pullback i need to be in a more upright position. The install was pretty easy and the best part was i didn't have to unpin the TBW plug, it was just as small as the other connectors. So i bought that molex tool for nothing. Pulling the wires was fairly easy ( but i suggest having someone help you). I had to make some small modifications to remove guide pin from the hydraulic clamps for brake and clutch but no big deal. So after all that i go to put everything back together and fire it up, but what to my suprise a check engine light.. I ran the diag and have codes ECM p2122, 2127,2138. Spo u0140. WTF. So i google the codes and everything says it has to do with low voltage and the TBW. So i pull it all apart again to check all connetions and make sure nothing is broken. But light is still on and codes remain the same. So i guess tomorrow i will be heading over the the dealer to find out whats up. Oh by the way the bike runs fine. Here are some photos of the install.
Attached Images
File Type: jpg IMAG0189.jpg (1,017.9 KB, 69 views)
File Type: jpg IMAG0191.jpg (1.30 MB, 61 views)
File Type: jpg IMAG0192.jpg (1.39 MB, 59 views)
File Type: jpg IMAG0193.jpg (1.05 MB, 52 views)
File Type: jpg IMAG0194.jpg (592.3 KB, 53 views)
gman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-02-2018, 06:03 PM
Life Member
 
RGKen's Avatar
 
Join Date: May 2012
Location: Jax, FL
Posts: 3,758
Garage
Quote:
Originally Posted by gman View Post
Well decided to get rid of the stock bars for some Khrome Werks bobber 12" bars. Bars are very nicely made and they they give me the pullback i need to be in a more upright position. The install was pretty easy and the best part was i didn't have to unpin the TBW plug, it was just as small as the other connectors. So i bought that molex tool for nothing. Pulling the wires was fairly easy ( but i suggest having someone help you). I had to make some small modifications to remove guide pin from the hydraulic clamps for brake and clutch but no big deal. So after all that i go to put everything back together and fire it up, but what to my suprise a check engine light.. I ran the diag and have codes ECM p2122, 2127,2138. Spo u0140. WTF. So i google the codes and everything says it has to do with low voltage and the TBW. So i pull it all apart again to check all connetions and make sure nothing is broken. But light is still on and codes remain the same. So i guess tomorrow i will be heading over the the dealer to find out whats up. Oh by the way the bike runs fine. Here are some photos of the install.

If you did the bar swap without pulling the main fuse and disconnecting the negative battery cable it will throw the codes. If you did put everything back together correctly all you have to do is clear the codes. Then start the bike and I bet your check engine light will go off and the codes will not come back. If you did not do something right then the appropriate code or codes will show up.
gman likes this.

2018 FLTRXS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RGKen is offline  
post #3 of 4 (permalink) Old 09-02-2018, 06:11 PM Thread Starter
Hangaround
 
gman's Avatar
 
Join Date: Feb 2010
Posts: 81
Ok i will give that a try. Thanks
gman is offline  
 
post #4 of 4 (permalink) Old 09-03-2018, 03:43 PM Thread Starter
Hangaround
 
gman's Avatar
 
Join Date: Feb 2010
Posts: 81
All is well in the world now. Pulled the fuse and disconnected negative battery terminal. After 2 start ups the check engine light went out.
Homer93 likes this.
gman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New 13" Legend REVO Shocks Installed Today MotoPGG Suspensions 0 05-04-2017 04:13 PM
Installed new system today RDCRIS Audio 12 07-17-2015 06:46 PM
Bars bars and more bars Deadstroke Controls & Handlebars 6 10-09-2013 08:59 AM
Installed my new Sancho's Wings today... Ma$$hole *General Road Glide Discussions/Pictures 1 07-31-2011 07:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome