KST Kustoms Renegades - Road Glide Forums
Controls & Handlebars Controls and Handlebars for Road Glides

 2Likes
  • 1 Post By LS GLIDE
  • 1 Post By flhtcm
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-05-2018, 08:17 PM Thread Starter
Newbie
 
Nitro's Avatar
 
Join Date: Feb 2015
Posts: 3
KST Kustoms Renegades

Installed 14” Renegades on my new 2019
Road glide and nothing works. Turn the ignistion on the radio, headlights and running lights come on. All the hand controls do not work nor does the speedometer or any gauges. I am baffled as I did not mess with the speedo wire except for unplugging it.

Any help would be appreciated.
Nitro is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-05-2018, 10:43 PM
Member
 
Join Date: Sep 2018
Posts: 440
Check that you didn’t mix up the small switch housing plugs under the speedo cluster. If you have right plugged into left and left into right, nothing will work.

2018 FLTRXS Wicked Red
Harley Master Tech
Disabled Combat Vet - JTAC 96-06
crazy4ink is offline  
post #3 of 7 (permalink) Old 09-06-2018, 09:58 AM Thread Starter
Newbie
 
Nitro's Avatar
 
Join Date: Feb 2015
Posts: 3
I pulled the speedo back off, reversed everything, put it together and nothing. Put them all back and nada! If one set of wired is bad will it make everything not work or will it just affect what the wires are connected too?
Nitro is offline  
 
post #4 of 7 (permalink) Old 09-08-2018, 08:00 AM
Hangaround
 
LS GLIDE's Avatar
 
Join Date: Mar 2015
Location: North Texas
Posts: 98
Did you take pictures of the main Molex connector, I think it was the right side) and make sure you plugged them in exactly the way you took them out?
Also, did you hear the audible click when you plugged them back in?
You shouldn't have a "bad" wire on a new bike, unless you just reefed on them.
Swomack likes this.

'19 RGS
LS GLIDE is offline  
post #5 of 7 (permalink) Old 09-21-2018, 07:11 PM
Hangaround
 
flhtcm's Avatar
 
Join Date: Jun 2012
Location: Tri-Cities Tennessee
Posts: 83
Quote:
Originally Posted by LS GLIDE View Post
Did you take pictures of the main Molex connector, I think it was the right side) and make sure you plugged them in exactly the way you took them out?
Also, did you hear the audible click when you plugged them back in?
You shouldn't have a "bad" wire on a new bike, unless you just reefed on them.
Having the exact same issue on an 18. Here the click, tried swapping them out... Get head lights and radio unit works but nothing on the handlebar switches, I hear the fuel pump, wires went in fairly easy, no bent be pins... Please help!

Sent from my SM-N950U using Tapatalk
flhtcm is offline  
post #6 of 7 (permalink) Old 09-22-2018, 06:41 AM
Hangaround
 
flhtcm's Avatar
 
Join Date: Jun 2012
Location: Tri-Cities Tennessee
Posts: 83
Quote:
Originally Posted by flhtcm View Post
Having the exact same issue on an 18. Here the click, tried swapping them out... Get head lights and radio unit works but nothing on the handlebar switches, I hear the fuel pump, wires went in fairly easy, no bent be pins... Please help!

Sent from my SM-N950U using Tapatalk
Found the culprit. The 5 amp fuse blew. There is a spare in the fuse box. Fixed the problem, bike back on the road!

Sent from my SM-N950U using Tapatalk
crazy4ink likes this.
flhtcm is offline  
post #7 of 7 (permalink) Old 09-22-2018, 06:48 AM
Member
 
Join Date: Sep 2018
Posts: 440
Quote:
Originally Posted by Nitro View Post
I pulled the speedo back off, reversed everything, put it together and nothing. Put them all back and nada! If one set of wired is bad will it make everything not work or will it just affect what the wires are connected too?

So the only thing you did was install the new bars and now you have no switch function from either side? What did you use to extend the wires for the switch housings? Typically, only the side with the bad wires will stop working.

Couple suggestions of things to check:
- neither switch housing is pinching anything right where the halves meet
- With new grips, the left grip is stepped so that the switch housing pinches it, making it a glueless install. Have seen the grip turn which makes the switch housing sit weird, and have seen that affect
the switches working at all
- Double check the little white plug on the back of each switch pack. Have see those come loose

2018 FLTRXS Wicked Red
Harley Master Tech
Disabled Combat Vet - JTAC 96-06
crazy4ink is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
14" KST Renegades Korazu Controls & Handlebars 8 09-10-2018 10:00 PM
KST Kustoms 10" Renegades jchar27 Parts for Sale 11 05-22-2018 01:40 PM
KST renegades on 16 Road Glide Special seņorbeavis Controls & Handlebars 11 01-31-2017 09:42 AM
14" KST Kustoms Mayhem bars installed. NWA_RoadGlide Controls & Handlebars 14 02-15-2016 04:12 PM
KST Kustoms Handlbars Installed Fahred Controls & Handlebars 2 03-31-2013 10:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome