Factory 47 12in -Problems - Road Glide Forums
Controls & Handlebars Controls and Handlebars for Road Glides

 11Likes
 
LinkBack Thread Tools
Old 10-10-2018, 11:31 PM Thread Starter
Newbie
 
Join Date: Oct 2018
Location: San Diego, Ca
Posts: 9
Factory 47 12in -Problems

I just got 2019 Road Glide special. I bought New Factory 47 12in. I watched the video and took my time putting the wires through the bars. When I plugged everything back in nothing works. The controls on both side won't work, the gauge cluster has no power. I did not unplug the battery when I did all the work (I know that was stupid). The only fuse box I found was on the left side with only 6 fuses ( all good). Any suggestions would be appreciated It seems like it should be a fuse since nothing works.

Last edited by RustyStolzz; 10-10-2018 at 11:38 PM.
RustyStolzz is offline  
Sponsored Links
Advertisement
 
Old 10-11-2018, 12:27 AM
Member
 
texasnurse's Avatar
 
Join Date: Jul 2018
Posts: 301
Check the main fuse, you should have removed the fuse prior to disassembly.




Sent from my iPhone using Tapatalk
wevsspot likes this.
texasnurse is offline  
Old 10-11-2018, 05:32 AM
Member
 
Join Date: Sep 2018
Posts: 440
Not unhooking the battery shouldn't have messed with anything. Double check the small plugs for your switch packs coming out of your bars. Since they are the same, it's easy to mix them up.
madmat and Nutt2336 like this.

2018 FLTRXS Wicked Red
Harley Master Tech
Disabled Combat Vet - JTAC 96-06
crazy4ink is offline  
 
Old 10-11-2018, 09:35 AM
Hangaround
 
Swoop76's Avatar
 
Join Date: Jun 2017
Posts: 150
Had the same issue when did a bar swap, turned out had right side control wire was pinched and a bit loose.
Swoop76 is online now  
Old 10-11-2018, 11:14 AM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,602
Sounds to me like the main fuse or you forgot to plug in all the connectors.

2019 Silver Flux/Black Fuse FLTRU
"SLIVER"
BH#103 is online now  
Old 10-11-2018, 12:55 PM
Newbie
 
federal officer's Avatar
 
Join Date: Feb 2018
Location: massachusetts
Posts: 37
same thing happened to me buddy. double check you small 5amp acc fuse. that was my issue.
federal officer is offline  
Old 10-11-2018, 01:16 PM
Life Member
 
wevsspot's Avatar
 
Join Date: May 2015
Location: God's Country
Posts: 1,718
Garage
@RustyStolzz

Turn the ignition switch to the ON position. Does anything else power up? i.e. lights, radio, fuel pump prime?

Yes - make sure you plugged everything back in, remove the gage cluster and make sure the gage cluster plug is securely connected to the back of the gage cluster, and then make sure that all of your switch housing wires and TBW wires are plugged into the appropriate connections inside the cluster housing. If all that checks good, loosen and remove switch housings and make sure that you didn't pinch any of the wires coming out of the handlebars and going into the switch housings.

No - check 50A fuse under left side cover (hint it's the big red maxi-fuse )


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by wevsspot; 10-11-2018 at 01:19 PM.
wevsspot is offline  
Old 10-13-2018, 10:48 PM Thread Starter
Newbie
 
Join Date: Oct 2018
Location: San Diego, Ca
Posts: 9
Fixed It!!

First I want to thank you guys for the help!

So I had to wait a few days to work on the bike and started with checking the fuses. I found a blown fuse I had missed the night I was working on it. When I replaced it everything but the right side controls worked. I then checked to make sure the wires and the were pinched or loose. They weren't pinched! they must have been loose because after I disconnected and reconnected them everything worked! I love the Factory 47 12in bars. Much better (in my opinion) then the factory bars. I'm loving the Road Glide!
madmat and BigBlockBobby like this.
RustyStolzz is offline  
Old 10-14-2018, 06:26 AM
Life Member
 
madmat's Avatar
 
Join Date: Jun 2012
Location: Mass
Posts: 3,866
Garage
Quote:
Originally Posted by RustyStolzz View Post
First I want to thank you guys for the help!

So I had to wait a few days to work on the bike and started with checking the fuses. I found a blown fuse I had missed the night I was working on it. When I replaced it everything but the right side controls worked. I then checked to make sure the wires and the were pinched or loose. They weren't pinched! they must have been loose because after I disconnected and reconnected them everything worked! I love the Factory 47 12in bars. Much better (in my opinion) then the factory bars. I'm loving the Road Glide!
Congrats on your fix!

I beleive we will need picture proof that they are on the scoot!

OEM bars for me are not comfortable.
MightyWhitey likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

18 RGS Bonneville Salt Pearl
madmat is online now  
Old 10-16-2018, 08:56 PM Thread Starter
Newbie
 
Join Date: Oct 2018
Location: San Diego, Ca
Posts: 9
Here she is!

Quote:
Originally Posted by madmat View Post
Congrats on your fix!

I beleive we will need picture proof that they are on the scoot!

OEM bars for me are not comfortable.
Here she is!
Attached Images
File Type: jpeg 0FBC5A36-CF7D-4104-A403-538FEA809E70.jpeg (158.7 KB, 90 views)
madmat, flhman, till66 and 2 others like this.
RustyStolzz is offline  
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Similar Threads
Thread Thread Starter Forum Replies Last Post
12" factory 47 malo for 2015 special dware15glide Controls & Handlebars 91 04-06-2017 07:59 PM
Just ordered my new 2015 factory 47 (formerly Buky Bars) road glide bars Wotsrab Controls & Handlebars 33 05-03-2016 10:04 PM
Factory 47 / Buky Bars cruznmarine Controls & Handlebars 37 04-26-2015 11:54 PM
Road glide hand guards on 14 inch Buky bars ( factory 47 ) opinions? ccsolo24lal Controls & Handlebars 33 03-15-2015 11:32 AM
Factory 47 rg113 Controls & Handlebars 22 02-07-2015 10:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome