Connectors dont snap back together - Road Glide Forums
Controls & Handlebars Controls and Handlebars for Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 07-03-2013, 09:03 PM Thread Starter
Newbie
 
Join Date: May 2013
Location: Pearland, TX
Posts: 3
Connectors dont snap back together

Did the internal wiring for handlebar took molex apart now the connectors wont snap back together. cant get the pin alignment/holder to set back in housing all the way.
Help
cmetal is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 07-03-2013, 09:10 PM
Life Member
 
reficul's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Posts: 3,677
Quote:
Originally Posted by cmetal View Post
Did the internal wiring for handlebar took molex apart now the connectors wont snap back together. cant get the pin alignment/holder to set back in housing all the way.
Help
Make sure all the pins are seated right and not pushed in to far also make sure they are not twisted. Be patient and don't force them. With everything lined up they will push together real easily.

Sent from Motorcycle.com Free App

2012 Shark Face
Keep knocking on the devils door,
One day he is gonna answer
reficul is offline  
post #3 of 9 (permalink) Old 07-03-2013, 09:19 PM
Prospect
 
lostboy792's Avatar
 
Join Date: Sep 2012
Location: NE Ohio, snow belt area
Posts: 219
I had same problem and it ended up i had all the terminals flipped 180 degrees in the connector. Be patient they will come back out but can be tricky.

Sent from Motorcycle.com Free App

2012 Road Glide Ultra, BBP. Jackpot head pipe, V&H Monster ovals, VIED's DIY rear air ride suspension, Progressive Mono Tubes in the front -1.
lostboy792 is offline  
 
post #4 of 9 (permalink) Old 07-03-2013, 09:52 PM
Life Member
 
mjsdouble's Avatar
 
Join Date: May 2012
Location: West Covina, CA
Posts: 2,616
This is where I had trouble too. If you put the pin in correctly you will hear it click into place. It will then be difficult to come out. Once you get the hang of one or two pins its a piece of cake. As has been said ... You might have to rotate the pin 180 degrees.

2012 RGC aka Black Sassy, Vivid Blk, 12" Drk Wind Splitter, V&H Chrome Pro Pipe 2-1, SE AC, TTS, Drago 580 cams, WO612 Outlawz, CM 21/17 Raiders, Monotubes -2 and 444's 11.5". Willie G Theme
SWIII, SWIV, SWV, SWVI & SWVII
mjsdouble is offline  
post #5 of 9 (permalink) Old 07-03-2013, 10:25 PM
Life Member
 
tdkkart's Avatar
 
Join Date: Jun 2011
Location: East Central Iowa
Posts: 3,035
Garage
Quote:
Originally Posted by lostboy792 View Post
I had same problem and it ended up i had all the terminals flipped 180 degrees in the connector. Be patient they will come back out but can be tricky.

Sent from Motorcycle.com Free App
Quote:
Originally Posted by mjsdouble View Post
This is where I had trouble too. If you put the pin in correctly you will hear it click into place. It will then be difficult to come out. Once you get the hang of one or two pins its a piece of cake. As has been said ... You might have to rotate the pin 180 degrees.

I did this too, the pins are likely backwards which prevents the whole connector housing from going back together properly.

2015 RGU CVO........under continuous change......
tdkkart is offline  
post #6 of 9 (permalink) Old 07-04-2013, 01:14 AM
Member
 
ammojeff's Avatar
 
Join Date: May 2013
Location: Utah
Posts: 690
I had the same problem. Pins kept twisting. Take it slow partially assemble the lock and red rubber seal and the pins will line up better. At least thats the way I remember it.

AMMO: Giving the enemy the opportunity to die for their country

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ammojeff is offline  
post #7 of 9 (permalink) Old 07-05-2013, 09:58 PM
Member
 
Join Date: Jun 2013
Location: Southern WV
Posts: 641
Garage
Glad I'm not the only one. Just had the same problem this afternoon and had a couple of pins 180* off. Helps to put the white plate in to the first notch to align the pins.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DuraGlide is offline  
post #8 of 9 (permalink) Old 07-08-2013, 09:32 PM
Newbie
 
Join Date: Sep 2012
Location: Austin, TX
Posts: 8
Quote:
Originally Posted by DuraGlide View Post
Glad I'm not the only one. Just had the same problem this afternoon and had a couple of pins 180* off. Helps to put the white plate in to the first notch to align the pins.
Exactly this. Once the plate is in, then put them through the gasket seal in order first. Then plug them into the connector with the white plate seated in loosely. I don't know how folks do it otherwise.
guitarslinger is offline  
post #9 of 9 (permalink) Old 07-09-2013, 08:57 AM
Newbie
 
Join Date: May 2013
Location: Nelsontucky OH
Posts: 48
Little tab on pins goes towards the center if I remember correctly.
As others have said, put the white plastic piece in only part way. It will click but you can tell it's not completely seated.
Then put your wires in, make sure all are straight and put in as far as possible.
Then push the white piece the rest of the way down until it clicks.

KO

2013 Road Glide Ultra Midnight Pearl
Torqueinc .510 Cam, Fullsac X-Pipe Header, Jackpot Muffs, Fuelmoto A/C, Dynojet P-Vision w Autotune
kiohio is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Best way to put Deutsch Connectors back together! 1BadGlide Controls & Handlebars 7 07-10-2013 08:50 PM
Back together after the Paint Job Wooden Nickel Paint & Bodywork Section 38 01-12-2012 11:48 AM
Finally back together! PICS!!!! Sedona Blue *General Road Glide Discussions/Pictures 60 11-11-2011 12:50 PM
Putting the puzzle back together! Sedona Blue *General Road Glide Discussions/Pictures 25 04-02-2011 07:49 AM
HD snap on lowers & HD snap on wind deflector ironmark Aftermarket Accessories 0 12-27-2010 09:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome