Handlebar/TBW assistance!?!? - Road Glide Forums
Controls & Handlebars Controls and Handlebars for Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-22-2011, 12:51 AM Thread Starter
Newbie
 
Join Date: Jun 2010
Location: Murrieta CA
Posts: 45
Handlebar/TBW assistance!?!?

First time ever doing anything like this. I just hope I didn't mess anything up.

In the process of changing out my bars. I ran both sides of wires through the bars and hooked everything back up (took my time and was very careful).

Did the first start up; "run" switch works, "start" switch works - bike starts up with no problem.

Problems:
-throttle does not work
-cruise control light stays on and flashes
-ABS light is on
-engine light is on

All seems to be issues related to the right side of the bars. left side controls work fine.

Am I screwed? Anyone have any ideas what can be wrong? Please advise.

Thanks.
ttlpakg is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-22-2011, 12:54 AM
Newbie
 
Osuno77's Avatar
 
Join Date: Nov 2010
Location: Huntsville, AL
Posts: 42
Sometimes in the line they break it and put a soildered joint into it. I saw this on mine when I just did them. There is a possibility that you broke that connection, or you frayed a wire. Unfortunatley there is only one way to check it, take them back out and visually inspect them and if you can, get a ohm meter. Run it from one end to the other to check to see if there is a break.

2007 XLC 1200 "Rosie"
2010 Vivid Black Road Glide "Clarice"

Last edited by Osuno77; 01-22-2011 at 03:54 AM.
Osuno77 is offline  
post #3 of 8 (permalink) Old 01-22-2011, 09:53 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,519
Your engine light is on so that means the bike has DTC codes stored in the computer . You will have to clear the codes and then see if you have DTC codes show up again . Doing the wires you had to disconnect the TBW harness and your bike may have seen this as a TBW malfunction and the computer put the bike into limp home mode by disabling the throttle .


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
 
post #4 of 8 (permalink) Old 01-22-2011, 04:04 PM
Newbie
 
bvette94's Avatar
 
Join Date: Jan 2011
Location: Westland Mi
Posts: 28
Did you cut and splice the throttle by wire control or force all the wires in the handle bars without eliminating the green plug. if you squeezed them all in with the plug they probably came un plugged. (ask me how i know) lol. also check the plugs at the end and make sure the colors match up. it is possible you could have a few swapped . if thats the case it is an easy fix. just swap the wires and you should be back in business. fyi harley makes a tbw that has additional inches on it that has no plug in the center. I believe the part number is 32310-08. that way you arent second guessing your splice. last piece of advise pull off the factory black sleve and put a piece of heat shrink in its place and shrink it down. makes fishing the wires a little easier. also make sure there is enough coverage so they dont chafe from vibration where they enter and exit the bars.
bvette94 is offline  
post #5 of 8 (permalink) Old 01-22-2011, 09:37 PM Thread Starter
Newbie
 
Join Date: Jun 2010
Location: Murrieta CA
Posts: 45
thanks gents. appreciate the advise.
after looking back through everything, i think i pulled a little too hard and disconnected the green plug. i went ahead and picked up another one from HD.

how do i get rid of the engine light though??
ttlpakg is offline  
post #6 of 8 (permalink) Old 01-22-2011, 10:31 PM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,519
YOU need too clear .the code on our bike . I posted the info you need under the troubleshooting section


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #7 of 8 (permalink) Old 01-23-2011, 03:19 PM Thread Starter
Newbie
 
Join Date: Jun 2010
Location: Murrieta CA
Posts: 45
ironmike,
thanks.
just finished the install and everything works. soon as i put everything back together, I'll post some pics.

one thing though - my ABS light keeps blinking; is there any fix for this??
ttlpakg is offline  
post #8 of 8 (permalink) Old 01-23-2011, 04:13 PM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
It will always blink until your moving at least 5-7 mph. If it continues to blink once your riding down the street at normal speeds, then you have a problem.






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock green TBW to CVO TBW? hd4cruzin Controls & Handlebars 12 02-17-2018 11:34 AM
Handlebars TBW to non-TBW HelzBelz Controls & Handlebars 3 10-17-2016 09:47 PM
TBW vs. Pre-TBW Halstem1 Controls & Handlebars 7 12-18-2013 01:13 PM
Need Assistance xusnatc Troubleshooting for Road Glides 20 08-19-2010 04:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome