Blinkers not working?? - Road Glide Forums
Controls & Handlebars Controls and Handlebars for Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-27-2013, 07:31 PM Thread Starter
Newbie
 
Join Date: Jul 2013
Location: Mid GA
Posts: 29
Blinkers not working??

I installed new bars and had the front & rear light bezels powder coated and now the blinkers don't work. The rear stays bright constantly (and won't blink) and the front wont blink either (one won't light up at all). The indicators work on the dash and all other handlebar controls work fine. Need help please!!!


Sent from Motorcycle.com Free App
Bodawg1 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-03-2013, 02:59 AM
Newbie
 
SBR_GUY's Avatar
 
Join Date: May 2013
Location: Las Vegas
Posts: 45
Did you run the wires internal? If so I would start there. Also Did you do the powder coat and the bars at the same time? If not did the lights work before the powder coat? If they did it maybe a ground issue. If not then check your wire splices for the bar install.

The difference between you and me, is I run towards gunfire.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SBR_GUY is offline  
post #3 of 7 (permalink) Old 09-03-2013, 09:16 AM
Life Member
 
laxinharley's Avatar
 
Join Date: Aug 2011
Location: East Hartford, Connecticut
Posts: 3,430
Are the rears bright because the brake lights our on constantly. If so you may have broke the brake switch. Just a thought.

"A zest for living must include a willingness to die."
laxinharley is offline  
 
post #4 of 7 (permalink) Old 09-04-2013, 09:06 PM
Member
 
garbage cannon's Avatar
 
Join Date: Aug 2011
Location: On the southern shore of Lake Arthur of Moraine State Park. About 40 miles north of Pittsburgh
Posts: 478
I just changed the bars yesterday and then my brake light is stuck on. I disassembled the controls on that side and the switch wasn't being engaged correctly. I put it back together now it's intermittent. Maybe your switch is stuck out too.

Sent from Motorcycle.com Free App

It's funny how we keep expecting leaders from a system that rewards weasels.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
garbage cannon is offline  
post #5 of 7 (permalink) Old 09-04-2013, 09:10 PM
Life Member
 
Mike U's Avatar
 
Join Date: Aug 2012
Location: New York
Posts: 5,753
If you ran your wires through the handlebars check to make sure that you replaced the wiring in the harness properly.
Best of Luck!
Mike U.

USMC 1975-1977
Semper Fi!
Nothing else matters!
Mike U is offline  
post #6 of 7 (permalink) Old 09-05-2013, 08:01 AM
Grey beard
 
Phantom6722's Avatar
 
Join Date: May 2012
Location: Main Residence Perth Western Australia, Secondary Varna Bulgaria, Satellite Houston
Posts: 1,379
Garage
Blinkers constantly on usually means a bad or open earth connection. I would undo all your connections again check for correct wiring and make sure all earth connections are tight.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Cheers Skip
Veritas Vos Liberabit{the truth shall set you free}
Phantom6722 is offline  
post #7 of 7 (permalink) Old 09-05-2013, 09:34 AM
Life Member
 
Join Date: Jun 2012
Location: Pac NW
Posts: 4,092
What ever you do- don't get water in them
reds4 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Neutral light on cruise not working and gear indicator not showing Xman247 Tools and Garages 7 08-11-2018 11:09 AM
Blinkers not working?? Bodawg1 Troubleshooting for Road Glides 0 08-28-2013 07:56 AM
Blinkers Stopped Flashing Double0 Troubleshooting for Road Glides 2 09-25-2012 06:08 AM
arlen ness blinkers drmudd Lighting 15 02-14-2012 03:25 PM
blinkers Graybone32 General Off-Topic Discussions 2 01-16-2012 09:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome