Brake like doesn't work - Road Glide Forums
Lighting Lighting for Road Gildes

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 06-07-2017, 04:27 PM Thread Starter
Grey beard
 
Join Date: Oct 2013
Posts: 1,174
Brake light doesn't work

So, 2 months ago I noticed my left rear turn signal doesn't turn on or and doesn't blink when turning. Thought the bulb blew, so I bought a replacement and it still doesn't work. My cousin told me today to check behind the taillight and see if it's still plugged in. It is, but then while testing the brakes I learned that my actual brake light doesn't turn on. My right rear blinker light works perfectly, when used as a turn signal and using the brakes.

Last time I can say they did work was prior to me installing my air ride last year. I don't ride a lot because Belgium weather is terrible and I am constantly gone for work, so I rode maybe 10-15 times since 2015.

2007 RG FLTR

Last edited by dinggus; 06-08-2017 at 04:25 PM.
dinggus is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 06-07-2017, 05:04 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,186
Garage
Quote:
Originally Posted by dinggus View Post
So, 2 months ago I noticed my left rear turn signal doesn't turn on or and doesn't blink when turning. Thought the bulb blew, so I bought a replacement and it still doesn't work. My cousin told me today to check behind the taillight and see if it's still plugged in. It is, but then while testing the brakes I learned that my actual brake light doesn't turn on. My right rear blinker light works perfectly, when used as a turn signal and using the brakes.

Last time I can say they did work was prior to me installing my air ride last year. I don't ride a lot because Belgium weather is terrible and I am constantly gone for work, so I rode maybe 10-15 times since 2015.
To you have stock lights or fancy lights with a AF module?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #3 of 14 (permalink) Old 06-07-2017, 05:27 PM Thread Starter
Grey beard
 
Join Date: Oct 2013
Posts: 1,174
Quote:
Originally Posted by Big_gary View Post
To you have stock lights or fancy lights with a AF module?
Headlights are Day Makers. Just installed CD Turn Signals up front. Rear are all stock.

2007 RG FLTR
dinggus is offline  
 
post #4 of 14 (permalink) Old 06-07-2017, 05:32 PM
Member
 
RD-GLIDER's Avatar
 
Join Date: Jan 2011
Location: Brooksville Fl.
Posts: 624
Do you have a brake tail light module in line they can go bad with some weird symptoms


Sent from my iPad using Tapatalk
RD-GLIDER is offline  
post #5 of 14 (permalink) Old 06-07-2017, 06:41 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,186
Garage
Quote:
Originally Posted by dinggus View Post
Headlights are Day Makers. Just installed CD Turn Signals up front. Rear are all stock.
I'd disconnect the CD turn signal module and see what happens. Head lights are not in play.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #6 of 14 (permalink) Old 06-08-2017, 12:35 AM Thread Starter
Grey beard
 
Join Date: Oct 2013
Posts: 1,174
Quote:
Originally Posted by RD-GLIDER View Post
Do you have a brake tail light module in line they can go bad with some weird symptoms


Sent from my iPad using Tapatalk
I shouldn't, never played with the lights before.

Quote:
Originally Posted by Big_gary View Post
I'd disconnect the CD turn signal module and see what happens. Head lights are not in play.
I don't have a signal module. I just know that the left rear blinker didn't work prior to me ever changing out the front turn signals.

2007 RG FLTR
dinggus is offline  
post #7 of 14 (permalink) Old 06-08-2017, 12:07 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,186
Garage
Quote:
Originally Posted by dinggus View Post
I shouldn't, never played with the lights before.



I don't have a signal module. I just know that the left rear blinker didn't work prior to me ever changing out the front turn signals.
I thought the CD lights used a module pre-Rushmore ?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #8 of 14 (permalink) Old 06-08-2017, 12:15 PM Thread Starter
Grey beard
 
Join Date: Oct 2013
Posts: 1,174
Quote:
Originally Posted by Big_gary View Post
I thought the CD lights used a module pre-Rushmore ?
The module is only needed if I didn't like the rapid flashing lights.

But, my left rear turn signal stopped working prior to me even installing the CD lights.

I just learned that my running light works now, don't know what I did but as I stored it in the garage, I noticed the license plate window was lit up so I checked. Does that light not get bright when engaging the brakes?

2007 RG FLTR
dinggus is offline  
post #9 of 14 (permalink) Old 06-08-2017, 03:58 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,186
Garage
Quote:
Originally Posted by dinggus View Post
The module is only needed if I didn't like the rapid flashing lights.

But, my left rear turn signal stopped working prior to me even installing the CD lights.

I just learned that my running light works now, don't know what I did but as I stored it in the garage, I noticed the license plate window was lit up so I checked. Does that light not get bright when engaging the brakes?
I don't think so. I'll bet you pinched a wire whill using /installing your Air ride.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #10 of 14 (permalink) Old 06-08-2017, 04:25 PM Thread Starter
Grey beard
 
Join Date: Oct 2013
Posts: 1,174
Quote:
Originally Posted by Big_gary View Post
I don't think so. I'll bet you pinched a wire whill using /installing your Air ride.
Guess I'll have to go through the wiring again. I looked under the fender to see if I ever rubbed the wiring harness due to sitting lower than stock but doesn't look like it.

2007 RG FLTR
dinggus is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stereo doesn't work harlydavdsn Audio 7 06-22-2016 06:08 PM
cruise doesn't work firefighterkp Troubleshooting for Road Glides 10 08-23-2013 03:26 PM
New Clutch Cable USED to Work, Now Doesn't adam_twenty6 Controls & Handlebars 9 02-27-2013 10:50 PM
Forum Google search doesn't work on Android cypress General Off-Topic Discussions 3 07-17-2012 03:25 PM
Throttle doesn't work on an '11 FLTRX twr05 Troubleshooting for Road Glides 12 03-19-2011 08:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome