Hi/Low beam at same time on Rushmore? - Road Glide Forums
Lighting Lighting for Road Gildes

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-27-2017, 12:52 PM Thread Starter
Hangaround
 
wheredugo's Avatar
 
Join Date: Nov 2016
Location: New Haven, CT
Posts: 69
Hi/Low beam at same time on Rushmore?

Has anyone figured out a way to turn on the hi and low beam at the same time ? Is there a harness available? or some way to do it thru the canbus system ?
wheredugo is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-27-2017, 02:21 PM
Hangaround
 
Join Date: Feb 2015
Location: Acton, CA
Posts: 132
Hmm... On my 2015, both low and high stay on at the same time when I have the high beams on. Came that way from factory. I see the same on other Road Glides around here. That is odd. Perhaps have it checked out if still under warranty.

2015 Road Glide Special

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
caberto is offline  
post #3 of 6 (permalink) Old 09-27-2017, 02:33 PM
Life Member
 
twowheeladdict's Avatar
 
Join Date: Feb 2016
Location: Tennessee
Posts: 3,660
I just walked out to the garage and confirmed that the low beam stays on all the time. Whether the high beam is on or not.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2018 Road Glide Special, 2018 Moto Guzzi V7III Carbon, 2019 Royal Enfield Himalayan, 2017 Suzuki Van Van 200

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
twowheeladdict is offline  
 
post #4 of 6 (permalink) Old 09-27-2017, 03:42 PM Thread Starter
Hangaround
 
wheredugo's Avatar
 
Join Date: Nov 2016
Location: New Haven, CT
Posts: 69
Ok maybe im just an idiot and assumed one shut off. Disregard post ! Im sorry ! I thought the low beam shut off when the high beam fired.
wheredugo is offline  
post #5 of 6 (permalink) Old 09-27-2017, 03:45 PM
Grey beard
 
UT_Larry's Avatar
 
Join Date: Sep 2015
Location: West Valley City, Utah
Posts: 927
Garage
If low is turning off with high beam on it's not functioning correctly. I recall a previous thread & headlight was replaced under warranty.

2015 FLTRX Road Glide. Vivid Black.
UT_Larry is offline  
post #6 of 6 (permalink) Old 09-27-2017, 05:33 PM
Life Member
 
twowheeladdict's Avatar
 
Join Date: Feb 2016
Location: Tennessee
Posts: 3,660
Quote:
Originally Posted by wheredugo View Post
Ok maybe im just an idiot and assumed one shut off. Disregard post ! Im sorry ! I thought the low beam shut off when the high beam fired.
Did you actually look at the headlights? No problems man. We are here to help.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2018 Road Glide Special, 2018 Moto Guzzi V7III Carbon, 2019 Royal Enfield Himalayan, 2017 Suzuki Van Van 200

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
twowheeladdict is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Low/High beam testing sanity check? Driftah Lighting 2 07-17-2013 06:18 PM
Rewiring Bright/Low switch so you can hit brites and horn at same time DC-3Mek Do-IT-Yourself 39 06-02-2013 05:57 PM
Daymaker light pictures (low Beam) txflyer Lighting 8 05-28-2013 11:18 PM
HID High Beam Low Beam Fit EasternSP Lighting 9 09-29-2012 01:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome